How to merge .TLK files? (CEP 2.67 with PRC 4.1.5)

Was wondering if there is a way, be it an program, or editing manually say via NotePad++, Excel, etc. to merge .TLK files? I realize CEP 2.67 really needs it’s own .TLK file, or the CEP 2 TLK file, but PRC comes with it’s own .TLK file too. Would like to take the time to merge the two for use for any module using CEP 2, mainly 2.67. This might be a huge undertaking, but maybe some could help me out as well if I upload the file periodically here or say from Google Drive. I noticed without the proper .TLK file, CEP within the module editor has missing blueprints on the right side, even after I import the proper .ERF files I know have worked fine in the past. :frowning: This is another reason why I think merging .TLK files will fix the problem.

Any help, documentation, links, or expertise shared is greatly appreciated. Thanks!

1 Like

EDIT - The PRC manual says

1 Like

I have indeed done this, but were do the merged files created go? Do they overwrite original haks or do you have to locate them and install them manually via the Hak list under custom content? Also even when I did this properly the blueprint , Iist of all CEP content is gone or incorrectly displayed. Many empty spaces and the list itself changes to the default standard list. Like for example, the “civilization exterior” a CEP custom addition to the blueprint list under the custom tab is completely gone as we as others. I’ll take screen shots in a bit and post them here. That is the major problem I’m having it seems. I did read the documentation, in a few places. Just seems like a bug or glitch maybe somewhere. Could it be specific CEP 2 haks that are optional, that could be causing it? I also noticed upon opening the module PCR was installed to, the PRC tlk file is listed instead of the blank spot left from before as instructed, does the installation merge the CEP tlk and PRC into the PRC?

The PRC team, or PRC users, would have to answer that, if the manual provides no further help.

Maybe. The issue is also CEP related so I’d have to ask them as well, and I did send a message to PRC about the problem before I came here. Never hurts to ask incase somebody else has run into a problem such as this. Another issue, is the proper HAK and TLK files are not being created after the install and merge. I’ve tried multiple scenarios, with and without CEP, and making sure the files I have are the most updated, and that the module is freshly created. The issue is, with Steam’s version of PRC, you have to install it manually via the custom folder it creates when downloaded from the workshop. However, it does not include an EXE file to install to a module, this you must download from the PRC website itself. I even saw a few posts elsewhere, one on Beamdog’s forum, that you may need to leave the TLK filled under custom content empty, before saving otherwise you may get errors, be it a crash, access violation, or other. I’ve tried with and without a TLK, be it CEP’s or PRC’s, and it seems crashes occur with a TLK in the field, but without it, they do not. The PRC manual on the website does not mention this at all. Could be that it is outdated, could be a CEP issue, or a EE issue as it happened without CEP as well.

My guess is that the HAK and TLK files not created in the proper folders when the installation occurs and is to supposedly automatically merge files, are the main cause, and it would also explain why the blueprints on the right side menu within the toolset look odd or are missing sections completely. Without being able to fix them as stated in the manual, and then import them, obvious blueprint problems occur. The later part of the PRC manual does explain an issue they have with basetems.2DA, and it may help once I’ve given it a shot, but I would still require the missing HAK and TLK files not created to go further. I even used admin privilege’s to ensure it was not a issue of that sort, but it still had problems. I’m hoping it is not a issue with how steam installs their games, or that the new EE has most the folders required, in Documents, rather then the games root folder like Diamond did.

I guess I’ll keep trying, and if I come up with a solution, I’ll post it here incase others run into the same problem. :smiley:

I’m the leader of the CEP 2 team, so you just did. :slightly_smiling_face:

PRC is designed to install on top of CEP 2, so, in the first instance, if install fails, it’s a PRC issue.

We would be happy to help the PRC team if they thought some change to CEP 2 had caused them a problem, but nothing of that sort has been referred to us recently.

P.S. When you mention Steam Workshop, alarm bells ring. I guess you read the instructions on that page about moving the files out of the Steam Workshop folder into Documents? Same applies to the CEP 2 files.

1 Like

Ok, good to know. :slight_smile:

I think PRC installed fine, I can use it in game, no errors of any kind so far, and it seems scripts are setup properly within the module events tab. The issue I am having as I think I figured out how to merge TLK files myself, is this one here in the aurora toolset:

This is what is happening to the custom blueprint list that comes with CEP 2. It is fine prior to this after I import the proper erf file, but after PRC installs, this happens:

I cannot seem to fix this issue, and many sub categories are also blank, or items are in places they should not be, regardless what ways I install the PRC. I do exactly what the manual says, and still this is the result. I’ve tried this with the CEP 2.65, 2.66, and finally with 2.67. All do the same thing within the toolset.

Another problem I am facing, is that the proper HAK and TLK merge files are not being created at all. I then decided to use a program a commenter above linked, and it seems to work when I create a TLK file. But it is the baseitem.2da’s and the PRC 2da’s that need to be worked with to get the extra two HAK and TLK files to work properly in theory. But of course, without them automatically generated, I cannot go any further on that part. I want to be sure the files are created properly before I got messing with them, the TLK file being just a test at this point by me merging my own.

Maybe it is a bug with the newest EE updates. Hopefully I can get an answer from the PRC team as I would really like to use this in my module.

Could it also be by chance, a 2DA override issue? Like say if any override in the folder for in game, could possibly mess with the toolset as well?

I have pre-made PRC / CEP2 merges (as well as tons of modules) available on the PRC Discord.

1 Like

You do? Even the needed Hak Paks? I have a custom setup with CEP 2.67. Idk if they will work with mine? Were should look on the PRC discord? I’ll go check now. :slight_smile:

I’ve made merge tlks and haks for that version. Ask in the #module channel.

1 Like

I this isn’t too bothersome, but do you have the merge files on another site? When I tried the discord it wanted to text me, and I don’t have a cell phone.

Here you go.