How to prevent henchman getting too close in cutscene (Solved)

Eventually solved this thanks to an extra trigger and Script Generator - what a resouce !

Quick question for anyone with a knowledge of the Gestalt system for cutscenes - or maybe scripting in general ?

I have a cutscene where the henchman closes in behind the PC thereby blocking the PC from view. I’m using Gestalt Camera track with the camera facing a third object they are walking towards and will speak with. It is complicated as they are walking up a slight hill so I have to change the tilt of the camera on the way.

I’ve tried setting start and finish WPs for the henchie but these are ignored.
I’ve tried delaying the start of the henchie’s walk till near the end of the conversation but that is ignored.
I can’t find an option which tells the henchie to stay where he is until the end of the cutscene, then come running up.

There is an option in Gestalt to make associates invisible for the duration when you start the cutscene.

Thanks, Proleric.

I’m assuming that’s GestaltClearAssociates. I would like to just turn them invisible for the duration of the cutscene.

Will try tonight. That’s a lot cleaner than my trigger solution.