How to re-install the Toolset?

How do I re-install the NWN Toolset? Mine has started really behaving poorly. It crashes if I leave it open while I start the game. And, now I see that some of the custom palettes are populated incorrectly. E.g., from a module with lots of custom items, the Custom Item palette is


Notice that that is the Custom Merchant palette, even though I have Items clicked and the Standard tab shows the standard Bioware items.

Anyway, is there a link for an installer I can use to re-install the Toolset? Do I have to uninstall and then re-install the whole game? I’d prefer not to do the latter, but I will if it’s the only way to get the Toolset functioning again.

BTW, I am using the Beamdog client and do not have Steam at all.

Have you tried the following?

  1. Open the BD client.
  2. Click on options
  3. click on Verify Game

This will start the verification process which should redownload anything that is broken.

TR

I have tried that before and just did it again, to be double sure. It checks the 6 GB of files. I don’t recall whether it downloaded any to replace the ones here. Either way, the Toolset (mis)behaves the same way when I open it. E.g., if I open a test module, open the game, then come back to the Toolset, it is locked up. If I wait long enough, it responds, but it is pretty seriously hosed by that point. Areas in the area list that weren’t open before starting the game have nothing in them (not even empty lists of Doors, Encounters, Merchants, etc.).

Anyway, I think I need a full reinstall of the Toolset and I am still not sure how to do that.

BTW, is what I have the current version?

vts80 is the latest version of the toolset.

I had this issue once before and I resolved it by deleting the offending copy of the toolset and then running “verify files”. With Steam, if it detects the file exists and the meta data (or checksum) matches, it will not overwrite it as Steam has no way to detect if the offending file has been corrupted. Maybe the Beamdog Client works the same.

Also, if you are using F9 to test your module from the toolset, STOP. While this works for me, many other users have reported issues with using F9.

1 Like

So, one problem is resolved. The lack of Custom Item palette items was apparently an issue that my module was corrupted somehow. A slightly older version works okay.

The problem that still persists is that running the game while the Toolset is open completely munges the Toolset. It’s essentially unusable after that. There is uber (e.g. over a minute) lag between Alt-tabbing from the game to the Toolset even being responsive. The area lists are unpopulated (Creatures, Merchants, Encounters, etc. are missing). Etc.

I do not run the module from F9. I start the game client separately.

I did try deleting the Toolset executable and running verify from within the Beamdog client. It replaced the Toolset, but the problem described above persists. Basically, I have to make whatever changes I need in the module, close the Toolset, open the module in the game client, test, then close the client and re-open the Toolset to make the next change. Since most of what I do in the Toolset is scripting, where debugging requires pretty frequent testing in the module, this is a pretty huge bottleneck. :frowning:

Beyond me, time to get the experts involved, i.e. file a bug report on Github.

hi MrZork,

i, too, have run into many problems with the toolset, and found that, ultimately, they weren’t caused by the toolset at all. sometimes the module itself, and its associated hak files, can cause all sorts of strangeness in the toolset. the following approach has worked for me in the past :

  1. try repeating whatever actions you usually take, but with a completely blank module of only 1 area [i.e., in the toolset, create a new module, and before you populate it, run it and see if the toolset still runs off to tea w/rod serling].
  2. if that works, try doing the same thing with a ‘known-good’ module, such as one of the official campaigns.
  3. if that works correctly, try making a copy of your module, removing any hak-dependent content and any haks listed in the module properties, rebuild, and re-run. if it works correctly, then one of the elements in your haks is causing the problem.

if the above fails even at step one, there could be a more systemic reason. for example :

  1. have you changed your graphics card recently ? i’ve had no end of non-
    display-related toolset headaches still caused by display drivers.
  2. have you recently installed anything that updated your .net or c++ runtime libraries ? [since you’re using nwn:ee and not 1.69, this is really a longshot because normally ee would also be up-to-date, but …]. you can see this if you go into control panel -> programs and features and click on the ‘installed on’ tab at the top, which will sort the list by install date, then look for, for example, ‘microsoft visual c++ xxx redistributable’ or ‘microsoft .net framework xxx’. if it turns out to be the case, you could try uninstalling whatever you installed after nwn and see if that clears up the problem.

if none of that works, you might want to try a clean re-install.

1 Like

Thanks for that advice. But, I haven’t had luck with it, so far.

I have tried opening a minimal module and then testing. For example, the screenshot below
image
is from the “CEP - Starter 265” module that comes with CEP. It has only one area. I opened it in the Toolset, then opened the game, did nothing in the game (didn’t open a module, didn’t go to a PW, etc.) and closed the game. When I go back to the Toolset, the above is what I see. As you can see, the area list has only the one area and it is completely empty (not even the headers for Merchants, Encounters, etc.).

I tried the same thing with a (non-CEP) blank module with one area and painted a single encounter and one chest in it. I saved the module, opened NWN, closed NWN, and now the Toolset has been nonresponsive for about two minutes.

I haven’t changed hardware in a long time. I think that the last time I updated display drivers was actually after I first started noticing this Toolset issue.

Looking at changes to the the C++ runtime libraries is a good thought. Unfortunately, in the middle of August, I upgraded my Windows 7 machine to Windows 10 and that spawned a ton of software updates and re-installations, including Microsoft Visual C++ Redistributable for 2013 and 2015 (for both x86 and x64). I have no idea which of those might be connected to this Toolset issue.

I do see (at https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads) that there may be newer files for Visual C++. I don’t know if installing the 2019 packages would be helpful here or not.

BEFORE trying what I suggest below, I still maintain that the BEST choice to resolve this is to post a copy of a NEWLY MADE module with no CC applied to the Git Issues Repository so the DEV Team can look into this. It is most likely the ONLY way this issue will be accurately resolved for you. Also include screenshots if you can of error messages, etc.

The Git Issues can be found here - https://github.com/Beamdog/nwn-issues/


Update Visual C++ and NET Framework to the latest versions.

According to my system, I have the following Visual C++ installed: 2008, 2010, 2012, 2013, and 2015-2019. For NET Framework I have 2.0, 3.0, 4.0, and 4.5+.

I run Windows 10 on an AMD CPU with a Radeon GPU. I have no issues with the toolset or the game. I’m not sure what versions of Visual C++ and NET Framework it requires but hopefully you can glean some info from what I posted above.

So we’re reporting issues to github now? Rather than the Beamdog Service Desk site?

Yes have been for awhile. Github is a more direct route to the Dev Team.

Little suspect about the “they ignore 99%” claim. They’ve currently got 98 open issues and have closed 107.

(Edited to supply some context)