How to stop seeing into next room tileset

I’m frustrated. How does one set a tileset where your PC’s can’t see what’s in the next room? Sometimes they cheat and just use some magic (i.e. I have a magic rope item) that allows the PC to move up to a ridge)…they use that to go through a thin part of a cave complex wall to go into the next room.

So:

  1. Is there a way to stop the PC looking into what’s in the next room as most of my tilesets allow you to see that.

  2. How do you stop jumping through walls or past portcullis doors for example

You can use invisible placeables to block movement in some circumstances. In others, where the player is exploiting a limitation of the engine, I’d probably engineer suitable unwanted results. For example, if they enter a room through a wall, you can catch that by placing a trigger just inside the doorway, and using that to put a local variable on the player. Then, place a trigger that covers the entire room, except for the area directly in front of the doorway. That way, when they enter the room without coming through the doorway, you’ll know it by checking for the variable when they step into the larger trigger. Then, make bad things happen to them! :slight_smile: Such as “Oh no, as you were trying to wedge yourself through a small gap in the wall, you slipped and fell into the room, landing awkwardly on your <item/weapon/whatever>! You not only broke the item, but you’ve suffered severe injury and will probably die and turn to dust in here, forgotten and alone, an utterly forsaken soul lost to the ages. Oh well. Probably should’ve just used the door.”
Or some such. LOL.

As for seeing into adjacent rooms, I think an inverted black one-side box (so you can see ‘out’ but not ‘in’ could be made and placed over important rooms to prevent that from happening. Not sure I’ve seen that anywhere though…

JFK

Thanks JFK. I remember you from years ago. It’s nice to see a familiar name. Creative ideas but lots of work to implement…sigh…but thanks. I appreciate your knowledge. Too bad the tileset walls for the caves I use can’t be solid. I also hate the new NWN:EE where when you walk by an placeable or building or hill, etc it turns transparent…hate that feature…wish we could turn it off.

1 Like

If you’re talking about “keyholing”, you can turn that off. CTRL+SHIFT+F12, then CONFIG, then search for Keyholing.

If not keyholing, I haven’t noticed what you describe. Can you elaborate?

I think he’s referring to a pw. Keyholing is client-side controlled, isn’t it? Or is there a way to disable it for the server?

JFK

Of course I remember you too, Imtherealthing!

Yes I was referring to the keyholing…hate it. Thanks for telling me how to disable it. But the part where you say “then CONFIG”…i got lost there…lol.

How or where do you do the “CONFIG”? I’m sure I look stupid…lol…but I am struggling to see how to do that.

Nice to know you remember me too bud. Been a few years. :slight_smile: …Yes if I could disable the “keyholing” on the server that would be great. My NWN skill sets are super rusty. I remember you were very helpful back in the day when I was on the CCP…then I was helping Barry on the CEP.

Does this thread help with the original question?

As for keyholing, in game, Ctrl+Shift+F12, select Config, scroll down to graphics.keyholing.

You can also do it IG via the Options menu:
Controls -> Change Key Settings -> Misc. -> Enable Keyhole Dissolve -> I gave it the K on the keyboard.

Thanks BlackRider that solution worked!
But I get this bar along the top left that has this stuff:

Resman \ Net \ Config \ Steam

If I hit ESC it does nothing. How do you get rid of that in game?

Thanks Proleric

I tried that…it did not work for me. It took a pic. I think you meant: Ctrl+Alt+F12…but that still did not work

Your way only had me take a pic of my screen

Black Rider’s way worked though

Still thanks for offering to help :slight_smile:

@Imtherealthing from the official announcement in December :

If that’s not working for you, update your copy of EE.

Separate question - did the link I posted above help at all?

Oh Proleric…I just noticed the link…thanks man…I feel so stupid. I will go check it out and let you know,

Update my EE? I’m with GOG not Steam…stupid GOG does not give us updates like STEAM does.

Ok I read it…I sort of understand what you said there. I am no scripter nor know how to add “variables” on how to prevent PC’s from seeing into the next room. One guy in response to that thread said if one is using a custom tileset that we should ensure that on the Advanced tab to set it to “interior”. I checked mine was and to “underground” too for my cave tileset. Still I and the PC’s can see into the next room. It sucks. I remember when you couldn’t see what was in the next room. You know how to fix this or is this something EE might fix later on?

Also…I tried to update NWN:EE on GOG (went to check) don’t even know where to do that, but from what I have read…STEAM is really like 4 patches ahead of GOG (well Beta testing patches).

I am also frustrated…BlackRider’s suggestion fixed the Keyholing issue but now I get this stupid set of commands (Resman \ Net \ Config \ Steam) top left corner that won’t go away. Do you happen to know what key shuts this off?

Thanks for your help…I remember you too from back in the old days.

I found I have the version 79.8193.5

When I try to update it…it says…“Loading”…been doing this now for 10 min…nothing.

Ah…found out how to toggle that annoying top left bar off. No worries now.

Still wish as per this topic that I could find out how to not allow the PC’s to view what’s in the next room.