I have a problem reloading savegame of Prelude edited with the Toolset

I took original campaign’s Prelude.nwm, renamed it to Prelude.mod.
I used this file through the Toolset, I modified it, I loaded the necessary CEP3 hak in the module by inserting them in Edit>Module Properties>Custom Content as I should have done.
I also tried copying my Prelude’s .ncs scripts from Temp0 to override, but it didn’t help. (But maybe on this I could have done better, I’m not sure I really did well in this last step).
I used both the scripts of the modified module by me, both the scripts of the original Prelude, and the scripts of a new module completely disconnected and different from the modified Prelude and the original Prelude. None of the three options worked, but again, I’m not sure I’ve done these steps correctly.

I am using NWNEE v82.8193.20.1 [7cb918c9]

The problem I can’t solve is that when I enter the game in that modified Prelude, I save a game, then I try to reload it and the loading screen freezes.
The game allows me to start the new game in modified Prelude, but when I save and reload the game, the loading never completes even though the loading bar is full.
I also tried taking the Prelude.sav save file from the Neverwinter Nights/save folder, renaming the .sav file to .mod, but the Toolset doesn’t open it.
Please help me. I’ve spent the last 12 days editing a lot of things in that module, but if I can’t load the games I save, the work I’ve done is completely useless.

If you’re putting it back as a nwm file that may be missing some header or other. It’s not something I’d recommend. Instead just run it as a normal mod file.

1 Like

I’m doing as you suggested, I tried both to use the Build> Test Module F9 command, and to close the Toolset (once even without closing it) and then start a new game manually and enter my module. Also the modified Prelude is not even called Prelude anymore, I renamed it trying to see if it worked, nothing.
At that point I loaded the Prelude and edited the scripts through the Toolset, from the Scripts Palette, I copied the scripts used by the module, exactly identical, in a file renamed by me. It did not work.
So I took and created a new module, completely different from Prelude, without hak, without creating any objects and no creatures, just the ground, I saved it and selected Test Module. I enter the game, save the game, I try to reload, again no loading. What the hell can it be?

I just noticed something even more absurd. I enter NWN, new game, I enter the original prelude, i save a new game, I try to reload, the loading stops.

Ok, I was using a non-original prelude, I was convinced it was the original but it wasn’t, luckily I didn’t break anything

I just checked the area related scripts, both my Prelude and Prelude OC match each other

So if you are playing a .MOD file then the .SAV it creates is basically a copy of the .MOD so it will never load changes made in the .MOD later.

If you are playing a .NWM file then the .SAV has different information - it contains only the changed (instanced) parts of areas, eg creatures, encounters states and some other things (Stores, items, etc.). This means if the NWM is changed it can load those changes, eg a script is altered it’ll use that new script. Bioware used this to (carefully) patch things, mainly script changes since if an area changed the players may suddenly find themselves loading into the void.

I don’t think any modders have used NWM files since they’re pretty hard to get loaded by the game and are not well documented or tested.

I’m not entirely sure what you are doing or attempting to do but hopefully the above gives a good overview.

1 Like

By doing several tests I was able to understand with certainty that the real problem causing this upload crash are the hak files of CEP3 4.1.5.
When I start Prelude without adding hak files to Module Properties, a video starts playing, the opening video before being spawned in the Senior Barracks area. While if I insert any type of CEP3 hak file that video does not start and when I save the game and reload it, the loading stops.
I tried using nwhak.exe to extract the resources and files from the haks and package them again in a new hak, but I encountered the same problem loading the game save.

Basically what I would like to do is just be able to start the game using the style and appearances of some weapons and armor I created using CEP3. I also created a mount creature using Proleric’s guide (Builder's Guide to Horses & Creature Scaling - NWN Lexicon).
If I start the game without the haks files in Module Properties, the armor, weapons and creature do not display correctly, or do not display at all.

The problem is only this: to be able to view the objects and the creature according to the style of CEP3, while maintaining the possibility of saving the game and reloading it.
Do you have any ideas on how I can fix it? Should I perhaps extract certain specific files from the CEP3 haks and package them in a new hak or place those extracted files in the override folder?