I'm unable to play NWN2 due to error message

I’ve had Neverwinter Nights 2 for years, and it’s worked that whole time, but after restoring my computer to factory settings and redownloading NWN2, I now get this message:

"This application is not compatible with the installed operation system. Please upgrade to Windows 98SE, Windows 2000 or better."

Is there anything I can do to fix that issue? I’d really like to play Neverwinter Nights 2 again.

Have you tried to run the game in Windows XP compatibility mode?

  1. Right-click the NWN2 desktop shortcut or .exe file and click «Properties».
  2. Go to the «Compatibility» tab.
  3. Check the box for «Run this program in compatibility mode for» and select «Windows XP (Service Pack 3)» from the drop-down menu. Click «Apply» and choose «OK».

I just did that and the same message still pops up. :\

try reinstalling Dx9.0c Redistributable from M$ (even if there’s already a higher version installed – they coexist, and nwn2 needs specific files in 9c)

1 Like

I won’t make a nightmare of this, but if you have the newest version of Windows 10 it may very well be that older applications won’t run anymore. I stick to Windows 10 version 1607 as long as I can because of this, but I will probably upgrade to Windows 7 this summer (my computer originally came with Windows 7, and I think I’ll revert to that for my gaming needs, and then I’ll have to purchase a new minimum-spec’ed PC to surf the internet and so on in addition). Also, you can contact your vendor (mine is GOG) if they are planning on updating the game so that it will run in Windows 10 of 2018. As I said, my version is still July 2016, and there are enough problems with that…

I tried, but I got a message saying “You must be running Windows 98, Windows Millennium Edition, Windows 2000, Windows XP or Windows Server 2003 family to install the DirectX 9.0.”

The problems just never end. I downloaded Dx9.0, tried Neverwinter Nights 2, and it finally started playing…

…but it had no sound. And when I tried to exit out, it wouldn’t let me. There was nothing I could do to close it. Not Task Manager, window out and right-click it to close it, nothing. I had to shut my computer down entirely to get it to close.


sometimes Ctrl-Shift-Escape doesn’t bring up task manager when Nwn2 freezes
but Ctrl-Alt-Del will bring up a fullscreen user-menu (after a short wait) and one of the options is TaskManager


But why the game doesn’t run … after ‘restoring factory settings’ uh … (my lessons have taught me not to do that).

try …
update video driver
if that doesn’t do it, update more stuff

tip: When you get an error message, google the exact message, in quotes, along with your OS. eg,

win8 “This application is not compatible with the installed operating system”

There are several windows games where I had problems with the Miles sound drivers causing the sound to fail. You could try renaming these two files and see what happens. Mssa3d.m3d and
Mssds3d.m3d. Give them a .old extension or something. Fixed a couple of games for me. Can’t hurt to try.

1 Like