Importing/Exporting from Sketchup Question

Okay so i may already have fixed my issue before hand but i think the 2da may be the problem with the dark shading. I will update this when i think i have a solution to that.

Original Post:
So has anyone ever tried using Google Sketchup for models? i found this odd “thing” that occurs where it seems the models appear very dark in-game as shown below

It was done in gmax thru Nwmax and i hadn’t ran into this problem before until now

Any explanations as to why this could be? Its very clear that the surrounding objects (IE: windows, walls, nearby buildings) are much brighter than the actual building itself so it can’t be the lighting and fog effects.

Perhaps i am missing a simple button to uncheck here?

I am throwing in a wild guess.

People occasionally complain about armor parts (especially robes or cloacks) doing the same and in these cases it’s almost always a graphics card driver issue.

As I said, just a wild guess.

Actually youre probably very far off because i think i may know what it might be… the 2da.

i will tweek around with the placeable 2da file and see if that fixes it.

Hey, when i first started porting objects from the witcher 2, I noticed the models would do this when I got them in game. I do not know if it is the same thing, but in blender I “cleared the custom split vertex normals data” that is in the object data tab,and it worked.

This reminds me of what was going on with the display case placeables. In case the 2da route doesn’t lead to a fix - could you upload the .mdl? I’d love to get to investigate this more.

Suggestions for things to check:
Are the ambient/diffuse/specular settings on all the individual objects within the model identical?

Does it change depending on whether or not the placeable is set to Static?

Is it the same in 1.69 and the EE, or are there differences?

Are there differences in between how they look in the toolset, and how they look ingame, in either game version?

hey thanks for replying, and yes unfortunately the 2da was not the case i did have a look through the model on gmax it seems nothing on my end really did the trick. I kind of chalked it up as it being too different. it was exported from google sketchup into a .3ds to be imported and then exported as a .mdl anything could happen between then and now.

From what i can tell of my own oversations it seems it stays the same regardless if it is static or not. It remains dark in the toolset as it does in-game throughout.

I do not own EE so i cannot confirm if this is the case

Here is the link to the model with the textures provided
Chateau .Mdl

1 Like

A blow has been struck against the (literal) darkness! It’s the ambient/diffuse settings. I’ve set everything to 1.0 1.0 1.0. File link.


thats awesome now i can fix it all. thanks much !

1 Like