Improved Zombies is glitching out with me, can you help?


The mod Improved Zombies initially worked fine for me, but now the zombie’s loincloth is misplaced. Take a look:

I didn’t use as override, I made a hak and put in userpatch.ini together with other creatures mod. Last mod is an appearance.2da with all the creatures lines. This worked fine but I don’t know when this started to happen with the zombies and zombies warriors.

What I did:
I removed the Override folder; the Development folder; the userpatch.ini file; used the hak in the Pretty Good Char Creator to spawn the zombie; used the override version in the aforementioned module; checked file integrity on Steam; rolled back to older versions of Enhanced Edition (currently on 8193.29); checked if something is overwriting something in userpatch.ini; checked if was subscribed to something on the Workshop, nothing.

Does this mod become incompatible with EE? Because I noticed I have colored skill icons and I didn’t installed any mod to do it, so something might have changed.

Can somebody test out for me?


Those models have numerous issues - I’m amazed they ever worked - that @cervantes has fixed in his Creature Catalog project see the thread here - Creature Catalog - #19 by Pstemarie


That catalogue is very cool, a lot of nice models there. It fixes all the zombies but the common one, the one shown in the photos, these still are glitched. Do you know if something can be done? Even if I have to do it on Blender?


You say the creature catalog models fixed all but the common zombie is that right? Can you be as specific as you can on the glitch and explain it better in words? I will take a look at it tomorrow see if I can pin point any errors I overlooked on that particular model as I will be making another model compatible for someone haks. I have a hard time seeing your pictures getting old you know kinda looks like lion cloth is sticking straight out in the back but not sure.

If you click on the pictures they enlarge and you can download them. I did, snipped a copy of the zombie out and enlarged it in -


No idea what it’s got stuck to its butt. It looks weird. Somewhat reminiscent of a toilet seat. Anyone been playing with the super glue :toilet:?


1 Like


It’s the loincloth that dislodges from it’s place and moves to it’s back. When the zombie spawns and is stopped it’s ok. When it acknowledge you and start walking towards you the glitch starts. The loincloth moves to it’s back and don’t return to it’s place.

It’s true, it happened with the zombie warrior and tyrantfog zombie as well, but it’s fixed with your hak. The zombie lord I don’t recall how it was on Improved Zombies, but I can use yours and I see no problem.

Thank you very much for looking into it.

Like pstemarie said those models where in a pretty bad state took a while to go thru them and make them work. it wouldn’t surprise me if I did miss something.

I have tested the Common Zombie in several different tilesets and in several different situations. and have not had occurance of what I see above. I looked thru the model found no problems there either.

I know this is probably a long shot but since adding the other zombies from the creature catalog has fixed the others. I would get a copy from my paks. Then delete the common zombie from your hak. Save the hak without the common zombie and then open it back up and add the one you have from my haks.

I say this because I have had this happen to me where it says the model is overwriiten and it really isn’t. The only other difference is I use the Beamdog version and not the Steam.


I’m not sure I understand. I’m not using the Improved Zombie hak since I’m using your hak, as it has the Improved Zombie models, right?

I understand there are many models for the common zombie, right? The zombie with the fully exposed ribs is OK. The zombie that is still glitched is the one with half exposed ribs half fleshed chest. I learned playing a module with zombies today.

Maybe the problem is with this model? If you looked and saw nothing, maybe if I deleted the model the game wouldn’t use it. Is that what you were talking earlier? But which model is this one?

Thank you very much.

I’m not seeing any issues either - pardon the lack of textures, I just tossed the model and it anim chain supermodels in my /override



No “toilet seat” attached to the pelvis. Do you have workshop items subscribed? Files in /override or /development?


What could be the problem then? Because at one point it worked fine. I do have items from the workshop (fast rest, red crosses on medkits, new rain, some new skyboxes and a tileset nothing that should interfere.) and in the Override and Development, but I removed them all minus the steam workshop items and still the same. Look at the first post for a list of things I’ve done.

For now what I’ve done is swapped the zombie common for the zombie rotten, so I have 2 zombie rotten.

Do you have any advice?

Are you using only my haks or have you built your own? Are you using any other haks? If you are using other haks the only thing I can suggest is sending me all of haks zipped so I can investigate further. PM me on the vault and I will PM you my e-mail thru it. You can then send the haks zipped to that email address and also send me the order you have the haks installed.

Open the model and change the supermodel from c_mum_com to a_mummy and see if that works to fix the pelvis issue.


Wow, it solved the issue. Look at that:

Thank you very much for you and everyone that helped. I don’t know which message to flag as solved though, this or the one where you showed me the Creature Catalogue.

Good catch pstemarie thanks for the help.

1 Like