In toolset...not in game

Hello everyone. First time posting here, but I used to be active about 10 years ago on the old forums.

Anyway, my question is this. I have a custom creature I’ve modeled in 3ds Max 2009 and exported using Tazpn’s Importer/Exporter tool. I’ve edited the proper .2da files and the model shows up in the toolset like it should. But when I load up the game to look at it, the model just isn’t there.

So I thought there was something wrong with the model and abandoned it after I tried everything I could to figure out what was wrong with it. I moved on to a different creature. Same thing. The model shows up in the toolset but not in the game. I’m stumped and there’s nothing I can find on the web addressing this issue. Any idea what causes this? I’ve also noticed skeletons aren’t being imported when I pull a NWN 2 stock creature into 3ds Max, so I am thinking this is probably linked to Tazpn’s tool for 3ds Max and maybe its a Windows 10 compatibility issue. His tool worked great for me back when I was still on XP and even Windows 7, as I recall.

Any help would be greatly appreciated. I’d like to get back into creating custom content again. Just need to figure out this issue. Thanks for any help you can give me!

If you’re talking about the skin, I had the same issue a while back; if I remember correctly there was a parameter to set. However you first need to import the skeleton, and then the creature.
Let me have a look, l’ll give you more details tomorrow hopefully.
And I’m on Win 10, so it’s not an OS issue.

do you have gog’s nwn2 complete installed? this version doesn’t add a registry entry and tazpn’s tools can’t find the installation folder. if i remember right tazpn’s plugin comes with a nwn2utils.ini file where you can configure the path. this should solve the issue regarding the missing skeleton.

if there was no skeleton imported, you could also not weight the vertices to bones. perhaps that’s why you can’t see the model at runtime? just a guess.

anyway, if you’re still having problems with 3dsmax, i suggest switching to freelook’s im/-exporter. he put a lot of work into his own plugin, which offers the same features as obsidian’s expotron plugin without the baggage of having to own an old version of 3dsmax. hint: you can create custom skeletons and animations which is not possible with tazpn’s tools.

link to plugin
link to thread

Thanks 4760. Yes, I think that may be a problem I am facing too. I tried to import a skeleton but couldn’t, so I decided to import the creature I had originally based the model on (Balor…like 10 years ago) and it imported the skin, but nothing was weighted. I eventually found an old Max file that had the skin with weights and used that, but I would like to solve that problem as well. Thanks for your help!

Thanks Semper…yes, it’s GOG nwn2 complete. I found a post on a different forum where they mentioned the same thing you did, so I went in sure enough, the NWN2utils.ini was showing the wrong path. I edited and then tried exporting again but it didn’t change anything. I was only able to mess with it during lunch so its possible I didn’t get the path right. I’ll check later and update here if I did make a mistake and that fixes it.

BUT…I didn’t know about a different tool. I will sure download it and give it a try. Thank you for your help and for sharing sir! I’d much rather work in 3ds Max 2021.

It’s not totally true. The skeleton is still imported if you select the “bones” box:

But as you can see, I also set the scaling factor to 10,000 (meaning the mdb will be 100 times bigger than the skeleton). That’s why I import first the skeleton, then the mdb (this way, it fits on the already existing skeleton).

Re the missing skel
I’m not sure, but I’m wondering if the skin modifier is only imported when the creature uses a stock skeleton. I made a few tests, and all of my custom creatures had the skin and skeleton imported when they were based on gr2 files from the game, but not when I created the skeleton and animations myself.
I’ll check later, if adding a custom gr2 skel in the \Data\lod_merged zip files fixes this behavior.

YES :slight_smile:
That’s it: add all your customs skel.gr2 files in a lod_merged .zip file, and the skeleton and the associated skin modifier will be imported along with the mdb!
I renamed mine so it wouldn’t mess anything up with the stock files (unfortunately, it doesn’t work if it’s not in the \Data installation folder).

1 Like

Thanks 4760. That’s good info. Unfortunately when I try to import a skeleton I get the message “unable to locate: granny2.dll” I’ve installed that dll in the root folder of NWN2 (my main drive install, not through “My Documents”), and I even dropped a copy of it in 3ds Max. I think I made a mistake in installing Tazpn’s plugin to begin with though. I’m going to try a few things and see if I can’t get it fixed. Thanks for your help and I will update you as soon as I know if I succeeded or failed.

Semper, I downloaded Freshlook’s FBX to GR2 Tool and it’s pretty easy to use. I would love to continue to use it but the odd thing is the model won’t show up in the toolset now. Before it just didn’t show up in game, but now it won’t show up in either. I may have a problem with using Freshlook’s software though. I’m not very familiar with the FBX format to begin with (I always saved using the old .max files and didn’t even know what an FBX was until I got a subscription to Max 2021. Yeah…I am that out of date. Max 2009 to 2021. It’s a big jump). So I will play with it some more and go through the docs and tutorials on the github site and see what I might be doing wrong.

I really appreciate your help guys!

you probably missed custom properties needed for the engine to know what to do with the model. it’s best to convert a model from nwn2 to fbx and import it to max to study what have to be set. then export a simple primitive as a static mesh. while the plugin works with fbx, it was mainly tested and written for blender. perhaps switching your main dcc helps in the long run - it surely helps saving a lot of money, regarding the cost of subscription to autodesk.

I checked on my laptop, and I see there’s also a copy of that file in 3ds max root folder.

Hey guys, I got it figured out. In case someone sees this post while troubleshooting the exact same error, the problem was caused by not putting nwn2utils.ini into the AppData folder as described in the installation instructions. Everything imports and exports just fine now.

I’ll definitely continue to work with Freshlook’s software though…I am not a creature animator (or any kind of animator really. I went to school to become a 3d modeller, not an animator), but I would like to be able to animate simple things like windmills turning and the like. So it’s definitely going to be a fun tool to use. Thanks for the recommendation and all of the help gentlemen.