Invalid URLs? when downloading

Has something changed in the last day? We’re getting invalid URLs when attempting to download files stored here on the Vault, and these are files that have been downloaded hundreds of time over in the last 2 years.


Yup. Tagged Niv to look into it.

Yeah, I’m having the same issue, even with a file I downloaded like, a couple weeks ago. :slightly_frowning_face:

Looked on Rolovault and a file that has invalid url on the mainsite is downloadable from there but that isn’t the whole story. It took 3 tries before the hakpak folder would open. And this was for the top item in the files list - CEP V1.X installer.


Just did an unscientific test and it seems to affect ALL hak file downloads from the oldest to the very newest (shadguy’s NWNEE chat bubble demo / VFX model).


I’m not able to download anything since I get ERROR: Invalid download url.

The latest EE patch broke the Vault :scream_cat:

Give it time, the admins (niv) will get it working again…

Yeah, all file downloads are busted via project file clicking.

Does that include downloading through your web browser? I’ve tried both Brave and Edge with the same error. NIT gives me 400 bad gateways.

It might be an idea to put a notification on the front page before we get loads of “I can’t download X” in the comments to projects.


FWIW, I think this may have happened at midnight CET (Central European Time aka German time) as we went from September into October.


Hi, I confirm the error

Looking into it now.


Should be fixed now … letsencrypt cert expired recently and the php install did not have the correct cacert bundle. The pubdlcnt script is checking locally of a URL exists and it was failing on the https:// part of the URL.


Thank you for fixing it.

1 Like