Issues with using Phenotypes above 99?

I’m trying to combine several different phenotypes into a module, but whenever I try to set a creature’s phenotype to 100+ via SetPhenotype(), it doesn’t seem to work. I updated the phenotypes.2da, but what else could I check? Has anyone else had this issue before? I’m thinking of just moving this phenotype to a number under 100 at this point.

According to my notes, SetPhenoType() used to work before EE, but now there is a bug if the phenotype has no talk table entry.

As it happens, my examples were also in the 100+ range, but that might be coincidence.

I’m not quite certain, as I was able to work around the bug by setting the phenotype in the toolset.

Update - I tested this. SetPhenoType() works in the latest retail version of EE if the phenotype has a talk table entry, even if the phenotype number is 100+.

This already worked on 1.69 and as can be read from the description it uses pheno 101 102 and 103

Yes, that’s one example I’m using.

As previously mentioned, it worked in 1.69 but failed in EE until I added talk table entries.

Hm, I must be doing something wrong then. I did add talk table entries, and could then set the phenotype in the toolset when it was 100+, but I can’t use SetPhenotype(100), even with talk table entries. When I moved the phenotypes to something under 100, I was able to change via script though. I don’t need 100 phenotypes anyway, so this should work well enough for my purposes.

In NWN:EE the SetPhenoType script command appears to check if the phenotype is >=0 and <=99 for ??? reasons. This wasn’t the case in 1.69.

Edit: I asked around, 1.69 did have the check but it was broken and always returned true. And the reason why it’s limited to two digits is due to filename naming conventions.