Java problem

Okay here’s a nerdy one for all you tech guys. Please keep in mind I don’t understand the question properly so the answers may leave me a little cold and more questions may follow.

I recently had to refit my pc with a new primary hard drive. I then tried to build all my old toolset up again.

I could not run tlkedit and it transpired that this program needs an old version of Java (jre1.5) so I installed it along side the latest java (jre1.8). Perversly jre 1.5 appears in my Program_files_(x86) folder which I thought were the 64 bit files and 1.8 appears in my program_files folder. Is that the wrong way round?

My current issue it that I can run mdbcloner just fine but I cannot run mdbconfig. I prefer config, and for a current problem I have with a retexture, I really need RJS’s superb config tool.

Running config give me the message “could not find the main class. Program will exit”. A little googling tells me that it might be a conflict betwen the 32 and 64 bit versions but it does not give me a solution in a way that I understand.

So I see my options as:

  1. Delete the newer java and try to run everything on the old. At the risk of newer java reliant files not working.
  2. Ask a kind soul to look at some of the older nwn tools and update them to run off the newer java.
  3. swap the java installs so the newer works out of the (x86) folder and the older sits in the 32 bit program_files folder … that one I am really not sure about.
  4. Sob gently to myself for a few minutes then give up on the tool set and play Caesar III instead?

Your thoughts and comments would be welcome before I embark upon this journey into darkness.


You could use the command prompt or set up a .bat batch file to run the mdbconfig.jar file with the correct java path.

C:\{path to java.exe version}\java.exe -jar C:\{path to jar file}\MDBConfig.jar

note, x86 = 32-bit

ps. running jre1.8 32-bit on a Win7 64-bit computer and TlkEdit2 works fine here.

pps. Sorta sounds like issues w/ Java not setting a path to its \bin directory in your System path spec. But that’s a touchy issue and you really wouldn’t want to screw that up …

pps. at least take a glance at ControlPanel|Java|Java|View <- lists currently installed JRE’s (JavaRuntimeEnvironments)

1 Like

Thanks guys

I uninstalled the later version of Java I am now in the same place as I was when I had the old drive.

I can’t get config to work it gives the same error message.

Going to try some other stuff … thanks for the advice.


FWIW I’m having a similar problem and no closer to sorting it out.
Running Win7 on an HP machine if that helps.