Jumpy laptop

Hello, I’m away from my PC and internet most of the time at the moment so excuse me if I’m a long time replying to any suggestions.

Because I can’t use my PC at the moment due to my life getting flipped in the space of four weeks I put NWN2 on my daughter’s laptop which isn’t that powerful. She used it before to play NWN2 and it worked but I had to stick her save of before the King of Shadows fight on my PC because it couldn’t handle it. She also played one of my mods on it and it all worked fine.

However when I put my new mod in her laptop it’s awful. I cleared out the override and it didn’t change at all, all graphics settings are on minimum or switched off but it’s really bad and unplayable.

Everything loads but the problem is that it’s very jumpy. You click on a place to move to, it freezes then jumps you there, your companions run on the spot for a while and then one by one do the jump too. Conversations hang on the PC response and the person you’re talking to takes forever walking on the spot before finally facing the PC.

The laptop is on Windows 10, toolset works fine but playing is impossible and I haven’t even tested a fight, this is just walking about an interior area ! Any ideas why it’s got this bad ?

Thank you, I’ll return here when I can.

One of the first things I think you should do (if you haven’t already), is to restart the computer. On Windows 10, for some reason the game gets laggy every now and then, and then I just restart it, and it works fine again.

Otherwise I can’t think of anything. Maybe you could try the Client Extention, but that made my own module freeze in the first scene on my own laptop. Still, you could try it. On my main PC the client extention works, but I haven’t used it since I want the same setup on both my main PC and my laptop.

What kind of specs is your daughter’s laptop? It would be interesting to see if it’s the same as my own. My own laptop is getting a bit old so…

1 Like

andgalf… Thanks, it’s been restarted a lot, I’ve ran the task manager and had nothing else running, closed down/ removed a lot of programmes and it’s way more than a bit laggy. But it worked fine with NWN2 and not on lowest possible settings a couple of years ago.

I haven’t got it here but I know it’s got 4gb of Ram, a dual core and integrated graphics.

That’s weird then. Have you tried the Client Extention? You can always uninstall that if it doesn’t work:

Alright, I have 6 gb RAM on mine.

There is some discussion that the April update to Windows 10 causes a phenomenon referred to as micro stutter on some machines. I’m dealing with the effect on one of my astronomy programs but I think it’s affecting NWN2 as well.

SSD vs Disc HD?

SSD is the best single upgrade you can do to speed this game up.

I can’t imagine playing on 4Gb of RAM, again. That’s probably what I was running in 2006. Try boosting that up.

I don’t use the last couple versions of the Client Extender, due to some things not working great. Try an older version of you can…

A Windows 10 update at the beginning of this year was troublesome, but an update a week later fixed it for me.

I do run the game with compatibility mode XP3.

Good luck

Try using the “-home” switch with a game shortcut to create a completely new pristine game documents directory.

1 Like

Thanks everybody, I’ll investigate further into this. I’m not going to upgrade the laptop as it’s not mine and I only want to use it while I’m away from my PC.

Seeing as it worked fine before I’m beginning to think it’s because of some sort of update or changing of direct x to play another game that’s stuffed it up.

This laptop can play Dishonoured and Fallout on decent settings without an issue so should be able to handle NWN2 ( on lowest everything with no boxes checked for grass etc.) without going really bad.

1 Like

I’ve had a breakthrough with this but it still makes no sense…

I got another laptop ( my daughter’s happy now she can have hers back ) which is pretty powerful and on windows 10, I bought NWN2 :sob: from GoG :sob: despite always using the copy I have on a hard drive from my original discs so I don’t have to update :sob:

Anyway it worked fine, no jumping about, very smooth and normal on pretty high settings, no problem.

Having used my PC for a while and not the laptop today I gave the laptop a go and it was all jumpy again ! I tried everything, turning off all the bells and whistles in the graphics, messing with the sound, running it in compatiblity mode and as an administrator… Nothing still jumping about.

Then I read on the GoG game “start” screen that it may not function well if it’s offline so I put it online, loaded the game and back to normal no jumping about just as it was before.

I took the laptop offline, turned off the internet, fired up NWN2 again and it worked perfectly, no jumping but it wasn’t online.

The laptop didn’t update, it worked fine before when it was offline, then didn’t after resting for a couple of weeks and now does after briefly going back online so I have no idea what’s going on.

Any ideas why this happened ?


Try disabling the windows service superfetch(Sysmain in Win10), i bought an SSD for my laptop and noticed that some games were having some stuttering to the point where they were unplayable. Disabling that fixed my problem.


Chofranc… So far so good ! I disabled superfetch on startup ( had to look up how to do it ) and no jumpy characters at all. My problem has been intermittent but before disabling it there was definitely jumpy behaviour.

Many thanks and I’ll keep my fingers crossed but I think you might have sorted it, give yourself a big pat on the back !