Just Had The Weirdest NWN2 Toolset Issue (A Solution)

Hi All,

My experience with the toolset is usually reasonably “plain sailing”, albeit with the occasional “minor” issue. However, starting yesterday, I had the toolset drop to desktop after simply closing an area. I thought nothing of it until I realised I had not saved recently and had to rebuild the last few parts of the area.

Then today, working on the area some more, I went to add a prefab I had made (wall torch with light and flame effect) and it hung before crashing to desktop (again). I tried various resolutions (copying area, exporting erf, reusing older backed up version, different computer, reboot computer, different 2da etc), all with the same result of crashing to desktop whenever I tried to pick up and use a prefab … most often one that used a “flame” by the looks of it.

I was about to give up when I put all the original area files back and tried once more and the prefab worked fine. :astonished:

I have done nothing but move the files around. Bear in mind that this exact same set of files (imported as an erf) confirmed the same failure on a different computer with its own copy of NWN2!

Any clue at all as to what may have happened to help me avoid this issue again appreciated … and if I ever deduce what caused it I will let you know.

Cheers, Lance.

THE FINAL RESOLUTION (Copied from below) …

I suppose I had better conclude this post from my own perspective …

First, thanks to everybody who helped me examine this issue, especially to Sawdust37 and Travus for testing the area on their 16GB computers.

It appears the issue does “simply” boil down to the fact that the toolset does not handle 32x32 areas very well, and your mileage with such a size area will vary according to what you do to it when and with what objects. In particular, a fresh computer boot may allow you to open and continue working on a large area, but only if further work does not aim to use particular VFX “heavy” objects like adding flaming effects or (in my own tests) a “drowned” monster. As it appears that trying to “introduce” any new element to a large area will likely cause the toolset to crash. Furthermore, even if you are able to eventually add such elements (through pure perseverance and a little headway without crashing), then even trying to remove said elements will also likely crash the toolset.

In my own example of working with this mega area (also born out by Sawdust 37 and Travus on 16 GB computers), the actual memory you have does not matter as it is down to the way the 32 bit toolset program manages its resources, and some of those resources appear to vary in their impact even dependent on whether you are adding or removing them at any time on the area.

The workaround in the end, as has often been stated, but “I never saw it coming” is to stick to smaller areas, or if you are working in a 32 x 32, then keep a careful eye on what you add and how much you add, making sure the area saves and “closes” without crashing the toolset. You will know when you have hit the toolset maximum limit when the area you are working on crashes the toolset when you try to simply close the area before closing the toolset.

For my own solution, I ended up dividing the area into three new ones. At the moment, I managed to keep a 32 x 32 section, which I am glad I was able to do, as its layout works better if I could keep the size. However, I removed two sections from the original design (thereby reducing overall resources used for the area) and made two new areas that will transition to and from the main. In testing ,the 32 x 32 currently remains stable with the reduction of some of the surrounding tiles that have now been moved to their own areas.

I hope the advise helps others as a reminder, and I also thank everyone for the posts regarding the toolset memory issues too, as they were the reminder I needed after forgetting how old the toolset is. :wink:

Thanks again all, Lance.

I’ve also had the toolset just crash or turn itself off for no reason and bringing me back to desktop. Recently that happened with a prefab area. Eventually I just gave up on that area and used another one instead. It’s totally weird and I don’t know what’s causing it.


Hi andgalf,

Thanks for the feedback … although mine crashed trying to add a “prefab placeable” as opposed to a “prefab” area itself. That said, do you recall how big the prefab area was you were trying to load?, as that may still indicate if your computer system was being “pushed” to load data.

Cheers, Lance.

Prefab placeables groupings can cause issues if they include objects your module doesn’t support, for instance if there is no 2da reference in your module for an object.

Placeables groupings can also cause the toolset to freeze for awhile if they have lots of objects in the grouping. It takes the toolset a long time to get it into the area.

1 Like

Hi Kamal,

These are prefab objects that I have had around ever since day one! i.e. They are still in other areas and work fine. As I said in a previous post, the sudden crash was the weirdest and most unexplained event ever to occur for me, and (for now) I have put it down to some strange power issue, as I have been OK ever since I rebooted both my own PC and my wife’s. i.e. The problem did not fix with just a single computer reboot, but appears to have done after both were rebooted … I’m clutching at straws here, but just maybe it was something to do with that.

Ever since both rebooted, the problem has not reappeared on my computer (I did not bother testing the other computer again). That’s a relief at least.

Cheers, Lance.

The larger and more detailed the area, the more likely it seems to exit with a crash. I haven’t narrowed it down to one particular thing. Most of the time it will exit just fine; just sometimes it crashes.

1 Like

Hi again Lance,

I actually remembered wrong. Or sort of…I have had crashes with areas that I have managed to solve, when the toolset has crashed to desktop. I don’t exactly remember what the problem was then, but I know I managed to solve it and that it was something that was logical.
However, the incident I was thinking of was when I used this prefab: https://neverwintervault.org/project/nwn2/prefab/area/rustic-tavern-and-shrines and the area “temples druid and knight” and I edited the small temple somewhat with placing a few benches there. This didn’t cause a crash with the toolset but when having baked and everything and checked that the surface mesh looked ok, and I put the Set Start Location there, and trying it in game, then NWN2 crashed when trying to load that area.

1 Like

I think the large area may be an issue in my case too. Although it’s NOT very resource full at the moment, but it still feels as though the toolset cannot handle the size efficiently

The toolset does appear to have some strange behaviour with some aspects. I may try downloading that area to see if it has anything in common with my own and see how it handles in my computer.

Thanks, Lance.

EDIT: Another thing this “problem” felt like was as if the toolset could not access the resources I was trying to place from the toolset when I clicked on them. It reminded me of trying to access something from a corrupt part of a hard drive. Now, I have also just done a hard drive firmware update for my SSD, so we will see how that goes too.

Hi All,

An update … Now the toolset dropped to desktop after I clicked on a “Flaming Skull” creature to examine it in the toolset … another link to the flame effect! (But only when I had the large area loaded.)

Also noticed that the toolset would crash to desktop trying to load the large area after viewing one of these creatures too. I am beginning to conclude that I will simply have to break the area down into smaller chunks. (I am going to do that to test my theory anyway.)

EDIT: I could not load the area again until AFTER I restarted my computer!
EDIT 2: Now I just had to power down and reboot before the area would load! :astonished:

Can other people try testing their access to “flame” effect related objects, as I a, beginning to think there is a pattern here.

And in case it matters, my graphics cards use NVidia drivers.

Cheers, Lance.

Hi Lance,

I have ran into the issue too on occasion. I generally open a new folder and then export areas/dialogs/ etc individually and then check the toolset each time until I find the file that is causing the issue. I’ve found both 2das and blueprints that can cause this to happen. It’s a slow process but saves a ton of work.

1 Like

Hi SD37,

It is a frustrating problem I must admit as it is really interfering with any build time I get. :frowning:

In this case, however, any thing I have tried always appears to relate back to the one single area, as these objects always work OK on other areas, and have even worked with this area “sometimes” … or when they feel like it. :astonished:

The only other common aspect appears to be with the flaming effect, which still works in other places.

I’ll keep investigating while I can.

Cheers, Lance.

According to Windows 10 report, it is always to do with:-



I believe I may well have found the problem …

I believe it to be a Windows 10 memory resource issue due to the fact that larger areas require more memory to work, and as soon as there is a memory overload the toolset crashes …

HOWEVER, the reason I have been experiencing the issue of late is because the Windows realtime virus checker appears to be really memory hungry whenever I try to work on things in the toolset. If I switch the real time checker off, the toolset does NOT crash, even when I introduce flaming creatures in the large area!

Now I don’t really want to have to disable my real time virus checker every time I work on this area, and so is there any way to address this issue without falling back to buying more memory, which I will do if I have to. (Currently using 8GB.)

Also found this may be helpful …

I am also going to try reinstalling my graphic drivers …

Cheers, Lance.

Well, even after two “clean” driver updates (NVidia do two types), neither resolved the issue. Neither did turning off the realtime antivirus after a crash. Therefore, the “damage” has been done by the time it crashes.

Reducing the size of the area may be my only option, as this helps reduce resource usage by the looks of it. I’ll report back if this is more consistent than other previous testings.

EDIT: OK, in all my testing, the only thing that appears to “fix” the issue is to reduce the size of the area, which in turn likely reduces the resources needed, and stops it from crashing when I try to add anything new to the area … especially flame related objects … :anguished:

I may try investing in another 8GB memory just to test the theory. However, if anybody else has any more ideas or suggestions to try, I am listening.

EDIT: I ordered another 8GB memory in the hopes that will help with the issue, as I would prefer to keep to the original map size if I can. If that does not work, then I will just have to reduce the size and make do with a memory update as a consequence. (I may leave any further updates to that area until I have updated my computer in a few days.)



To all,

Does anybody have a computer with 16 GB memory (and possibly uses Nvidia graphic card, although not essential I guess), and would be prepared to test load this area for me?

I want to keep it to a minimum distribution as it is a key area for my module two and so I wish discretion when testing for me. However, if you have the hardware, toolset and know how to test an area, I would appreciate the help. It would require the following …

  1. Download the zipped file … I will provide a link in a PM.
  2. Add the five area files (single area) to a temporary module.
  3. Load the area.
  4. Try dragging a flame effect into the area and then delete it a couple of times. (In particular the flaming skull creature.)
  5. Close the area … without toolset crashing here too.

Thanks, Lance.

I have 16 GB but I use a Radeon Card. If you need someone I can give it a twirl.

1 Like

Hi Sawdust37,

Thanks, I will ping you a PM with the link …


Lance, I have 16GB with a Nvidia GTX 970 if you need another set of eyes on it.

1 Like

Hi Travus,

Thanks, I will PM ping you the link.


Hi All,

I am just going to disconnect my UPS as well to test the power supply … will be back online shortly.

EDIT: Made no difference - It was a long shot anyway.