Legacy of White Plume Mountain Unofficial Patch


#1

I was enjoying playing LoWPM but was put off by the game breaking bugs. The author, Wyrin, hasn’t been active, so I decided to fix them myself. I must say that I have been very successful. I managed to fix all the crash issues with the Gnoll Caves, Dragotha, and the Drow outpost. Additionally, the issue with Nix convo not firing has been sorted. Cursed items are now working properly. Some formerly inaccessible cave doors are fixed. Convo files that restarted quests or had blank entries are fixed. Convos that caused party members to disappear or walk slowly are fixed. Many script issues are fixed. Quest item checks are fixed. I added a new area for the Merchant, Wyrin. Prior to this new area, you would have to converse with him while on the OL map. This caused some issues with wandering monsters and getting kicked out of the store when changing characters. The new area prevents all of these issues. A lot of minor bugs I have discovered while digging through the files are fixed. There is a more detailed changelog with the download that explains all of the changes I made with each file.

Update: This patch is now live! Get it here:
Legacy of White Plume Mountain Unofficial Patch

Install instructions are included with the download. Note, this is a patch file for the Legacy of White Plume Mountain mod so you must have it loaded first. You can find the mod here:

https://neverwintervault.org/project/nwn2/module/legacy-white-plume-mountain

Thanks to Wyrin for making Legacy of White Plume Mountain. All the credit goes to him. All I did was fix bugs!

I big Thankyou to Quixal and GCoyote who made sure this patch actually works!

Original thread from the old vault forums


NWN2 Mod playthroughs www.youtube.com/user/AhTravesty


#2

I’m going to need to fire this one back up as I was one of the people stopped by bugs.


#3

I think you’ll be pleased with the patch. There are a couple folks still testing, but I’m pretty sure most of the bugs are taken care of.


#4

Now I have to try playing White Plume Mountain. I played it in the pnp form, but not in Neverwinter Nights 2 or 1. I had seen that it was buggy and didn’t try it.


#5

Hello,

I am just playing the module - no crashes, but I am not very far into it. So thank you for the patch!!

But there is a bug with crafting, probably overlooked and maybe not possible to fix:

If I use the crafting recipes (SoZ style, I think?), then all purchased recipes go into on of these books. I can open the book, and use the recipe from it. This works fine. Until you check the cost!!

It seems that recipes used from the book are activated twice with one click and on the same object!!

If I try a recipe for holy water, I create TWO holy water, the cost is not 18 gold as stated in the recipe, but 36 gold. In this case it would not be a big problem.

BUT: If I use the recipe for weapon enchantment +2, it should cost 4000 gold. Actually it costs 8000 gold, but the result is a +2 weapon. Obviously the ‘intelligent’ system does not check, if you use this on a weapon which actually already has the level, it just subtracts gold, and creates a +2 weapon. Even if it was already a +2 weapon…
The problem seems to lie with these books. So I will put the into a chest (or delete them). The books are meant to be practical (I find the loot satchel practical to use), but I am not willing to pay double. I could buy a +2 weapon, and this was actually cheaper the the enchantment.
No idea if this can be fixed. But without the books it should just work like it worked in the SoZ campaign.

EDIT: I just did an experiment: I deleted the books using Wyrins Editor object. I lost all recipes I already had bought, this was to be expected. Next I looked up several recipes in the editor. Then - without the books - I gave my character the ‘Weapon Enchantment +2’ recipe, which I already had bought. The merchant has always only one version of it, so I could not buy it anew. The ID: nx2_w_ench_02.
I used it on a normal Zalantar Quarterstaff. It cost 8000 instead of 4000 as stated in the recipe!

The books are not the problem!! The recipes do not work as intended. No idea why. I am an absolute layman with the editor, so I cannot help :frowning:


#6

I’ll take a look at that issue. If I find anything, I’ll add it to a new version of the Unofficial Patch.


#7

Thank you for looking into it!

I experimented a bit (see EDIT above), but it did not help. It always costs double of the mentioned cost, and the books are not the problem. I have the original game (purchased on CD when it came out), I have MoB and SoZ, and the game is patched to 1.23. I have only two mods, TonyK-AI and Tchos HD UI. Both are in the override folder in my user directory (…/Neverwinter Nights 2/override). The override folder in the game installation is empty. I also removed both mods and tested, override folders on both directorys (game installation and home directory) are empty. The problem persists. I will look if I can find an older save from may playthrough of the SoZ campaign. Maybe it was a game problem, because the LWPM campaign just uses both styles of crafting, OC and SoZ.
Could this be the problem?


#8

That’s been a problem the whole time with those recipes. I remember reading on the old vault the module’s builder Wyrin couldn’t figure out what was causing it. I usually kept track of the extra it cost me for the crafting then gave myself back that amount of gold.


#9

Ah - makes sense. The books are not the culprit. I could not find an old fitting SoZ save to check it in the original campaign.
I suspect the reason is that both crafting styles are active in LTWPM. For example, the workbenches in SoZ could not be opened, they were just objects, in contrast to the OC, where they could be opened and items put into it. In Wyrins LTWPM he uses the old workbenches.
Anyway: If it cannot be fixed, I will try to use the old style, which I like better anyway. The new style (SoZ) just uses gold instead of the old things, gems, essences and so on. I liked the old style much better, I think it is also closer to what D&D 3.5e intended.
Thank you for this hint!

EDIT: Just tried the ‘old’ system, without recipe, from the book: Enchant weapon +1, needs Faint Air Essence, Obsidian, and the weapon in the magic workbench, then cast light on it. Works like a charm and is much cheaper, provided you have the reagents. I like it better anyway.
So - problem solved, either give back gold by console, or use the old system.
Thank you all for your help!


#10

If you like the OC crafting try The Complete Craftsman Reboot by Vandervecken. He updated the original The Complete Craftsman, its got a lot more recipes and options you can use.


#11

I think I found out why the recipes are duplicating crafted items. If someone could run a easy test for me using the following instructions:

  1. Go to the main program files folder for the SOZ campaign (Neverwinter Nights 2 Campaign_X2).
  2. COPY the NSS and NCS files called “k_mod_activate”
  3. PASTE those files into your override.

Now, start your White Plume campaign and try to craft something using a recipe. Does it fix it? This should be save game compatible.


#12

Done. Seems to work, I used an ArmorClass +2 recipe, and it cost 1000 gold, as described in the recipe each time. Enchanted a shield and a full plate armor +1 (to +2).

Wow - thank you!


#13

Great! Just out of curiosity, did you test that with a new campaign or from a save game?


#14

I just used a save game - not exactly my current one, because this is a quicksave from the bowels of castle Mukos :slight_smile:
It is a save around the time we returned from Mukos to Soubar to restock and heal, and before I tried to enchant and found the problem. Should be okay, since in between we just bought equipment. I made a special save, so I can use it for further testing if required.


#15

OK, great! Once you are done playing White Plume, I recommend you delete those “k_mod_activate” files from your override, as they could potentially conflict with other mods. As long as you are only playing White Plume you should be ok until then.


#16

Yes - thank you.

I did a few more tests:
First - a negative test, i.e. I removed the script from override and it again cost double. Proof, that the script is a solution.
Second - I grew curious and looked into the White Plume campaign folder. The script is also there, but changed. Essentially some code lines were added, but the last (and only) line from the SoZ script is also there.
Can I move the new script (from the SoZ Campaign) to the White Plumes Campaign folder? This will overwrite the old script (from Wyrin). Wyrin just added a bit of code to his version.
Next test:
So next I renamed Wyrins scripts, so that they will not be used, and left the SoZ scripts in override. Then I tried to enchant a shield (AC +2, cost 1000 gold) with the new system. Worked fine, cost 1000 gold.
Then I used the old method to enchant a staff with +1 (Faint Air Essence, Obsidian, Light spell). Worked too!

So - why not to the White Plume campaign folder?
And then I moved the SoZ scripts (*.nss and *.ncs) from the override to the White Plume Campaign folder, which replaces the original script I renamed before. And it works too, both methods!

Could this be a valid solution? Maybe Wyrin used an older version of the game for his work, and something was corrected later, so that his additions are now superfluous? Because this would be the solution to this problem, with out the override.

The only change this introduces, that the original (edited) script from Wyrin is replaced by the SoZ version of the same script. Yet - I am not experienced enough to decide, if this change has side effects in other places. But essentially this is, what we did by placing the SoZ script to the override? Wyrins script is no longer used? Or do I miss something? Probably…
:slight_smile:


#17

Yes, you can replace the same named files in the White Plume campaign folder with the new files in the override. Although, doing that will likely cause it to not work in save games. Thus, you’ll have to start a new White Plume campaign for the new files in the campaign folder to take affect.
I’m surprised that the new script worked after you moved them to the campaign folder from the override. Did you possibly run that from a save game that had the files in the override?
Irregardless, if everything works from the campaign folder, then great! It’s always better to run stuff with as few files in your override.


#18

@travus - campaign files can be updated (they aren’t saved to the save-file)


#19

You’re right, they can be updated in the campaign folder. I could have sworn that wasn’t the case. Maybe I was thinking of mod folders or something.


#20

It seemed to work, but yes, I am sure I used a save which also was played with the script in override. So it could be, that the script is now in the save - I do not know nearly enough to tell…
Yet - it seems to be a real solution to put the script into the campaign folder, since everyone who starts a new game will profit. So could you add the solution you found to your patch, maybe?

While I have no experience in the script language from NWN2, I found that the old (Wyrin) version of this script uses an include (kinc_trade.nss), while the new version from SoZ does not. Maybe something was included twice (do not know if the script compiler detects such things) and therefore something was executed twice and led to the double price? Pure speculation on my side, I would not have know where to begin to look for solutions…
:slight_smile: