Legacy of White Plume Mountain Unofficial Patch

I already updated the Unofficial Patch on the Vault. It’s now version 1.5.
The real issue with the script was that it was causing a Craft/Enchant Item function to fire twice - once through Wyrin’s custom “k_mod_activate” and again through the “x2_mod_def_act” script. I just removed the function from the “k_mod_activate” script so it fires only once through the “x2_mod_def_act” script.


Hello travus,

playing the module I found a problem, but no gamestopper (I think):

I have recovered all 3 artifacts. This was a bit peculiar - I had thought, that the main quest would be hard, so I did several side quests - which were actually much harder. The Gnoll Mine is now without any glitches, Mukos Castle too, the Abandoned Quarry is also glitch free, and several smaller side quest are also without problems.
And now in level 13 we looked into the Mountain, and quite fast had the first artifact (West, the sword). Since it was so easy we next went north (Wave) and the east (Hammer). And here seems to be a problem:
First time we simply left the Mountain, and during the return to Soubar we ended in the small ‘fight area’ near Soubar and fought Elises party. No trace from the other party. But I found an entry in the journal about Nix. Yet - we never talked to Nix!! So I used a save where we have all 3 artifacts, but are still inside the mountain, actually in the place, where the last artifact (Hammer, after the jumping plates) was found. From there I retraced our steps. Returning we used the secret tunnel to bypass the jumping (poisoned, but not very dangerous), going in we had used the jumping plates. We returned to the main room (where we met the Beholder with its puzzles), and now Nix was there! Also - which did not happen the first time through, the mountain was crumbling and the characters wanted to run. So I suspect, that some trigger did not fire, when we first received the last artifact. This time we talked to Nix, and - which also did not trigger the first time through - we could not leave the Mountain, but ended in a cave, where the second party was waiting.
After this fight we arrived in Soubar again, and here it worked like the first time, and the second party was waiting.

So the appearance of Nix is triggered with the third artifact, and this did not work somehow.

To be precise: After solving the riddles we went west, and found the Sword. Then we returned to Soubar, and since we had promised to look for the sword we were not attacked. But: When we gave the Harper his artifact, he disappeared! So no chance to give him other artifacts after this. I think this works as intended but we wanted to have all the options, so I restored a save before this and we went back to the Mountain. And there we went first North, and then immediately - without leaving the Mountain - we went East. So maybe the scripting expects that you leave the mountain after each artifact? The first time Nix (and the mountain crumble effect) was not triggered. (It may be that we bypassed Nix, but the mountain crumbling effect was also missing).
I don’t think its a game stopper, but I am not sure. The fight with the other party also did not happen. So it may be triggering further bugs.
So now - after repeating the few steps - we are back in Soubar, have talked with Nix, have fought both of the other partys and have all 3 artifacts, and can give them back, or not. I think this is now the intended situation.

1 Like


I found 2 bugs, one of them sort of a game stopper - it traps the party in a dungeon and one has to use the debug script object to get out. This bug is very simple to fix:

Bug 1: Trapped in a dungeon.
Map: Dungeon of Swords, inside, level 1 (wpm_sword1)
If you enter from the outside into the Dungeon, you are in a room with a long bridge in the center. At the other end of this room is a door facing the entrance, which allows you to enter the mines.
Transition: wpm_sword1 -> wp_swordmineen.
This transition (both on the same map) is the problem: Using wpm_sword1 (the door) lets you enter, the door is unlocked. But going back is impossible: wp_swordmineen -> wpm_sword1 is locked, needs a key, and there is no key object linked! This seems to be an oversight. The only thing to do is to unlock this door in the map. (Will not help me, but is a necessary fix). But it should be combined with the rest of your patch, patching the patch makes no sense :slight_smile:

Bug2: This is in the Dungeon of Hark, and a bit more involved, but it can be solved, albeit a bit complicated.
The problem here is, that Wyrin obviously wanted to lock a door, but overlooked another situation, and also it show one (of very many :frowning: ) weaknesses of this game. The dungeon of Hark has two main levels (the sewer maps). If one enters from the outside, one ends up in Level 1 of the sewers (wpm_hark1). There is a level boss (forgot the details), and he has the ‘Sewer Key’, which you need to use the door to Level 2.
Door: dr_hark1d -> dr_hark2d. Locked, needs key, deletes key after use.
If you do it this way all is fine! But there is another way, which I used (unknowingly, but it is intended this way): You can do the Wolf Warrens, and if you go deeper into this dungeon you end up in a very deep level, there are undead and a bunch of other monsters. From there you can go to the surface (this is one way, you can only leave and end on the map), or you can enter the dungeon of Hark! If you do this, you go directly to Level 2 of the dungeon of Hark. If you now use the door (which I did) to Level 1, you have an unlocked door (dr_hark2d -> dr_hark1d). But the way back is still locked! You cannot go back. I then killed the level boss and found the Sewer Key. But since the door is now shown in ‘Open’ position (graphically), the key does nothing!
Weakness of the game, you cannot use this door, it seems to be bugged and insensitive, and nothing tells you that it is locked! I found this per chance since I tried to open the door with every character, and suddenly the rogue had the unlock animation, but unsuccessful, since a key is needed. I gave her the sewer key, but this did not help. I then had an idea and ‘closed’ the door (context menu) - and then the key worked normally, the door is now unlocked, and thats it.
I propose to create a second copy of the Sewer Key object and give it to the Hark. This way it does not matter from which direction you solve the dungeon, you can unlock the door from either side. So: Create second copy of the sewer key, give it the Hark, and lock the door on this level too. (Or maybe simpler make the door pickable from this side, no need for a second key, and it should be unlocked now. I am not sure if this works).

So if you find the time - could you add the fixes to your patch? (The second problem can also be solved by unlocking the door, this would be simpler, but not the intention of the original author).

Thank you.

1 Like

Did not test it without this patch, since I trust there indeed should have been those nasty bugs, that author solved, however when I started playing this campaign, I have encountered following interesting behaviour

  1. character gets randomly 38 damage (positive energy) - no idea why.
  2. when I exit any location, I it instantly returns me to Soubar instead of overland map. Works normally with monster encounters though.

Would anyone be so kind to tell me, if it is a bug or a feature?

Those issues should not be happening. It sounds like something is overriding the mod’s files. Make certain there is nothing in your override.

I wondered if thou may guess at any particular circumstances, that could potentially cause such behaviour. I only have Kaedrin’s pack files and few armour models in my override.

I found out, that character gets damaged when he equips one particular set of armour, but I can not understand, what is so special about that suit, just bonus to stats and few spell-slots for wizard. Also , strangely, on enter a new area, that is first one contained within separate module, characters re-equip their items and this is when the character gets damage.

What is more inconvenient though, is that whenever I exit the location to overland map, instead of overland map I end up in Soubar.

It may be an issue with Kaedrin’s pack. Does this item provide a bonus to Constituion?

Go to Kaedrin’s mod folder\Core 2DA, find there the cmi_options.2da and open it with any text editor, find the row that looks like “ConFix 1” and replace it with “ConFix 0”.

1 Like

I have the same problem as Taihou. When I exit from a location, I get teleported back to Soubar. The campaign didn’t start like this, my first 2 quest locations (Geen Welcome & Dead Knoll) worked normally, but now it seems to do it with every dungeon (just happened second time in a row, with the Coiled Outpost and Devil’s Cellar).

I have Kaedrin PRC pack & Races of Faerun installed.

I didn’t notice random positive energy damage, except the last time I teleported back to Soubar I got a random 9 positive energy damage to my lead character. Strange.

Changing the ConFix row didn’t do anything. First character still takes positive energy damage on transition back to Soubar. Area transitions seem to be the only thing that triggers this damage.

It’s not that big a deal, compared with being ported back to Soubar every time you leave a dungeon.

Download the archive from the link below and extract cmi_player_equip.nss/ncs to Kaedrin’s mod folder\scripts.

1 Like

It looks like Wyrin used a custom ka_olmap_visit script. This will conflict with kaedrin’s PRC pack causing OL map transitions to go directly to Soubar. To resolve this issue, remove the ka_olmap_visit.NCS file from the kaedrins\SoZ folder.


You guys are awesome! Thanks for the quick response.

@Travus I had already removed the SoZ folder from Kaedrin as part of the install instructions. But I searched my override directory for that script name ka_olmap_visit.ncs, and it turns out I forgot I also installed the SoZ overland buffs mod, which also has that script. Removing that entire mod solves the problem, and I can now exit dungeons back to the overland map.

So for anyone else with the same problem, the SoZ overland buffs mod is not compatible with WPM (it didn’t consistently preserve buffs anyways when I had it in there).

Thanks again!


@Aqvilinus. That worked too! You guys are great. Real credit to the NWN2 mod community that 10+ yrs after game & the mod is out, I can still get help so quickly.

Fixing the overland bug didn’t solve the positive energy damage problem, but replacing that cmi_player_equip script in Kaedrin’s mod did the trick.

1 Like

Incidentally, would you guys happen to know why Races of Faerun doesn’t seem to be working fully with WPM? Having RoF in there doesn’t break anything, but I can’t select many of the new races in character creation.

Strangely, I can select some of the new RoF races, like Bladelings, Alu-Fiends, Worgs, Bugbears. But I can’t select others, like Fey, Giants or Dragonkin.

I also can’t select some of the new Kaedrin races either, like the Deep Imskari humans, but can select others like the Star Elves.

When I say I can’t select them, I mean no char model comes up in the character creation screen. And if you pick it anyways, your character is invisible in the game (with a missing textures graphic in the portrait), and it crashes if you take more than a few steps into Soubar. Then if you force add a character with one of these races to your party through the party select guestbook, the game crashes. Any ideas?

Legacy of White Plume Mountain probably uses it’s own appearances.2da file, which would conflict with the one in RoF.


Hah, that was it. I thought that might be the candidate, but I didn’t see an appearance.2da in the WPM campaign files or modules.

It was hiding inside wyrin_wpm2da.hak. I don’t understand how the game determines which version of that file overrides which other one, but I decided to just try to overwrite the .hak version. Copying a line from the RoF appearance.2da file to the appearance.2da file inside that hak fixed it for that one race.

To fix it for all the races, I imagine you’d have to go through and figure out which ones were missing (there’s a lot of them, so kinda tedious). Maybe if I have time later, I’ll do that and post it for others to use. But just testing it with one line, that seems to do the trick.

Thanks for the pointer kamal.

Here’s a merged version:

1 Like

That fixes it! Thanks again @Aqvilinus