Light sources are way too strong when using enhanced lighting

Hey there. First post, but I have decent experience with the toolset.

As the title says, all light sources are emitting light MUCH farther than they should while “Lighting enhanced” is on.
These two gifs are with no CC, the area reset to black, and only one tile-based light source active.
How am I supposed to avoid lights going through walls when one tile-based light source blows up to about 30x30 meters? I can’t even zoom out enough to get their full reach.
This one’s with only one light-emitting placeable that’s supposed to be 3 meters (from Placeable/Decorative Lighting by Txpple)
Is there any CC trick I can use to tone EE lights down? I’ve already removed human-vision from fx_light_clr, but that doesn’t help with this. It’s a major problem for the module I’m making. I use a trigger-based darkness system, so I need to define exactly where dark starts and stops. It’s also harder to draw said triggers, since lighting in the toolset and ingame differ.
I have the latest GOG version (.23), but it happened in .20 too.

1 Like

The file to edit is fx_flame01.mdl. There is an entry called “radius” which is set to 7 which is 7 meters. For my forthcoming TrueVision massive update, I will be using a value of 3.962 which will give bright torches (239,239,196) a 15 meter radius. Note that this only affects tileset lighting.

While you’re there, you can also change “flareradius” from 30 to 0 in order to get rid of the lens flare on tileset lights.

How do I know that 3.962 meters produces 15 meters of bright yellow light? Because I measured it in-game using a 5 meter ruler placeable created for me by Buddha. For what it’s worth, that same setting produces 7.9 meters of dim torchlight (150,142,94) and 14.5 meters of orange light (234,204,165).

Bright torchlight (239,239,196) and dim torchlight (150,142,94) are the two colors that the Torch Lit Only visual setting uses for light sources.


For placeables, you need to edit fx_placeable01.mdl. In that one the radius is set to 10 and I will be posting one set to 3.955 which enables Pale Yellow and Yellow placeable lights to give off a 15 meter radius.

And while you’re there, you can change flareradius from 30 to 0 to get rid of the lens flare.

If you don’t want your candles to give off 15 meters of light (I don’t), then change their light color from 6 (pale yellow) to 29 (dark orange) or 5 (dark yellow) in placeables.2da which will give the candles around 7 meter radius.

I also give FlameSmall, CampFire, and Chandelier a color of 30 (pale orange) which then gives off a radius of 14.5 meters.

Pale Dark Orange (28) technically gives off the same radius as Dark Orange but it looks brighter than Dark Orange because Dark Orange has a larger drop off area. So I use Pale Dark Orange for candelabra which should be brighter than candles but not as bright as a chandelier.

PaleYellow (6) which is the default light and Yellow (7) both have the same radius, but Yellow appears to be a little bit darker. So I use Yellow for FlameMedium, Braziers, and Free Torches. In that way, PaleYellow is reserved for FlameLarge and LampPosts.

I was hoping they added something EE-specific that changed the lights, like how progfx.2da can replace some visual effects. If someone isn’t using enhanced lighting, their game will be way too dark if I modify the mdl files.
I assume most people bought NWN:EE for the first E, so I’ll have to give your suggestion a try. I think I’ll just provide two haks, one with lighting changes and one without, and recommend turning off enhanced lighting in the module description.

In any case, thanks for the measurements. If I’m reading it right, 1 pre-EE meter is about 3.8 post-EE meters. I had a quick try at fiddling with fx_flame01. Setting radius under AuroraLight01 to 3 gives tileset lights about the same radius as they had pre-EE, though now they are much too dim. I’ll have to find a middle ground.

I’ll see what I can do with placeables. I mainly want to reduce their total light radius, to stop wall-piercing light sources from illuminating areas which should be pitch black. I need it to be obvious when a torch/lantern/light spell is required. At least with placeables I can use a weaker one.

I don’t get why Beamdog extended lights this much. I guess they tried to make lighting a bit smoother, so there’s a better transition between stronger lighting near the source and weaker lighting near the edge. But instead of adjusting the light sources, they just made them have the same intensity as before and then added the transition part on top of that, basically tripling their total reach.

Thanks again.

This is purely a guess but maybe so that stuff is visible on mobile? Remember, until recently NwN was only playable on PC/Mac. So (usually) a much larger screen to see things. With it now being on phones and tablets it has to be visible outdoors too.


I don’t know if it’s that. The extension is much less noticeable if you don’t completely remove area-based lighting (like reset-to-black or torch-lit only do) AND modify fx_light_clr to remove darkvision for races that don’t have darkvision. It can still impact the area’s overall mood, but visibility-wise I don’t see a big difference. I’d say the vast majority of modules use bright environmental lighting, especially the official ones.

Besides, there’s a setting under Graphics > Lighting called “Light Intensity At Range” which modifies light source ranges. Turn it up to 1.0, and the light from a torch will span more than you can see on screen. They could’ve just cranked it up for mobile and left the PC version closer to the original.

Speaking of which, I’m just gonna advise players to either turn that setting down to 0.07 or (preferably) turn off enhanced lighting. The .mdl modifications don’t look quite right.