Lighting issues

Hello,

I’m back again and having another issue !

I’m getting big dark patches on my city streets when you move the camera at certain angles, so they flash on and off as you travel about. The lines are following the edges of the grid squares and look bad and totally unnatural.

I’ve checked on overlapping light spheres and how many lights per tile and it’s nothing outrageous ( never above six and most don’t even overlap ) turned off directional light and it casting shadows, moved lights around and stripped my party so they’re wearing nothing that emits lights but I keep getting it.

Is there a way to stop this or a tried and tested method of lighting a city at night that still enables the player to see where they’re going but looks effective ? Is it better to have lights with more range when compared to their neighbouring light or greater intensity or something like that ?

These are street lamps dotted about near buildings and I’ve never had this issue in an exterior or interior area without water.

Thank you.

Too many light spheres in a tile cause that issue.

1 Like

kamal… How many can I have and does this include any part of the sphere ?

For example… If I have four lights set in a tile but three tiny little overlapping bits of sphere from the adjacent tiles that don’t even touch the other spheres does that make that tile have seven or four ?

the limit is six, and that includes the daynight setting light if that’s enabled for the area.

In your example, you have at least 7, any part of a lightsphere in a tile counts towards the limit, plus the daynight. You don’t need to delete them, even turning them off should do it. iirc it’s six active lights, so you could switch lights on and off as long as you stay under the limit.

Thanks kamal… I deleted all the lights and put in new ones on lamp posts that make no shadows and messed about with them. With directional light switched on in the module properties my limit is only three spheres per square without this happening.

Luckily this area is the start of a new module so I’ve been able to jump my party straight into it and run around the place looking at it from different angles. Even with them stripped of all equipment ( in case they have light making items ) it’s still three that’s the only safe amount with no “black outs.”

This area is always night so needs the lighting and I’ve now had to adjust the default settings so it’s a bit brighter to make up for the lack of street lights. My guards have no torches now too and are feeling very vulnerable in the dark.

Maybe there’s more to this than a simple limit and position of lights within the square matters as I had one light right on a boundary line and it caused more problems than others.

Whatever it is it’s not very easy to try and light both sides of a street with a limit like this and in some cases impossible ! Maybe when making cities sticking buildings and other placeables on the boundary lines is a good idea so light spheres stay in the middle of a tile and don’t overlap at all.

As I said I’ve never had this issue before without water being involved so maybe my placement of placeables in other areas was just plain lucky.

It’s a bit bad really because if somebody casts a light spell or two party members have light emitting items it’s all going to look really bad again and if three have such items they’ll trash the whole place ! I tried it and it all went wrong fast.

  • A tip for anybody else placing lights in an outside area and trying to observe the limit use the sunset setting with the grid on, that way you can see what you’re doing and all the spheres are clearly visible. I was going mad doing it in the dark ! *
1 Like

Is this issue happening in the “boudang” area by chance?

travus… It is indeed, in the market, it just got an overhaul and I’m now wondering if the raised curbs the buildings sit on aren’t helping matters.

I’ve got the docks coming up soon and I’m dreading it !

I was going to mention that about the curbs. I noticed that they still reflected light while the ground went dark in certain circumstances. I wonder if placing a curb strategically under some of the light spheres in the more troublesome locations would help?

Sounds like a cunning plan, I will investigate later as there’s one area that really annoys me and keeps going wrong.

I never noticed all this before when I made it as I didn’t really know what I was doing and was just happy to make a city area that you could roam around in.

It might also be going more wrong or becoming noticeable because the original version was made and play tested on an old laptop with all the settings on low or off but now my pc can handle NWN2.

Which I must say looks pretty good for an old game and it is still of course an awesome game because it’s got a toolset and so much choice in who or what you play as. While testing my mod I’m now getting into being a caster (which I never really bothered with much ) but it’s given me a new dimension to gameplay styles and my testing sorceress is a real bad ass monk killer !

Long live NWN2 !

1 Like

Are shadows turned OFF on the curbs?

Arianna0… Good idea, I just checked and they’re not turned off but most of these curbs are pretty much flat with the ground and aren’t even placeables they’re environment objects, even the main beast one, so they make no shadows on the ground but might be up to no good under it !

The only ones that are placeables are where the ground wasn’t flat enough to lower them into it without losing bits off the sides and they don’t seem to have issues with lights.

I’ll turn them off later and see if this fixes anything and makes it possible to run around waving torches about and letting off light spells without making a mess of the cobblestones.

travus… I was looking at the properties on the kerbs after what Arianna0 said and they can have shadows that are cast on them switched off so it seems you could indeed cover badly behaved over lighted areas in kerbs and not get the problem because they’d block the ground and all lights from affecting it too much. So it’s a good sneaky fix and I might stretch them a bit, thank you.

Arianna0… I turned the shadows off on the main badly behaved one and it can definitely handle one more light source and it’s not such an obvious blackout on the ground nearby when it goes wrong and only at certain angles.

Thanks for the idea and it’s definitely the best it’s been in a long while now but I’m still having to stick with three light sources which is sad.

I have found that some things that SEEM small actually have a LARGE footprint that causes weird shadowing sometimes so check even things that seem innocuous.

Arianna0… I’ve already been finding a few things like that and you’re right some shadows are weird and seem a bit bigger than they should. I’m turning them off as I playtest, along with getting rid of lots of flicker effects that were driving me mad.

I feel a bit sorry for people that played my campaign with all shadows on now as I never used to be capable of doing that on my laptop without it slowing down badly and didn’t know about some of the shadowy mess I had made !

But seeing as this campaign’s pretty old now maybe players didn’t have as many high powered computers that could run NWN2 on full graphics like we can today ( fingers crossed ).

1 Like