MDB Config trouble

So I used MDB Config v1.9 to change the texture files on the old naked body mdb, and after I saved it I got the legs separated from the body.

So I went back and just changed a specular value and saved it again, and this time the legs are joined, but the whole body is floating off the ground.
What’s going on?

I’ve no idea, but the MDBConfig tool doesn’t modify the mesh.

I don’t see any reason. Did you change the mdb number in the process, or just the texture file? In the first case, you may have used an already existing number, and what’s displayed is not what you changed but another model, not compatible with the original feet?
What is the mdb reference you want to change (and what is the new texture file name)? I could try from my end to see if I can find a reason.

Basically what I’ve done is changed p_hhf_nk_body01 with p_hhf_nk_body02 so if I select ArmorVisualType 10, I get the later high-res naked body with the rounded shoulders by default.
And then made a clothing blueprint I called naked, that used the old model and textures, to get my heads to be the best colour compromise between the two, because a lot of the clothing I use, uses the old zylch model.
Anyway, after much changing, it’s working again, so I’m not sure what the problem was. The last thing I did was to change the mdb name from upper case to lower case, just in windows explorer, because it was in lower case in MDB Config. Not sure if that could make a difference. Thanks for the replies, I’ll mark rjshae’s reply as the solution, because I’d be lost without MDB Config.
A lot of trouble for something that should have been simple, but I’d rather have it default to this seamless body, than the old one, or the clothed “naked body”

I’m still having lots of random trouble with MDB Config.
I’m trying to change the specular colour to 255-255-255, specular value to 0.01, & specular power to 0.0 of Xaltar’s Tiefling head P_HTF_Head02.
Changing any single one of the above, results in the eyes disappearing from the model and the specular value going right over the top.

I’m thinking now that the problem might be my version of java.
I’m using Version 8 update 281 (build 1.8.0_281-b09)
If I need to find the older version of java for MDB Config, can I have two versions installed simultaneously, or is this not the problem?
Edit: So I installed java 7, how do I add the path to this shortcut “F:\Mods\Neverwinter Nights 2\mdbconfig_v1.9\MDBConfig.jar” to make it use this version C:\Program Files (x86)\Java\jre7\bin\java.exe

I tried just setting the path at the command prompt SET PATH=C:\Program Files (x86)\Java\jre7\bin\java.exe
But either this didn’t work, or the java version isn’t the problem, because still no eyes.

There’s a known issue with some floating point values not being converted correctly for the ‘Specular value’ field. One of these days I’ll try to find a fix. I’ve been using Blender with nwn2mdb to edit the values, so I have a work-around alas.

Thanks for the reply rjshae
I’ve made those same changes to a lot of other heads (including most of Xalter’s ones), but this head just won’t play ball.
Can you confirm if MDB works properly with the current java version?

I don’t know why it wouldn’t, if you’re at or past the minimum version. I’m running it with the same version as you listed above.

@olnorton Okay, I believe I have a fix for the problem. Can you try the new version 1.10 of MDBConfig and see if the issue is resolved?

@andgalf Please give the new version a try. Sorry for the long delay; I meant to work on it but got a little lazy with my retirement &c.


@rjshae I don’t remember what I said about this…so I’m a bit confused right now.

So sorry:

Ah, now I remember. Thanks for reminding me and updating MDB Config.

1 Like

Have you got a link for the new version.
A search of this site for MDB Config only brings up two posts from 5 or 6 years ago.


Thanks! That certainly worked for the tiefling head.
I’m glad it worked, she’s one of my favourite heads.