MDB/GR2 to FBX & FBX to MDB/GR2 tools


#41

I haven’t seen an option to vary the specular shader in the MDB file. All you can do is vary the parameters in the material data type.

Blender has a number of shaders available, if that matters.

https://docs.blender.org/manual/en/dev/render/blender_render/materials/properties/specular_shaders.html


#42

Thanks - That’s good to know.


#43

Just reporting a minor issue:

I built a simple model consisting of two non-triangulated rectangles, then exported it to FBX format. When I ran it through the converter, it successfully generated an MDB file. However, the model crashed the NWN2 toolkit.

I checked the log.txt and it did show an error about non-triangulated faces, but it generated an MDB file anyway. If I perform a triangulate prior to exporting to FBX, the model displays normally in the toolset.


#44

Thanks for reporting.

My tool sometimes continues the conversion process when it encounters an error because maybe the output is useful anyway. However, based on what you expected, maybe the tool would be more usable if no output is generated whenever it encounters an error. I think I’ll change this on next version.


#45

It’s strange because I use extensively quads for my meshes. I export to FBX as quads, the Freshlook tool convert them to tri when creating the mdb. I have not experienced a crash of the toolset with these models.


#46

I guess you have Triangulate checked in the FBX export options of 3ds Max. Blender (as of 2.79) doesn’t have such option.

My tool expects polygons to be triangles and will emit an error otherwise. There is a reason for not converting quads tro tris automatically. There is two ways to split a quad into two triangles, depending of which of the two diagonals is choosen for the split, and each way can produce different shading results, especially for low poly models. So my decision was that the artist decides how to triangulate.


#47

Yes, and maintaining quads (where possible) is good for when one need to do things like splits or loop cuts. It’s a nuisance to go around and flip all the triangles after a split.


#48

I have a problem when using this tool to rig bodies.

I use 3DS Max 2018 without problem (thanks for Freshlook help) for heads and hairs.

I tried to rig a body and it’s floating in the air a bent forward (like the wraith does). The idle animations are working, the body can be moved.

The mesh pivot is set at 0,0,0. The fbx export settings are the ones working for heads and hairs.

The first time I used 3DS Max skinutilities to copy the rig weight from another body. I even tried to rig only to the root bone. In both cases I have the same floating body. Note that I successfully rigged this body before when using tazpn tool, which I can no more use, because I have no more a compatible 3DS version.

Here is a screenshot from the toolset (this is the version rigged only to the root bone). The wraith is here only to show the similarity, the body is rigged to a P_HHF skeleton.

EDIT :When I open the created mdb in Gmax. The skin modifier is here but the rigged bone are not the one I used in 3DS Max. For example I didn’t use all the talkdummy, but they are in the mdb. I selected the P_HHF_skel bone, but it’s not in the mdb.


#49

Has the body object in 3ds Max the property HEAD = 1.0 ? If so, set to 0.0 or remove it.


#50

user defined property is empty in 3DS Max


#51

Can you send me the FBX?


#52

Problem solved with Freslook help. Thanks

When I had rigged my body, I exported it to FBX format, then converted it to MDB.

Then I used mdbconfig to modify the textures and specular value. But, and this is the error I did, I also checked the “Cutscene mesh” box.

The tool works correctly when I don’t check this damned box !!!


#53

Thanks for the information, that’s nice to know what happened.


#54

Just to clarify. The flag “Cutscene Mesh” in mdbconfig is the same flag that “Head (cutscene)” in Expotron and “HEAD” property in my tool. As far as I know, it should only be used for heads. That’s why I asked to krighaur the following question:


#55

There is specifical installation requirement?
Just downloaded it,when i drag and drop an mbd over nw2fbx,a small window open for 1/2 second then close,nothing else happen,no message.


#56

Check your log.txt file… it might have an error.
If you just installed… I can guess what went wrong… you need to update your config file to point to your NWN2 install directory.


#57

Made it,still not working.
Gonna redownload…just in case.

Edit it still tell me he cannot find an installation directory even if i pointed it in the config file.


#58

Can you paste config.yml?

It could be you need to uncomment the line (remove the # at the beginning).


#59

(Optional) Directory where NWN2 is installed.

nwn2_home: F:\Atari\Neverwinter Nights 2

The one on the second line?Well they don t show here but i have them on both
Ok it was that <3


#60

Had the same problem “Cannot find a NWN2 installation directory. Edit the config.yml file and put the directory where NWN2 is installed.”

I have Gog NWN2 originally installed at F:\gogGames\NWN2 Complete. After pointing the second entry “nwn2_home: F:\gogGames\NWN2 Complete” I still got the error. Note # is removed.

To fix I reinstalled NWN2 under F:\gogGames\Neverwinter Nights 2, with “nwn2_home: F:\gogGames\Neverwinter Nights 2” on the second line of config.yml. Only the # on the second line removed.

I am still not convinced I didn’t do something wrong in the first instance. For it seems weird that NWN2 should have to be in a particular named directory. But its working.