Merchants in some old modules crashing the EE?

Is there a known issue connected to merchants in some old modules making the EE crash when opening their shop window? This just happened to me in “Lords of Darkness 1”, and I remember that I had this issue with one other module in the past, but I don’t recall which one (I stopped playing it shortly after starting it because of that).

Has this happened to anyone else? Does anyone have a clue what it could be related to? If this happens, it happens reliably, btw. It is not random, the EE will always crash in these instances, whenever the shop window is opened. But it’s only in specific modules, the grand majority works fine.

Crashing when opening store is usually related to baseitems.2da inconsistency. Are you sure you don’t have baseitems.2da in development folder?


I only had Kamyrin’s x0_skill_ctrap.dlg in the development folder, the crafting dialogue needed for the Customize Character Override Hak. I disabled that, and I also disabled userpatch.ini and cleared the override folder, but the issue persists. And it happened only in these two modules, I played lots where it wasn’t a problem. Could it be something related to CEP 1?

Yes, if you didn’t download my version of CEP - CEP1 Complete then these issues are absolutely normal. They have nothing to do with EE though.

1 Like

I don’t remember which version I downloaded, but it might have been this one:

Is that your version that you would recommend, or do I need another one?

I see now though that other players in the comment section of the module had the same issue, and one user koro said: “USE CEP v1.x haks and DO NOT use ‘Cep1 complete (pre-release)’ files. Problems just disappeared” …

Yes that is the one I recommended. Uh weird, could you verify the problem goes away with original CEP1 haks, ie the version CEP v1.x?

Okay, I downloaded and unzipped CEP v1.x, made a backup of my hak folder, then copied the hakpaks of CEP v1.x into my hak folder and let them override what was already there. But the game still crashes when the merchant windows are opened.

EDIT: I tested with my old savegame, does that make a difference? Would changes to the hakpaks appear in the savegame, or would I have to start a new game?

I made a fresh install of your CEP1 version into an empty hak folder, along with the modules hakpaks, and now the merchant works and the game does not crash, so I can confirm your solution and NOT koro’s.

I was pretty sure though that I did not have CEP1.x installed previously. Weird. But I just remembered, I did apply the cloak fix to the CEP files, maybe that caused it? I’m going to try and replicate that now to see what happens.

I applied the cloak fix to cep1patch152.hak, cep1patch153.hak, and cep2da.hak with The Krit’s CloakHakker.EXE, which does indeed change the baseitems.2da in those hakpaks, but it still works fine without crashes. So it seems these fixes weren’t the cause. I guess I must have messed something up with my previous CEP1 installation then. In any case, it’s fixed now thanks to your version.

Thank you so much for your quick help! :slightly_smiling_face:

It could very well be it.

I downloaded the mod in question to see what haks does it use.

It only uses cep2da.hak and cep1patch.hak which means that the cloak fix you applied into cep1patch152.hak 153 and cep2da will not take any effect. The highest priority for this module has cep1patch.2da and in my Complete version all these patch haks contais same files to prevent these kind of issues. So the baseitems.2da will be in it and thus take higher priority than baseitems.2da you modified with that Krit’s program.

What is the problem with cloaks anyway? The grey 3D cloaks? I don’t think that can be fixed via haks, except disabling 3d models completely.

In some older modules including some CEP1 ones, dyeing cloaks has no effect, they are always yellow/beige. After I applied The Krit’s hack to these three files, I could color those cloaks again, so it worked. But I don’t remember the module, in which I had those issues and managed to fix them. This time I only applied the hack to see whether it was the cause of CEP1 merchants crashing in Lords of Darkness, and it wasn’t.

Please try to apply Krits fix into cep1patch.hak as well and load the savegame and try open store what happens. (And yes btw, these kind of issues are not related/stored in saved game so no need for replay to verify.)

If I do that, Cloak Hakker says “This file does not seem to contain baseitems.2da”.

I’m also pretty sure I only applied it to the three files listed above, the last time, because that’s what Cloak Hakker’s download page recommends. And I had no issues with cloaks and shops in other old modules (including CEP1 ones) after I did that. I suppose there was something wrong in my previous CEP1 installation that would only cause trouble with very few modules like Lords of Darkness though, due to something specific in them?

Tested that tool and it does nothing for CEP 1 Complete = this version does not have that problem already.

1 Like

Cool! I guess I really had the wrong version then.

IIRC you need to start a new game to “refresh” the containers, but it has been quite a few years since the problem occurred for me last time (fixed it on my install so long ago…)