Merging two different spells.2da's

Hi all,
I have a problem regarding an existing spells.2da file that I have in my campaign folder, for a campaign I’m working on. This 2da file comes with the “creatures compilation pak” that includes models I need for my campaign. The 2da adds a few new spells to creatures, none of which I care about using for my campaign.

However the issue I am having, is that to use tony k’s monster ai 2.9 and kaedrin’s prc together, I need to use a different spells.2da file. I have spent (no joke) at least 20+ hours the past week trying to fix corrupt module and 2da files, so I am now hesitant to try anything on my own, without first asking for help.

Would it be as simple as me deleting the 2da file that comes with the creature compilation and the creature files (folders) that use those new spells with the 2da? Could I then in theory, just use tony k’s ai .2da file and kaedrin’s pack with no issues?

You will need to keep appearance.2da for the new creatures to exist in the campaign. Obviously, if you don’t keep the spells.2da file that comes with them, the new creatures will get the spells from tony k’s or kaedrin’s pack instead (NWN2 doesn’t find anything by name, but by its line number in the 2da files), but if you delete said creatures then everything will be fine.

If you’re using this compilation, there shouldn’t be any conflict though, according to this table.

1 Like

Thank you very much 4760, that puts my mind at ease. I’ll go ahead and give it a try!

Sadly I think I have just messed everything up. The ai seems to just stand around doing nothing, including companions when hostile and now if I try and load my campaign from the in game menu, it gives me a module is corrupt or out of date version error.
Any tips on where I went wrong, would be well appreciated. Thanks

Maybe if you check the creature’s spells in it’s properties it’s searching for spells it cannot find now.

Or maybe Tony K’s /Kaedrin’s 2da doesn’t include your new creatures and that’s making it go wobbly.

I don’t know how these things work and always avoid swapping about custom content if possible.

Take one out and put in the other to see what happens and that’ll give you a clue where the conflict is.

Yeah I’ve always avoided it too Tsongo, but I have a slightly better understanding nowadays of what’s what, but it’s still a hefty learning curve and googling tends to add more questions than answers.

I’ve managed to salvage the corrupted module thankfully and it now starts properly again. I think I will take your advice and leave the ai and PRC enhancements to the experts who choose to add it on, with the final campaign product.

It drives me insane, just when you think you have something worked out in comes another version and you’re back to clueless again.

If you really want to waste massive amounts of time staring at a screen and getting nowhere you should try ordering parts for a thirty year old imported Japanese van !

1 Like

Are you sure only spells.2da are conflicting?

1 Like

Thanks for asking.
I tried to give it another few attempts. You were right, there were some sneaky .2da files that were duplicates in subfolders of the creatures in the creature compilation pack. So I deleted those files from their respective folders, to keep the main .2da’s as the “go to”, so maybe that could be causing an issue.
The “main .2da’s”, being the ones that came with the creature pack. The other three haks I use - the mega tilesets and beautiful armors/weapons/hairstyles and pj placeables, don’t appear to have any .2da’s that the creature compilation or the improved a.i do. I can get those initial 4 hakpaks to work fine, by adding them to my campaign folder and override folders, but adding the companion and monster ai 2.9, is where it fails.

The companion and monster ai 2.9, comes with two spell.2da’s as well, one called spells.2da and another backup file called spellsundead.2da (that need to be renamed to spells.2da in a specific instance which I couldn’t quite understand) - something to do with monster global settings or something.
Either way, I attempted both versions of that .2da and the ai still just stands around. Now however, they seem to at least ‘face_target’ towards hostiles, but still nothing.

Hopefully that all made sense.

The priority in case of conflict (same name) is that the file loaded last is the one used, so any 2da in a subfolder will take precedence over the same in the root folder (simplified version, as there’s also a rule with hak>override>campaign>module).

I don’t have Kaedrin’s pack, so I can’t be sure if the extra classes and spells require some modifications in the stock scripts. There could be the issue you’re facing with the companions doing nothing. Or, and it happened to me, you somehow clicked on the AI button at the bottom left of the screen, and set everybody to not use their AI but wait for the player’s instructions.

1 Like

Ah, so to clarify, are you saying that it is ok to have a duplicate .2da in a subfolder -which then takes precedence over one in a root folder? If so, that’s cool to know.

Also to clarify, the above testing I did before your last comment, I tested only using the companion and henchman A.I 2.9. I’m not going to include Kaedrin’s hak pak now.

Thanks again for your assisting

Then could you check that the AI on your companions is active? You can do that either through the character sheet (is the puppet mode on or off?):

or directly for the whole party near the rest button:

1 Like

Sure thing mate. It’s late now, I’ll reinstall it tomorrow and let you know.

No need to reinstall, just press “C” to open the character sheet and check if the puppet mode is deactived or not or click on the third eye icon (the smaller one I circled in red) and see if the companions start doing stuff by themselves.

Ah ok then, I jumped ingame just now and the (near the rest button) was enabled and puppet mode is disabled (marionnette mode for you i guess)

Then everything’s fine there… I’m afraid I don’t know what’s going on, I have companion and monster ai 2.9 installed, and it works as expected.
OK, let’s try this then: move the ai 2.9 folder out of the campaign (or out of the override, I don’t exactly know where you put it) and check if the companions behave as expected then.
By the way,do you use the hak or the override version? If your campaign is configured to use the hak, the spells.2da and other duplicates conflict will remain.

1 Like

Yeah it’s a bit weird. I’m assuming that it must be a 2da issue with one of the other packs I’m using.

  • Pj’s placeables
  • monster pack
  • mega tileset pack

Currently I don’t use any haks in my module, everything is mostly in campaign folder, except for those things which don’t quite work alone in the campaign or override folder. For those, I’ve got them in the override as well.
For companion and monster ai 2.9, I tried override first, then campaign folder, then override+campaign. All failed.

By the way, thank you trying to assist! I appreciate it.

You’re welcome :wink:

I’m afraid you’ll have to check each of them to see if spells.2da and appearance.2da are included - normally, the reserved ranges are followed, so you’ll “just” need to copy/paste a few lines from one 2da to your master version.

And without anything? If it still doesn’t work, we’ll know it’s not in companion and monster ai we’ll have to look for the culprit!


@4760 From memory, I tried without (using the older version .2da provided by creature pak) and with. Just can’t remember if I tried those two options, once in the campaign folder and once in the override…

Ahh the dreaded moment has arrived, I guess. I’ve been avoiding learning the intricacies of .2da modifying, but if I’m ever to release my campaign, I’ll have to learn sooner or later.

Anyone got a good link for a tutorial on how it’s done, please?

1 Like

Don’t worry KevL_s has saved you all the hassle of going blind as your eyes struggle to see what is on what line and the never ending scrolling to check, when editing 2da, use this… Yata | The Neverwinter Vault

All you do is change the numbers on whatever you want, I used it to swap what class could do what spell.