Missing campaign tab?

I know I’ve done this before and it’s something to do with deleting the toolset to get it back but can’t remember and after searching the internet could only find an xp or vista solution.

I’ve lost my campaign tab and would like it back and I’m on windows 7. But… The appearance wizard works perfectly with no hiccups and I don’t want to curse it by reinstalling the toolset after a delete.

I’m in module mode not directory so is there a way to move two conversations into the campaign folder without getting the tab back as I never use it anyway, need it for this one task and would prefer having an appearance wizard that doesn’t crash.

So how do you get the tab back but preferably how do I convert two conversations to campaign without the tab open ?

I’m not sure if this is going to help in this case (and I’m not sure what you mean by Campaign Tab but…I’ve had issues where I changed the look in the Toolset and wanted it to get back to the vanilla look (maybe that has something to do with anything, I don’t know):

Toolset - lost Blueprint/Terrain window
Lost the main Blueprint/Terrain/Tiles window.
Nothing I did could bring it back. Using the View/Options/Windows/Reset,
although it had worked in the past, no longer worked.

Solution: Delete/rename the file in your
‘Documents and Settings//Local Settings/Application Data\NWN2 Toolset\en-GB’
folder called WindowConfig.xml

Local Settings is a hidden folder so make sure (for XP anyway) that you tick the box called
‘Show hidden files and folders’ in Explorer the Tools/FolderOptions/View.
You may also need to UNTICK the box called ‘Hide Protected Operating System Files’.

If I would want a dialogue file in the campaign folder, I would just copy the file directly in Windows to the campaign folder, I think.

If you’re in Campaign Mode however, and If you use the plugin Powertools (or what it’s called) you can just make a new conversation and choose it as a Campaign Conversation, and then copy all the nodes from the conversation you have in the module directory, to the new conversation you’ve put in the Campaign. Then erase the original one, and then rename the new Campaign Conversation to the same name as you had with the original. I hope you can understand what I’m saying here (it’s a bit convoluted).

andgalf… Thanks and I do understand what you mean but can’t make a campaign conversation straight up as a new conversation as I don’t have any plugins.

However I had a brain wave and for the first time ever I saved as a directory, then I opened it and copied the two dlg files straight into the campaign folder and they now show up across modules so it worked. So it was as you said to copy it with windows but you can’t get to it in module mode.

In your first post the deleting of the toolset is definitely the way to get your things back as I know I did it before and was quite worried about the thought of deleting in case it went wrong !

Anyway it’s working now so all is good, thank you.

1 Like

In the Toolset, go to “View”, go to “Option”. A window will pop-up. Click “Reset” at the bottom of the screen. Have a nice day and take care.

1 Like

@raymondsebas Ah, ok. That sound like like an easier way to do it, I suppose.

1 Like

@raymondsebas,

Unfortunately, this does not always work.

Deleting the file outside of the toolset is the only sure fire way of doing it, if I recall correctly.

I suppose you could test what I mean by closing the tab manually and try resetting, but I am reasonably sure it fails to help more often than not. (I wish resetting did work!)

1 Like

@Lance_Botelle With all due respect, I never had to do what you say. I have lost my tabs quite often while doing the Sunless Citadel even recently (I’m not sure why they go away like this without warning) and the method mentioned has always worked for me. :slightly_smiling_face:

@raymondsebas

I wish it worked for me. … :weary:

But sadly, it never has. It’s good to know it works for some people then.

@Lance_Botelle I’m sorry to play Captain Obvious and probably you already did it, however after clicking the “Reset” button, you need to restart the Toolset (It’s just a clarification and I have no doubt that you have already done so). I think it’s a shame that this normal option doesn’t work for you. :neutral_face:

@raymondsebas,

Yes, I definitely did that. I first experienced the issue years ago, and I tried all the resets and restarts, but all to no avail.

In the end, somebody in the old forums gave me the heads up how to get them back and I made a note in my files, so I would never forget.

I may even have an old blog post to link to it…

Yes, here is my first experience and the fix required … See comment at the end.

Here is a copy of the relevant info from that post …

Q: Help! My toolbars are gone!

A: Click on the View menu and choose Options… On the left side, choose Windows. Click the Reset button, then click OK. Close the toolset, and reopen it. If this doesn’t correct the issue, or if your menu bar is gone, close the toolset. Open up Windows Explorer, and paste this text into the Address bar:

Windows XP: %USERPROFILE%\Local Settings\Application Data Windows
Vista:
%USERPROFILE%\AppData\LocalHit Enter.

From there, delete the folder named NWN2 Toolset. That will reset everything for when you next launch the toolset.
I had to do the latter. I also received a post from Sunjammer, who, among his post, advised the following method to remove the close crosses from the tabs completely:

To help avoid a recurrence go to your %USERPROFILE%\Local Settings\Application Data Windows\NWN2 Toolset[lang]\ folder and open the WindowConfig.xml file in your text editor of choice. Then find and replace all instances of CloseButton=“True” with CloseButton=“False”.
Just to be on the safe side, I have also made a backup of the WindowsConfig.xml file now as well.

2 Likes

Just a quick note on the reset button… Don’t forget to turn auto save off again !

ps. It didn’t work for me either but this happened when one just wasn’t there for no reason, but I think it has worked before when I’ve dragged one to somewhere that doesn’t exist by accident.

1 Like

I confirm!

You’re lucky then! It never worked for me.

2 Likes