MODEL HELP REQUIRED: Pedestal Requires 4 Sides! (RESOLVED!)

Hi All,

UPDATE: Maybe this is something @4760 or @rjshae may be able to help me with?

I have a pedestal that was made by Kalister (for the crypt tileset), but I am unable to find a link to the download. (I have now provided a download link to the files in question.)

Basically, I am in the process of updating the “look” of the pedestal to include some “markings” that appear on each of the four sides. So far, after editing the dds file, I discovered that I can only edit two of the pedestal’s four sides - I need to be able to edit all four. (I think it mirrors the opposite sides.)

The model that only allows me to edit only two sides is called PLC_CPT_pedestal_01

It remains that if anyone with the modelling skills is able to update the first placeable object model so that it has four unique sides for me to be able to edit and update, that would be helpful!

Let me know if you need the files and I will upload them.

Thanks in advance.

The files (valid for 30 days):

I managed to get the model into Blender, but I have absolutely no idea where to begin (reading too much to find specifics) … If anybody wanted to record a video of what they do to change two sides to make all four editable in this case, it may go some way to help educate, but that was just an idea … :slight_smile: I would settle for the finished product done by somebody who knows what they are doing … but I would certainly watch the video for educational purposes. EDIT: Found some videos and trying to work this out.

@Lance_Botelle Here you go:
https://drive.google.com/file/d/10oQn6tJgRNOOFS_PYUseGm3UkIRSq55r/view?usp=sharing

1 Like

@rjshae

Wow! - Excellent - I am just about to check it now then … saves me going through hours more videos!

Videos … I reached something about UV Maps which looked like I was getting somewhere … but I was still out of my league.

Will report back shortly with result with yours! :slight_smile:

YES! - Excellent - Here is the model now showing the two sides I could not see in game before … You can see they once showed “Not Used”, which means I can now edit the image for my own purposes.

Well done! :+1:

By the way, is this something I would have been able to do in Blender myself, or did it involve more complicated tools?

For instance, I had this when I was trying to assign the textures, which appeared all over the place compared to the tutorial I was watching … i.e. The outline image was not matching the area I thought needed to be used …

What is happening here? It looks like the image needs to rotate to fit the “mapping”? Is that even the right word to use?

Out of interest I checked out your model in Blender and that responded as I expected with all the parts aligning up … what tool did you use to fix that?

YOUR MODEL …

Yes you could do it in Blender by selectively modifying the UV mapping. That’s how I did it: I chose just those face regions that are overlapping then relocated their UV maps to the unused parts of the texture. I’m not quite sure I understand why Kalister overlaid them.

2 Likes

That’s the part I am still trying to learn in case I ever encounter a similar problem.

I tried “unwrap” first, which appeared to unlock them to that image above, but trying to “rewrap” (?) them currently escapes me. I thought I may have to “assign” them but that appears to do nothing. I am missing some critical aspect of Blender control here at the moment.

Nevertheless, I am extremely grateful for you doing this for me, as it allows me to avoid some horrendous scripting if I had to rely on only two surfaces.

A rewrap will destroy the association with the diffuse texture map. That’s normally the first step in applying a texture to a new model. Once set, you shouldn’t need to do it again unless you are starting from scratch.

When you select mesh faces in the 3D view they will show up highlighted in the UV map. In the UV Map you can use ‘g’ (for grab) then drag them about, ‘s’ to scale them, and so on. If you want to learn Blender (and who wouldn’t? :wink:) I suggest trying some of the excellent tutorial videos available.

1 Like

This did not work for me using the original model. But it did work when using your module. (Compare the images above between your model and the original I was trying to work with. Your mesh matches up, whereas the original did not even show until I did the “unwrap” option - and then nothing lined up.)

Experimenting further, I could only grab and scale “mesh” in your model. However, they were only triangles, which made altering them to fit over the texture picture difficult.

I guess I will have to watch a few more videos… :wink:

Thanks again for all your help. :+1:

You may not have had UV Sync Selection picked in the UV Map. That’s the little double-arrow icon in edit mode. I flip it on or off depending on what I’m doing.

I will keep an eye open for that then and test again a little later - but I still thought it strange that your model worked first time with no obvious “issues” whereas the original I could not appear to get to work very well at all … I will try to compare and fiddle some more and let you know if I discover anything else as well.

@rjshae

OK, I double checked what you said regarding seeing the meshes in the old module and I still get nothing selected after ensuring the UV Sync is on …

NOTE: I have selected a part of the model on the right hand side but nothing is highlighted in the left hand pane.

What version are you using? Any specific plugin?

I downloaded and used the latest 3.0.1 Blender and the 0.13 alpha plugin from here: https://github.com/Arbos/nwn2mdk/releases Perhaps there is something I am missing in my setup … but likely just my ignorance. :wink:

The mesh needs to be in edit mode in the 3D view before it will show the UV map; you’re viewing it in object mode.

@rjshae

First, thanks for your continued help in understanding what is going on here. :slight_smile:

If you check out the image above, it says I am already in Edit Mode at the top of the right hand window. That is how I can select the individual pane on the pedestal (as image).

However, you say “the mesh needs to be in edit mode”, but I do not see any way to make that change anywhere else. i.e. I understood that the TAB key made the object toggle between OBJECT and EDIT mode.

How can I change the mesh to EDIT mode?

Oh, I know what’s going on. The UV mesh is below the image:

I had to move it up to place it over the texture map. To address that, I select all (a) then shift it up by two heights (g y 2 ).

Sorry, I just do that by reflex now.

Ah Excellent!

That explains the reason why I had no idea what was going on!

You have answered the riddle!

I thought there was nothing for me to edit! :exploding_head:

Problem solved (again)! :+1:

Thanks @rjshae

PS: How did it get down there?

PS: How did it get down there?

I’m not exactly sure. It happens fairly frequently when I port a model in a different format. It may have been built in a different 3D engine.

2 Likes

I guess that sometimes moving some UV parts up, down, right or left helps reusing the same areas of the texture without having overlapping faces, making it easier to place them carefully.

1 Like

@4760

The way it appeared to me made no sense. It looked like it had missed all the textures. But this is all new to me and so I am not familiar with the nuances of such.

If I ever become more involved in such, then maybe it’ll make more sense. :slightly_smiling_face:

Thanks.

The textures actually tile in the UV map space of Blender. The View tab along the right has a ‘Repeat Image’ option.

1 Like