Models are not reading pallets from my 2da file for a compilation I'm creating (Solved)

Hi all,
Here I’m with more questions for my project.

On, to the point:

-I’m creating my armor and robes pack 2da for the OC replace compilation I’m creating, but when I loaded the files to test them in a module, I saw that the 2da is reading the models, but not the palets (see example images).

What did I do?
I make a test file starting with CODI dustman robes, copied the lines 30 and 31 corresponding to CODI robes from its 2da file

In the original NWN 2da these lines are reserved so I added them as 39 and 40, and renamed the mdl and plt to match this numbers, for example pfa0_robe030.mdl is now pfa0_robe039.mdl and pfa0_robe031.mdl is now pfa0_robe040.mdl

Model renaming

CODI Dustman robes 2da

Original NWN 2da with added lines 39 and 40 (Dustman robes)

I checked files twice and build a hak but in the module, as you can see in the images the palets are not loading.

Any advice about what I’m doing wrong.

While I’m not an expert I think renaming the mdl file is not enough. You would have to edit its internal references also.

1 Like

You need to open the mdl’s (with notepad for example) and search and replace pfh0_robe030 with pfh0_robe039 (to stay with your example). Should also work if you just search and replace ‘_robe030’ with ‘_robe039’.

You need to do this because your mdl is still referencing the old plt inside.

1 Like

Thanks boodah, I will try it and let you know.

Thanks for the help guys, it is solved!