My Vault messages don't seem to arrive

Yesterday I sent a message to a module author via the Vault’s “Contact” messaging system. I had checked the box “Send a copy to yourself”, but I didn’t get any copy of my message. I tried again, same (lack of) result. So then I wrote one to Tarot Redhand, and today I also messaged him here on the forums to ask whether he had gotten the Vault message, but he said no.

When he sent a Vault message to me, I got it. When I sent one back, this time without checking “Send a copy to yourself” though, once again, it didn’t.

So it looks like I can receive Vault messages but when I sent some myself, they are lost and never arrive. Possibly get blocked or something? But I also never get a warning. The system just acts like the message was sent but it does not arrive.

Any idea what could be the cause? It worked perfectly fine before (well, looks like my last Vault message is from April, but nothing significantly changed on my system since then - at least, that I know of).