New Picklock Icons Problem

I have tried to use the New Picklock Icons, but do not see any in-game changes.

I have tried the hak and override versions without any success.

Has anyone used this successfully? If so, I would really appreciate some help in getting this to work.

I used NWN Explorer to try and investigate my problem with the coloured lock picks. These are the only references to ii_picks that I found…

NWN Main Data
- data\textures_01.bif
  - Images, Icon, Inventory
    - iit_picks_001.tga
NWN Texture Packs
- GUI_32bit.erf
  - Images, Icon, Inventory

I the tried renaming the iit_picks_002.tga to iit_picks_001.tga, which I installed. When I ran my test, lock pick +1 was yellow.

I know nothing about modding, but I guess that NWN uses a common image/icon for all lock picks, which is why I am not seeing any changes when I install the mod. There probably needs to be something that makes NWN use a different image/icon for each of the possible lock picks.

Apologies if what I said is nonsense - I have never written a mod, so it is very likely that I just don’t understand what is supposed to happen.

Any help or feedback will be very much appreciated.

hi, @Surazal,
While I can’t solve this problem directly, I’ve found some information explaining, how things work.

Basically, you’ve got that right, one model = one icon=one tga/dds - see that thread - TAD’s explanation here:How do I use several models for a single base item?
Also, you can check this recoloring:

Hope, that helps.

Many thanks for your explanation @DrA, much appreciated.

I will pass this information on to @quevy, who is the author of the mod - maybe he will provide an update.

I tried again on a new module, I added icons and uti files in override and placed on the ground the picks, they are displayed with different icon.

I did the same thing by mounting the hak version, in both cases it works.

@quevy, many thanks for taking the time to test this.

If you place the picks in your inventory, do they still display the different colours?

This is what I have been doing to perform the test.

Yes, different colours.

@quevy, just tested mine again and it still doesn’t work.

I can’t think what I must be doing wrong.

@DrA, any chance that you could make the time to see if it works for you as well?

Sure, I’ll try it. Do you plan to use other item haks with it? Like CEP or Q?

@DrA, Many thanks. I do use CEP and Project Q when required.

I’ve checked override version (and I have the newest CEP and 1.69 patch) - everything works OK.
Seems like NWN:EE issue. I’m not sure, how things are arranged in NWN:EE - is it possible, that they use different solutions for palettes, or override works differently?
For NWN up to 1.69 top priority should be override, then goes the rest.

I’ll try mix with Q next, but I think some clues form people using EE would be needed here.

Many thanks for taking the time to test this.

I am really confused. Just tried it on a vanilla installation and it still doesn’t work.

I am using Pretty Good Character Creator to perform my tests. I wonder if this is an exception Mod.

Will try with another Mod on a vanilla installation later and see if anything is different.

I have a doubt that you already have a break-in tools in the inventory of a saved PG. They don’t think they work, because they are saved with the basic icon. Have you tried acquiring new items?

@quevy, I tried purchasing a Lockpick +3 from the merchant in Pretty Good character creator and my inventory and the merchant’s inventory did not display the coloured icons.

@Surazal, quick update - with Project Q everything still works just fine.

Something seems to interfere with lockpicks in your module - this can happen if you have multiple items with this same name in Override.

Usual bug-hunting process recommends emptying Override folder, then creating brand new test module with new hak or Override items you’ve wanted to test. Other than that, I’ve run out of ideas, what is causing this problem.

last minute news:
I’ve just got PGP - will try with this module to see if it’s somehow related to it.


Already tried this and it still doesn’t work.

Many thanks for taking the time to try and help me - very much appreciated.

Tested with PGP v.4.4. - doesn’t work in merchant - all lockpicks in store look vanilla, BUT those I’ve created in a new module and were exported in PC’s inventory, look just as intended. Seems, that merchant doesn’t use new stuff automatically, and you’ll need to add it to the store or inventory manually.

@DrA, many thanks for all your help.

I will keep it installed and see what happens when I use a different Mod in NWN.

Things I will try for EE…

  1. Use the Hak.
  2. Use the Hak as a User Patch file.
  3. Try placing the files in the ovr folder rather than the override.