Noobie still needs HELP!

I posted last week and got a bunch of advice, but none of it worked… Here is a more detailed look at my problem with some visuals. Hopefully better developers and designers than me will see something that I’m missing. Here’s the sample area that I’m testing in:

You can see the 2 encounters. encounter1 is NEVER hostile to the player when it’s triggered. Encounter n2_en_easy01 works fine when triggered. Here are the properties for both encounters:

To me they both look almost identical with only a few minor differences. So WTF is making one hostile and the other not?! Even thought they both have nothing listed in the Scripts section, I’ve tried adding in several different attack scripts from the toolset, nothing works.

I’m starting to loose it and am close to giving up on building any mods, any help the community can provide would be very much appreciated.


Did you happen to create a duplicate c_orc template?

No, encounter1 was a custom encounter created as described in the NWN2 Toolset Manual and n2_en_easy01 was one of the canned encounters from the toolset. It was one of the encounters listed when I clicked the “+” next to the “Easy” encounter category.

it worked fine for me here.

“encounter1” was created by rightclicking the stock blueprint and CreateBlueprint->Module, then filling in values to mimic the stock blueprint. I also tried with CopyBlueprint->Module and it worked that way too.

Orcs of any of the three encounters went aggro as soon as they spawned ingame,

Sorry but I don’t understand what “not hostile” means. Do the orcs spawn but are not hostile to the player or are they not spawning at all?

kevL_s, excellent! Thanks! I’ll try exactly what you’ve done here and see if it works.

kevL_s, it worked like a charm! Thanks. But now for the next question… Let’s say I want an encounter with 2 giant spiders. There are no templates listed for that. When I go through the same steps of creating the encounter, the spiders are not hostile, don’t attack, and when I hover the cursor over them, all I get is the conversation bubble. How do I get them to behave the same way as the orcs? Do I copy the template and change the creatures?

andysks, they spawn, but do not attack. The cursor never give me the attack option, only the conversation bubble.

that strikes me as extremely odd. Every creature blueprint has a variable called “Faction ID” (eg. Hostile, Commoner, Merchant, Defender, etc) – and if a creature’s faction is Hostile on its blueprint, it should spawn hostile unless something is changing it.

Also, note that you don’t have to create a new encounter blueprint each time you want to paint an encounter. A stock encounter blueprint can be painted on the ground; select it. It’s settings can then be adjusted however you wish. But make sure the encounter on the ground is selected, not the stock/default blueprint, before making adjustments.

(Think in terms of “blueprint”, also called a “template”, and an “instance”. An instance is what you get when a blueprint is painted in the viewing area.)

Note that encounter triggers also have a “faction” … leave the encounter’s faction Hostile (that means it reacts to a PC entering it) … it’s rather the creature faction that’s important here,

and, yes, encounters are complicated; they were ramped up significantly from Nwn1

1 Like

yeah, very frustrating here… maybe it’s the order in which I’m doing things… Here’s what I did:

  1. Right-click on the wolf pack, select Create Blueprint, then Module.

  2. Paint the encounter on the ground, use Select Objects to select the box and Paint Spawn Point.

  3. With encounter1 selected, I click the “…” in the Creatures box. I select the spiders, enter the max and min numbers, set single spawn to True, click OK.

  4. Save, Bake All Areas, Run Module. When I do, I still get a friendly giant spider that I can talk to, not fight.

Don’t know where to go from here…

have a look at the blueprint of the creature

c_ancom_spider1 is an AnimalCompanion; they’re friendly.



AH HA! Thank you for pointing that out! I totally missed it. Like I said, I’m a total newbie! I actually had some more success last night when working on the encounters. I’ll post my updates later tonight when I get out of the office.

Thank again for the help!

1 Like