NWN 2 Act 2 shandra bug

Encountering a bug at the start of act 2 where shandra and sand are not present, no map markers and no way to progress. Was wondering if someone may be able to possibly help, i will attach the compressed folder of the game save. I tried going back to the previous save and boss just before this, i beat her then the same bug happened again so it did not fix. Not too sure what to do now.

Edit. Forgot to mention i also reinstalled, this did not work either.


Thanks for any possible help/advice.

do you have a save before going to the Flagon? ie, before rescuing Shandra from Zeeaire

see also NWN2 OC Stuck Act II

I think i Do kev, i will give you two, one when zeeaire is killed and one just before that.

Zeeaire killed and just before speaking to shandra to return. https://gofile.io/d/gCcVp3

Just before killing Zeeaire https://gofile.io/d/F5N5Ii

Big thanks for the help Kev

ok got em. Will look tomorra  :)

1 Like

Cheers kev appreciate it.

i got what seems to be a workable solution for yourself and @Leo-B-20-Fi

hopefully its just a script in /override. But i want to wait another day … its kind of tricky and i don’t want you guys to have something in your overrides that can/could screw up later,

Sounds fantastic looking forward to it, its my first time on the nwn2 campaign and iv really enjoyed it so far haha, excited too continue. I will save the fix and this thread for future in case it reoccurs. Cheers kev




files: 1001_cliententer.nss/.ncs

This overrides the OnClientEnter script for the OC
Module: 1000_Neverwinter_A1
Area:   1001sunkenflagon

It is intended to workaround a gamebreaking bug that can happen at the start of
Act2, if Shandra and Sand were somehow not properly added to the roster. For it
to work these files should be placed in your docs Override folder *before*
rescuing Shandra from Zeeaire and returning with her to the Sunken Flagon at the
end of Act 1.

This workaround simply removes and re-adds Shandra and Sand to the roster. This
ought allow them to spawn and participate in dialogs that would otherwise break.

Kev massive thanks for this your both a gent and a scholar, seems to be working so far i can see the map icons and sand and shandra are fixed. Stoked to get back to the game, your too kind good sir <3.



glad its going … before you go too far, pls make changes to Sand and Shandra, and save your game into a new slot. Then close down the game and reload the save; see if sand and shandra load okay and still have their changes.


Everything is going great kev, i have played through now and just finished the trial by combat, enjoying the story and no issues thus far with saves or characters. Big thanks kev everything seems super

1 Like

sweet )

Thanks so much for your effort! I truly appreciate it. So, all the dialogue cut scenes worked this time and both Sand and Sharda are in my party! Also, I went outside and the map transitions was showing the districts as it was supposed to and I can finally travel to Blacklake!

May I ask something unrelated? As I said, I haven’t being playing this game in a while. Is there a known issue with wands or are they supposed to be used directly from the characters’ inventory? I’m asking this because not even Sand is wielding any, so all my mages are carrying swords or crossbows. I couldn’t find anything about this point. I’m sure the information is out there, but I thought I’d include this question here in case it takes me a long time to find out how equipment works.I’ll go looking for smoe tutorial right away. I hope that’s just how wands work. Anyway, thanks again for fixing my game!


My game version is 1.023 (1765)

you should be able to rightclick an item in inventory and choose Activate (or similar)

or drag the item to a hotbar slot and do same. Can’t equip wands …

if something else screws up, no guarantees but let me/us know eh – as above, start a thread with specifics helps. have a good one, Leo

ps. i think staffs can be equipped …

pps. I noticed that when you leave the Flagon, Tasha is waiting outside. In the other savegame i was working with she had accomplices with her but not in yours… or something like that. Not sure if it matters but there it is eh

I’m not sure about Tasha, since she walked away after the dialogue though, I guess it’s all right. Everything else seems fine now. I’ll look into equipping items as soon as I find a reliable source, but considering how messed up the game was, I wanted to make sure that wasn’t another bug. Hopefully, I shan’t be bothering you anymore. Thanks for the fixe and your insight! Have a good one.

1 Like

Kev i am not sure but i think i have more issues. After saving aldanon and black garius dying during the ritual, i was sent back. The quest now requires me to go to temar’s manor and i can’t enter it is locked, also i checked a walk through on youtube and it shows the mission return to crossroad keep. I don’t see this mission nor can i enter lavar mansion, pretty much leaving me stuck with no options. I checked online to try find the bug on google but no real success. Do you have any knowledge of this ? cheers kev

sounds confusing. Link me to your current save, pls?

No problem cheers kev iv got some terrible luck hoping i am just missing something.


Thanks again.

As far as Tasha, if I remember right, she acts differently depending on whether or not Neeshka is in the party.

will have a look l8r today