NwN 2 From GoG Just Crashes on Win 10

So I’ve had NwN 2 in my GoG library for years and decided to download and install it. Installing it went fine. However, it just won’t play. It either dumps me to the desktop or it locks up leaving me with one option - to restart my PC.

Any ideas how to get it to work? It’s supposed to be version 1.23. Do I need to download something from here?


Probably direct X you need the old direct X used by NWN2 to be installed.


DirectX 9.0c redistributable from Microsoft … although it may have been installed by the Nwn2 installation itself … either way, I believe it’s ok to reinstall Dx 9.0c

Tried that, no joy. Thanks anyway. I have gone through all the NwN 2 exe files and set them to compatibility for Vista, and set the ones that I thought needed it, to run as administrator (so they are OK to save to disk). No joy except the toolset will load and appears as though it should work.


OK. It appears to work now except that it only works with a screen resolution of 1024x768. If I change to any of the other resolutions I just get a black screen/window. It doesn’t seem to care about any of the other graphics settings, just resolution.


1 Like

NWN2 needs to get the EE treatment fast.

Not going to happen sadly, as Beamdog has neither the license nor any experience with NWN2, and whoever the actual license holders are don’t seem to be too interested in it.

Someone thought it was a good idea to bring the Baldur’s Gate: Dark Alliance games to PC. I would say there is hope that someone will try to make money off of NWN2 again someday, but it could be over ten years from now.

I have no problem with what ever resolution I run NWN2 into.

But If I remember you need to run it in windowed mode, and when all is fine you switch to full screen.

Getting back on topic…

Anyone any ideas on how I can fix that black screen/window?


GPU Drivers up to date?

Also, download the DirectX 9.0c SDK and run it. That’s what I had to do. It’ll install whatever DLLs you need that are no longer part of DirectX. If it prompts you with the “you have a newer version of this DLL installed” DO NOT INSTALL the older one. Keep your current version.

Try Crossover, Tarot ……:sunglasses::see_no_evil:

Just to be clear, and in case someone goes off to try it, that was said in jest …. And it doesn’t work in Crossover either !

I have tghe original “DVD NWN2 versions/extensions”

I can run NWN2 full screen 3440*1440 the game cap and stay at 60FPS.

IT works with NWN2 “standard” and the NWN2 clients extension.

I doubt GOG altered the engine files. Since I played NWN2 the first time I changed my GPU 5 times the computer 3 times.

I had both brand for GPU and CPU NVDIA/AMD gpu and AMD/INTEL CPU

I am currently runing AMD CPU NVDIA GPU.

I have troubles upon the original configation of the graphics setting. I have to use the windowed mod to set the resolution, and only once it’s done can I switch to the 3440*1440 resolution full screen. But I had to do this operation only once at the first launch after a fresh instalation. This trouble only occur for this resolution.

I am using the last NVDIA drivers and the GFORCE experience soft ware works perfectly fine. All my software/driver/firmware are up to date.

NWN2 destroyed or broke the GPU I had when the game launched from overheating, it was a NVDIA 1650 and the card didn’t have a real cooling solution like all gaming cards have nowadays.

My current PC is “custom” computer that was fully new/installed early 2020 NWN2 was fully installed from scrach on an “empty” machine when I got the new PC, I am running on windows 10 but poeple with windows 11 don’t report any problem.

Either GOG tempered the engine file, or there is a problem with your hardware or you are missing a fundamental windows librairy that elude us beceause it’s a default one.

I also ran NWN2 on 2 laptop computer, a I3CPU+integrated intel graphic card. The game was runing without problem, poor FPS, need to cup shadows and so on, but absolutly no resolution problems.

and I7 laptop+ 1030 or 1040 NdVIA GPU (one of the first “real” laptop GPU" which is a little more than an integrated intel GPU)

NWN2 seems to resist the new configurations/hardware/software pretty well.


I had the same problem a while ago. My notes say to edit the nwn2.ini file. In the file, change the resolution to 1024X768, and “FullScreen=0”.

Start the game, then change them in the options from within the game.

This worked for me.

(Possibly need to make a save?)

If it doesn’t work, after trying the above, try changing the settings from within the nwn2.ini.

Setting the games compatibility mode to XP seems more prudent.

Good luck.

I can play it in windowed mode at 1920x1080 but not full screen - I get dumped to desktop or get just a black screen. I’ve tried all the suggestions so far but that’s the best I can do.

Thanks anyway.


I had a similar problem that turned out to be my anti-virus software. I changed to McAfee and it started working.


While playing in windowed mode, then

Possibly look into “Borderless Gaming” problems.

Try another monitor?

I did see mention of turning off antivirus software when installing NWN2 onto Windows 10. Antivirus software can keep the NWN2 installer from picking the correct directx. I saw this in a post from June of this year.

You’ve probably already read these in threads.

1 Like