NWN and MSI Radeon HD6450

Is NWN incompatible with the MSI Radeon HD 6450?
I had to replace the video card in my 10 year old Gateway 4200DX 64-bit Vista/WIndows 7 dual-boot computer and I bought the cheapest one I could find that was equal or better to the one that came with it. Apparently you get what you pay for, even though I thought I was buying the same make and model series, just 3 iterations newer.

I thought it was an ATI or AMD (which bought ATI) card when I ordered it since it was only listed as “Radeon 6450” and my computer came with an ATI Radeon HD 3450 that did work with NWN. However the box said MSI, although their website does link to AMD now “for the latest drivers”.

However, I keep getting an “abnormal termination error in nwnmain.exe” when I try to launch the game. Knights of the Old Republic 2 is having similar issues. Neverwinter Nights 2 works better than before, while I don’t notice any difference in Knights of the Old Republic 1 (but I seem to have lost my saved games so haven’t gotten vary far on the Ender Spire as I was just testing). Jade Empire seems to have corrupted my saved games, but otherwise works fine. Probably better since I set it to use max settings.

I did get the game to briefly work when reinstalling without the expansion packs, but it was extremely sluggish, and it immediately crashed when I installed the expansion packs and updated to 1.69.
The exact dialog box has a title of “Microsoft Visual C++ Runtime Library” with the text

[quote]Runtime Error!
Program D:\NeverwinterNights\NWN\nwmain.exe
abnormal termination
Also the config program reports either that I don’t have enough video RAM (unpatched), or that I have 4096 RAM (1.69 patch).
I’m using a patcher called “NWNEnglish1.69HotUpdate.exe” dated 6/4/2009 stored on my Visa partition.
I tried to download the latest patcher, but the vault kept giving me a 500 internal server error. Although the download page reports the same filename and approximate file size (309MB according to Windows 7).

So, any idea how to get the game working with an MSI Radeon HD 6450? I did not expect this much trouble considering I was using an OEM Radeon 3450 since I got this computer. That is part of why I choose the 6450. That, and it was the cheapest card I could find on Amazon or Tiger Direct with both a DVI and VGA port that was equal or better than the 3450.

If it has Catalyst AI, try turning it off.

In game, try turning Shiny Water off.

If that doesn’t work, try turning other in-game graphics options down / off.

What is “Catalyst AI”? I can’t figure out where to look in the Cataylst Control Center as there is nothing with those initials. The closest I can find is “anti AlIasing”
As for Shiny Water, once I install the expansion or the 1.69 patch, I can’t get far enough into the game to access the options screen.
For that matter, I lost the Diamond Edition box & CDs, and had to find a torrent to get them back. I was able to save the “nwncdkey.ini” before trying to reinstall so I used a legit CD key (if I can find the damn box), but the copy protection won’t accept my original NWN1 CD for playing once I install SotU or HotU, so I HAVE to patch.
THe only time it started up was when I tried with just NWN1.
(The thing is, I got the game alone from the library “Book Sale” without expansions. 3 years later I found the “diamond edition” in another book sale, and installed it. Now the box with “Diamond Edition” is missing from the big box where I store all my original game CDs. I haven’t looked for it in nearly 10 years so I have absolutely no clue what happened.to it.)

I don’t know anything about Catalyst AI, just reporting what some players have mentioned about the HD6450 card.

You don’t actually need to start the game to tweak it. The launcher has an option Configure, which lets you fine-tune a few things before play. Make sure that’s right first. Then select Play, but notice the Options button, where you can fix stuff like Shiny Water before using the New button to start a new game.

I’ve been playing around with the Configure settings, but I get the above error as soon as I hit “Play”. I don’t even get to the splash screen, let alone the main menu.
Configure reports weird stuff about the hardware. Such as RAM being “4096” when the card has 1GB vRAM.
As for “Catalyst AI” the first time I heard of it was in this thread, so I’m not sure what I should be shutting down.