Nwn script for object to cast spell

No, the tag of the placeable is not currently being used for anything. :smiley: Correct - back when the trigger was causing this, we needed to identify the correct placeable by some means, so we looked for it by it’s tag.

Nope nothing in my override folder that is related to spells. Only a 2da for sounds. Going to check my top hak for the spell 2da.

Suggestion: Before you start searching through things one by one to find anything that might be the culprit, take everything out and test it, then. If it’s still not working, you’ll know that your overrides / patch haks / haks aren’t the problem, and won’t waste time searching for something that isn’t there at all. :open_mouth:

Hi “The Barbarian” …first, I want to thank you so much for all your help and your willingness to help me and for your patience. I’m very very grateful to you. Sorry for not responding to you as fast as before. I have had some family stuff come up. I really want to figure this out…sigh don’t know why it is not working…yet…so weird…but when I get a chance I will test it in a normal mod see if it works there. Could it be that perhaps it has something to do with my “module” EVENTS tab in the scripting requires something?

So weird as I have managed to do so much to this point in making a decent module…just not very good at scripting stuff.

1 Like

:thinking: I think the module events interfering with spellcasting is relatively unlikely. It’s theoretically possible that scripts that alter spellcasting mechanics could have been tied into the module events by placing a turn on/off flag into OnModuleLoad for consistency’s sake, but that aside, I don’t see very much of a way a scripter could have tied the module events into spellcasting alterations at all. Not in a way that leads to the result we’ve currently got, anyway.

Also, take your time and don’t worry about it. :slight_smile: This is one of the big advantages of asynchronous communication, like via forum posts - everyone gets to post when they’ve got the time, and everyone else can view it when they’ve got the time. People being around at the same time isn’t necessary to make progress, that way.

Definitely, yes; clear out the Override folder, remove all patch haks, and then start a new, fully-clean module (no haks, no scripts, no nothing) and try it out in there. If it works that way, the we’ll know that the culprit must be in any one of those three (override folder, patch haks, or module scripts/haks).

Also, if I’m seeing this right, then the basegame spells.2da file doesn’t contain Isaac’s Greater Missile Storm, so if one of your haks has a basegame version of that 2da in it, that would lead to this result, too, where the objects are being found correctly (SpeakStrings and all) but the spell itself isn’t firing. This seems relatively likely to me; a basegame 2da can cut out swathes of expansion pack content in an instant in an extremely innocuous kind of way. One harmless file - instant mayhem.

1 Like

How can I attach my spell 2da here? Is there a way to send it to you for you to look over. You know what is weird? I did a ctrl f search on it and I can’t find the spell Issac Greater Missile Storm that is in this spell 2da I use in my top hak yet all my issac missile storms work in the module…how can that be?

Free file sharing sites include Dropbox.

“Free file sharing sites include Dropbox”.

Thanks…yeah had dropbox before too but once I paid for them…they kept charging my credit card for three months after I cancelled their services. YOu ever try getting a hold of their customer service department? Impossible. So I had to cancel that credit card. Never using them again.

But thanks for your suggestion.

You could also try Mediafire or Google Drive for file sharing.

Isaac’s Greater Missile Storm is normally on row 448 of spells.2da, from SoU onwards. :thinking: If you’ve got a basegame spells.2da in your module, then you could try extracting and attaching a HotU-level one, see if that makes a difference.

If a basegame-level spells.2da was included in one of your haks, though, then it’s likely that something was added to or modified in it, and we should check for that change to carry it over into the new 2da lest we break something else.

REALLY REALLY IMPORTANT, though: Have you tried the script in a completely clean module yet (empty override folder, no patch haks installed, no module haks installed, no module scripts installed)? If it isn’t working in a completely clean module, then we’re chasing after phantoms by investigating the contents of the haks.

1 Like