NWN with CEP2.65

Greetings All,

Surely someone has had this experience before. I’ve coded a few modules, just to share with friends, but I’ve not included the CEP before. I downloaded 2.65 and added all of it to the appropriate folders, but I’m getting tlk errors. I don’t know exactly what’s gone wrong. I really just want to use it to take advantage of the new placeables, monsters, tilesets, skyboxes, etc. I’m not seeing those when I enter the toolset.
Would someone be kind enough to help me out?

Thanks,
Meb

Sounds like you haven’t put the all the cep tlk files in the cep folder situated in your
Documents\Neverwinter Nights\tlk
folder.

TR

Hi. :smiley:

In case “Make sure that the files are for sure-for sure in the right place” doesn’t lead to a fix - could you post a screenshot of your Module Properties -> Custom Content tab, and specify what the error messages you’re getting say? Maybe we can spot something that’s off.

Sure can - here is a run-down:

come into the editor and immediately get this error: tlk%20file%20error%20msg
then this pops up (pretty sure this is to be expected and everyone gets it) : hak%20file%20msg
then I have the choice of module Module%20Choice
and I usually choose the highlighted module. I’m guessing that’s what I’m supposed to do, and then change the module name later. I’ve tried all of them with no luck.

Here is the custom content:
custom%20content

As you can see there are no .tlk files to even choose from there.

By the way, there are over 40 .hak files in my hak folder.maybe this module only pulls those - not sure.

Thanks for your help.

Meb

**

The tlk files go in the tlk folder. If this is for 1.69/diamond this folder is in the install folder for NwN. If it is for EE the tlk folder is in your documents/Neverwinter Nights folder. When you extracted the CEP to its own folder there would be several sub folders created. Go into the one called tlk and copy all the files in there to your tlk folder. Then read the readme.txt file that came with the CEP.

Let’s go through the warnings. The 1st one tells you you are missing a tlk file from the talk folder. This means you didn’t put the file there. The second warning is a hold-over from the early days of NwN. Just click Yes and ignore it.

TR

cool, so the that did fix the tlk error.

I guess I need to get straight which haks I want for my module.

I still have no extra skyboxes, I have at least one new tileset - swamp (cool), but no new monsters - unless I’m not doing this right. I’ve looked in the custom monster list and I can see that there are place holders for an ant and a couple other things, but I can’t place them.
what kind of a configuration should I set up to enable these?

Much appreciation,

Meb

To get the skyboxes, you need cep2_add_skies in your hak list. The latest recommended order places it above cep2_top_2_65.

More generally, to get extra goodies, you need to add the optional haks. The hak names are fairly self-explanatory.

In the case of creatures and placeables, you don’t automatically get templates for all of the new appearances. This was done by design, as those template files were overloading some PWs. On the CEP download page, there is a link to the placeable templates (only). Alternatively, just make your own templates - for example, make a new creature, choosing its appearance from the dropdown - all the new CEP content is there.

Very cool. Thanks so much for everyone’s help!

2 Likes