(NWN1) Game Crash on New Game


I’m working on a large mod and I think I did something with the toolset, which causes the game to crash at “start a new game”.

The progress bar nearly runs to the end and the character selection screen should appear immediately, but it doesn’t.

The mod can be loaded with the toolset and a rebuild shows no errors. Earlier versions of the mod and other modules run perfectly well.

The log shows only “loading module …”

So it’s just a problem with this version of the mod, but how do I pin the fault down?
Are there any switches to make the logfiles mor informative?
Any Ideas to make the debugging-process more painless?

Please help

Look in your NWN folder for a folder named “modules”. Open and find your module in it. Right click the module there and see what it’s resource count is. If over 16k, then you have exceeded the max resources. I can assist with resource juggling to get it working again. If under 16k, it’s something else and more questions will follow.

Hello kalbern,
Thanks, but I don’t understand. Is “ressource count” a information given by the Os? (Windows). Right click on a file in a folder will give me some file properties, but ther I see nothing which matches the desciption.

Nevertheless, the problem is solved. Worked the whole day on this. Reason: I made a simple on_enter script for an area. The creatures spawned into the area at startup of the mod triggered the script, which causes problems …

Lesson learned: “if you make an on_ enter script, then make sure, that it isn’t triggered by anything”.

But I’m still interrested in this ressource count, that could eventually a useful information.