NWN1 original - weapon is self-un-wielding

I’m playing a Ranger (L8), Rogue (1), Sorcerer (1). I’m a big fan of dual-wielding, and have been playing such. I also have Exotic weapons proficiency.

Up until recently, I’ve been using longsword +1 and dagger +2, with no problems.
Then I found a kukri named Cutter (or something like that), which has 1d6 fire damage as well as normal kukri damage. I’ve been dual-wielding Cutter + dagger, but something will periodically un-wield the kukri and move dagger to primary weapon. It also removes the kukri from the quick-wield slot.

Apparently it’s actually okay for me to dual-wield these two weapons, because the game allows me to re-wield the weapon, but then awhile later I’ll notice it’s un-wielded again, and I’m only wielding the dagger !!

One action that causes this is loading my quick-save, but I think other actions are doing it as well.
Interestingly, entering/exiting combat does not do it.

Has anyone seen this before?? Any idea what is causing it?? I’m very confused!!

Later note:
Well, I switched back to a long sword, and this quirk stopped happening.
I suspect this has something to do with exotic weapons, since the same thing happened earlier with a katana as well.

What module are you playing? Some script is copying the item for some reason and replacing it from the sounds of things.

I’m playing the main module, at this point… I’m still in the second area, outside Port Llast.

If you’re asking what mods I’m using, I’m using several;
Trening, BetterFonts, StylishGUI, henchman AI, rest duration.

This issue occurred with multiple different weapons; the one thing they had in common is that they were all exotic weapons (kukri, can’t recall what the other was; I said katana, but that’s not right.). Once I switched back to a ‘normal’ longsword, it stopped happening.

Trening search on the vault had no results.

I doubt the fonts and gui mod can have such effect.

I presume so far you are referring to the PC, so the henchman mod should not be the cause.

Perhaps the rest duration is causing it?

You have not mentioned which campaign/module you are playing on, so I presume it is one of the original games.

[
The exotic weapons list includes the bastard sword, dire mace, dwarven waraxe*, double axe, kama, katana, kukri, scythe, shuriken, whip*, and two-bladed sword.
]

Yeah, I’m playing the ‘default game’, which started out in Academy and the Port Llast, which I’ve completed and I’m now in outside region, and Luskin is next. I don’t know anything about any campaign/module names, which is why I didn’t include that !!

Trening is a module from Nexus, which adds two items via a separate module:


You have to start a new character in the module, pick up the items, export the character, then start a new game and import that character. Doesn’t seem like it would have any reason to be changing any game rules, though I don’t actually know. It does change alot of player characteristics, so maybe it did create this effect. I’ll ask the author about that, he’s been responsive to a previous post that I sent him.

For ‘rest duration’ mod, which merely speeds up the ‘resting’ time, it’s less likely, since it doesn’t have anything to do with game rules.

Probly the custom module. Try playing with a char created in the original game, cheat in the items and feats and play it.

hmmm… I think I’ll keep that in mind for another play-through… I don’t really want to start over at this point !!

Correct me if I’m wrong, but it looks like you are trying to use items made for NWN2 in NWN1.

Hrm as Kamal has guessed, are you exporting the char from the module, which is NWN2, into NWN 1? The custom module is NWN2.

If you know how to use the NWN1 toolset its easy to recreate those items, then cheat them into the game.

This will probably related to ItemLevelRestriction if you play with some overpowered items.

go into NWN folder/nwnplayer.ini

and under [Game Options] set

Single Player ItemLevelRestrictions=0
Single Player Enforce Legal Characters=0

if these choices doesn’t exist, just add them, if they do change value to 0

1 Like

OMG !!! How did I miss that ???
Actually, I’m probably lucky they worked at all…

You need to understand that while many things remain the same between games, some behaviors were changed by the devs. So essentially both are separate games, and should not be mixed.

I tried Importing a nwn1 script into nwn2 toolset and got errors, eventhough the script language is the same for both games.

I certainly understand that!! I wouldn’t normally expect mods to be usable between versions at all. Somehow, I didn’t notice the NWN2 section header at all, when I downloaded this mod… it’s definitely surprising it works at all !!

I guess I’m a little surprised that I didn’t get an error message when trying to load the module, saying the module was for a different game…