nwn2_CritterStatsEditor Gff/Utc file(s)

update 0.2 Functional

- cut/copy/paste/delete
- search
- print treepath to statusbar
- add/resort nodes
- edit fields/labels
- many integrity checks
- create/open/save/saveas/reload

2 Likes

2019 November 10
ver 0.3.5.0

Please read the description on the Vault page and if still interested … have at it

https://neverwintervault.org/project/nwn2/other/tool/generalgff

 
:beer:

 
typo: the Context menu has an operation

add CExoString (ASCII)

But it’s actually UTF8 capable. (will be updated in next ver.)

3 Likes

efforts on UTC (creature) extension …


( editing creatures outside the toolset is why i started this app )

1 Like

this could be interesting (and intensely time-consuming) … GeneralGFF as a plugin

2 Likes

yes, but it would tremendously help on win10. there’s a serious issue with all the toolset’s 3d rendering screens (preview, armor tab, etc.) on that os. nine out of ten times they won’t update and you have to manually place the blueprint in the world to get a correct representation of the selections you made.

or is there a simple fix to get those problems solved? alas compatibility mode and admin rights don’t change a thing.

hey Semp,

maybe it could help. yes i’ve heard about the win10 woes re. creature appearance views. In part that’s why i’ve started tapping into the toolset’s plugin classes – to see what’s available. Unfortunately (or not…) I use win7.

Here’s the thing: I have no idea whether the win10 issues are inherent in the toolset classes themselves … or perhaps they are okay, but that current viewers have overlooked a call to update, that win10 expects (for whatever reason).

in any case, I’m a total noob with the toolset classes. There are a gazillion. On the bright side, c#/.net decompiles easily; but this is the sort of stuff i get to stare at for now …


(that’s a merest fraction of what’s inside all those Nwn2 .dlls in the installation folder)

 
I might put my creature extension on hold for a while and set my hand at tooling a simple creature-model editor that could replace the ArmorSet preview … no fancy wizards or anything, just ArmorSet editing … gotta learn some basics here,

 
ps. Is it only creatures that don’t update properly, or are other blueprint-types affected also? eg Placeable previews

test request: Win10 users

issue: creature appearance views do not update when you change the creature’s armorset.

I’ve written a small alpha plugin that i’d like someone with the above problem to test out. At this stage its only an attempt to establish – or refute – proof-of-concept.

reason it’s alpha and not even beta: I’m having difficulty finding and firing “SelectionChanged” event(s) successfully …

usage:

But if closing and re-opening the CreatureVisualizer plugin actually updates changes that you make to creature appearance (as shown in the video) this might/could be worth pursuing.

[link defunct]

@Semper @Lance_Botelle et al.

Hi KevL,

Thanks! I will test this straight away. :grinning:

Just give me a few minutes and I will download and report back.

Cheers, Lance.

EDIT:

OK, this is interesting … I think.

I loaded your plugin … and watched the video (the first part to see what to do), and started testing. I noted the following …

  1. Loaded an NPC and tried changing clothing, and it did not show in my normal toolset window.
  2. Loaded your visualiser and I noted the equipment had updated.
  3. Tried changing equipment, and neither window updated.
  4. Restarted your visualiser and it did show. Horah!
    5) Went to shutdown toolset … crash on exit. (If your plugin has been loaded, it sometimes does this.)
  5. Restarted toolset just to get more feedback for you.
    7) NOW my normal toolset window works! (Shows changes!) Even before I loaded your visualiser prog.

I was in the process to try to work out what combination may have caused the toolset crash, but was so excited that my toolset version now works, and thought you ought to know ASAP.

I will keep playing around to see if I can add to feedback, but whatever your little plugin did, it appeared to “fix” the normal toolset visuals from not changing to changing!

EDIT 2: Just out of interest, I tried loading the “right-click” on a creature to load the “Appearance Wizard”, and initially thought it had simply frozen the toolset again. I waited a good minute and decided to report, But, then, as I started to edit this post, the toolset “unfroze” and you know what … even the “Appearance Wizard” appears to have a degree of working. It is still slugglish changing pages,but at least it does change pages! EDIT 7: Tried this again, but failed this time, even after waiting.

EDIT 3: It takes around 40 seconds for the right-click Appearance Wizard to settle down, ten seconds between page swaps and exiting.

Whatever you have done in your plugin, definitely appears to be doing something along the right lines, as I have had more success with these two aspects of my toolset since adding your plugin, even if I don’t start the plugin itself now.

Maybe you have discovered something fundamental about how the toolset displays the creature, and can hone it to get rid of the delays completely.

So far a 100% better than before. :ok_man:

Interesting huh?

Cheers, Lance.

EDIT 4: On a second play around, immediate update in main toolset window now appears intermittent. And sometimes things update change, or do not. Same in your plugin window itself … still testing.

EDIT 5: OK, the only consistent working aspect is your own plugin, which does show updates, BUT ONLY IF I reload the visualiser after changes to see the updates. i.e. It does not show anything live. (Update: I notice that it works this way for you too after watching your video fully.)

EDIT 6: Something peculiar with the helms here … Only your window looks like the type I was expecting.

EDIT 7: And there is some cloak weirdness going on … your plugin shows correct, whereas the toolset appears to be invisible and on back to front (obscuring NPC). Cloaks 1-3 as do some others, but a few show OK.

EDIT 8: Your plugin has a direct impact on the toolset images as to whether I have your plugin window open or closed. i.e. If I change a cloak in the toolset and then open your plugin, the toolset may “lose” the item image. Close your plugin and the item image reappears in the toolset image.

1 Like

bizarre … will think about it some more tomorrow,

and try to do a realtime update (even if i have to do it with a timer)

thks so far,

Hi KevL,

No problem!

Here is a link for you to see my own experiences …

Just contact me here, whenever you need extra feedback. :slight_smile:

Cheers, Lance.

EDIT: I removed your plugin to see if the toolset version still shows changes, and it now does! So, either your plugin triggered something, which fixed my toolset, or I have had a Windows update and not noticed any difference since, as I tend not to use that since the problems. (The cloaks still do NOT show correctly though (invisible), as opposed to showing correctly via your plugin. So, your plugin is still doing something beneficial over and above the dodgy toolset version.)

EDIT: OK, There is nothing consistent with how the toolset appears to be responding, as now sometimes the toolset image updates or it does not, subject to what is highlighted or where you may click. I have reinstated your plugin, as that appears to be the ONLY consistent means of being able to determine what has been updated.

I think one of the issues may be that the toolset may have a delay before visually updating in many instances of trying to apply a change.

And here is a video showing how an initial change may show, but any subsequent changes do NOT show UNTIL you click in the toolset area window. At that moment, any changes you had been trying to make in the armor view suddenly update … Does this with or without your plugin in place.

EDIT: Just noticed I had CreatureCreator.dll from another plugin still in there, so I removed that in case it was clashing with yours. As far as I can see in further testing, it does not appear to have been, but I will leave it out until we have finished testing yours.

uh … well, i guess that’s better than the other way 'round …

I have no idea why that happened or if it’s truly related.

I didn’t discover anything, Lance. tbh i simply used bits and chunks of code from Grinning Fool’s Creature Creation Wizard – because without those working examples of “scene” functions (which Obsidian seems to call “NetDisplay”), the CreatureVisualizer simply wouldn’t happen (at least not by moi) …

ok, proof-of-concept established i’d say. will now poke at bringing it up to beta … ie, pseudo-realtime updates.

CreatureCreator is The Grinning Fool’s plugin (above). There ought be no clash. The difference between his scene-panel and my adaptation of it is that the latter will need to update according to what’s currently selected in the toolset,

/stay tuned …

1 Like

i tested your plugin and it works like shown in your video. the 3d view in the armor tab won’t update while closing and re-opening the creature visualizer does so.

so far i only noticed this issue happening with creatures and items. selecting an armor part, a color or a different part of any weapon like blade or grip won’t show. copy/pasting the instance in the world does update the preview and armor tab. i also noticed that using the coloring buttons in the properties tab works more reliably in tandem with the 3d main view. repeatedly clicking the color sometimes fires a 3d view update too.

thanks for looking into this issue. it’s really nerve-wracking.

2 Likes

ditto. I’ve come to realization that i could ( … ) recompile the toolset …

/Lol  for personal use only ofc.

But seriously, I might have to (so to speak) if only to figure out how it works. I mean… i’m trying what should be the simplest things like changing the background color in the visualizer and it doesn’t stick … or changing the initial starting position of the creature in the visualizer but nada …

on the other hand, the position and intensity of the light-emitter changed okay …

Trying to change the blueprint shown in the visualizer merely redraws a new instance of the old blueprint on top of itself … and i haven’t seen a “clear panel” function or a “really change the blueprint” function

etc – the visualizer might not get much farther than present (tbh)

 
So, make do with it as-is if you like and i’ll continue to hack away at here. Will see about Items also,

 


woohoo

4 Likes

beta breakthrough, hope on the horizon

4 Likes

Hi KevL,

That’s looking promising. :slight_smile:

I take it that your Visualisation window does not have the same kind of “hooks” as XML like GUIs then, like “OnMouseEnter” or “OnUpdate” that would do the same thing as you clicking your update button?

I have absolutely no idea how what you are doing works, so my questions may be silly even asking, but I have to ask.

Also, does this also show updates to hair and head changes? As that is also tricky.

Thanks for bashing away at this. It will be a blessing indeed if it can be sorted.

Cheers, Lance.

yes it does: .net hooks for mouse events etc. etc. It might not be as straightforward as I’m used to, however, since i’m used to wiring up a .net “Panel” but this is rather a special toolset “ElectronPanel” (that doesn’t inherit from “Panel” but from “UserControl”). Thanks for the idea to force an update on, say, double-click … currently, the F5 key does a refresh (same as clicking Instance|Refresh from the menu). I’ve changed some wording – in the video it’s called “create”. I tried to distinguish between “create scene” and “update scene” but can’t get this to work:

NWN2NetDisplayManager.Instance.UpdateAppearanceForInstance(_instance);

still have to do some figuring since Obsidian implemented custom mouse-hooks … I should be able to bypass those, for a simple refresh though. (sorta depends on whether double-click happens to conflict with anything)

not sure. I’ll say that the “Instance” that’s rendered seems to be the final model that would appear in game (including equipped items). [you could test it with the alpha Visualizer, btw – i haven’t changed the “model” that appears, at least not wittingly]

 
ps. Things are more complicated than XML guis. I could, for example, do a timed update that’s very similar to “OnUpdate” but if the model is selected it would go unselected (the way things are wired up now). But that’s awkward and i’ll avoid things like that …

/zzzz

1 Like

I wish I knew more about this side of coding. :wink:

I think I may be past that stage now … NWN scripting is challenging enough.

Cheers!

it could be there’s a chaincoif equipped on the NPC’s Inventory tab.

The ArmorSet tab doesn’t show equipped items. Go to the Preview tab for the final view …

I’m noticing that objects get displayed in a bunch of ways … notice for example that the hues are slightly different … depends on the DayNightSettings that each scene is set to be rendered with.

Even more irksome (for me who has small grasp of modelling) is that a sword-item will appear in the Visualizer but a boot-item won’t … a boot-item doesn’t get displayed on the Preview tab either, instead it appears on a default NPC in the ArmorSet tab …

/quirks

There’s a .NET event that fires when a control takes focus – will try to write a handler for it that refreshes the scene automatically, just by clicking on the Visualizer (to give it focus, typically after changes were made on the ArmorSet tab) …

with an option to turn it off so that one could, conceivably, open two Visualizers to compare different appearance choices

yes, looks way more usable than placing and instance in the world.

2 Likes