NWN2 Help - Glitch? Char changed to a 1st Level Fighter

#1

Whenever I complete the Fihelis Quest as soon as I use a World Portal my character gets converted to a 1st Level Fighter Chaotic / Good and half my inventory disappears (at first it is all gone then it reappears, but not in entirety). I also lose equipped items, but I’m assuming that might be based on the character change. I’ve tried saving it at several spots and when I look at the saved game it says my character is what it is supposed to be , but once loaded I’m a first level fighter. I essentially can’t get past this point. Anyone seen this? I researched and couldn’t find anything.

Thanks!

Ehk

0 Likes

#2

You said you researched and found nothing so I suppose I shouldn’t be surprised my research turned up nothing…

Do you have any mods installed that might effect the campaign?

What, if anything, are you running in your override folder? The first thing I would check is removing anything from your override and seeing if the problem still occurs.

That’s about all I can suggest. Hopefully some of the more knowledgeable folks will stop by.

Quixal

1 Like

#3

well, uh, after ~10 yrs this is the first i heard of it

Quixal’s advice is sound. Backup what you need to backup and start stripping things down to only what’s needed.

atm I think something more fundamental is wrong – like a file or folder that the game can access, but then can’t (for whatever reason), like a “corruption” of some sort.

 
Or it may be something simpler like a duplicate (rogue) file in /override …,

2 Likes

#4

I ran into stuff like this when I was messing with Mysteries of Westgate as a learning project. There was a script that, every time I would zone, would take magical items over a certain power level and de-level my imported characters to somewhere in the 15-20 range if I remember right (This was quite a few years ago though). The MoWG devs actually replied to me at the time on their forums, and had me change the level range on the campaign itself and save it, which stopped the script from nuking my stuff.

3 Likes

#5

So I had copied my original install prior to starting the game. I deleted my install and re-used the copied version. I was able to restart at one of my saves and play for a while without it happening, but once I saved and quit then reloaded my saved game a few days later it happened again. No idea what to do. I went back to an older saved file that worked, but soon as I began to play one of the transitions caused the same issue. Weird thing is all skills and attributes, experience is the same, but the class is set to 1st level fighter.

Help please

Ehk

0 Likes

#6

I’ve seen behavior like this from NPC’s in the OC if you start playing with the debug commands and get the party save de-synced from the individual character save files. But only with various level-capping scripts have I seen it happen to the main player character.

When you say you’re installing from a “copied” version I start seeing all sorts of red flags. Is it from GOG? Original boxed game? Pirated copy? A backup you made of an install and are copying off a flash drive? Your install file might be borked/corrupted?

1 Like

#7

Hey Sabranic,

This is an install from Platinum CDs. Once I completed the entire install and patch process I backed it up to an external drive so I wouldn’t have to go through that process again if I had some type of corruption or other issue. I suppose I could try doing a full re-install, but was hoping to avoid this since it is such a painful process. It is very strange. It changes 3 things that I can see: my character class, my level (although my XP remains the same up above it), and my alignment (changes from lawful evil to chaotic good).

Thanks!

Ehk

0 Likes

#8

The alignment thing is interesting.

Try looking at your player.bic file in your save in gff editor. Check the levels and alignment. See if it’s off there.

0 Likes