NWN2 laggy now - seems odd

When playtesting my new module I’m working on a few days ago (having migrated wholly to Win10 recently), I found my module was a bit laggy especially when the PC and the companions were running around. If there was a text message on screen, like a text floating on top of a creature’s head (using Speakstring) the text would flimmer a bit.

Now, is this because of my module (I hardly think so since I remember playtesting on my laptop with Win10 and on my old main Win7 installation) or some setting in NWN2 that I haven’t thought about, or maybe I don’t have the latest drivers for my graphics card (though Win10 claims I have that)? Does anyone have an idea what this could be?

It could be anything, heck it could be a staff of Balpheron. :scream:

But seriously, I don’t think anyone can answer this with absolute certainty.
Does your module run any specific heartbeat (or on enter) script on the module, area or creature?
Did you notice if this behaviour happens after certain actions are taken or it just happens and that’s it?

If there is a way to get your module, I could try to playtest it as well and see if it lags for me as well.

I have an on heartbeat script on the module itself made by Lance Botelle. It’s his weather system. I tried and removed that but it made no difference. My belief is it is the driver that must be updated for my graphics card. I will test and move my module to my laptop to see if it’s laggy there. It’s been months since I playtested this unfinished mod on my laptop.

There are so many, and large, files that I won’t put it up for others to check on their machines. I just wanted to know if anyone had any theories as to what caused this. I sincerely hope it’s not anything that I have put in my module that makes the game behave the way it does. The lagging is quite subtle, but still noticeable, when some NPCs walk and when the PC and companions run, and really apparent when using Speakstring that appears above the PCs head and the text flutters.

Are you using the Client Extension by chance?

Well, did you try to see at least if this lag happens only on your module or if it happens on other modules and original campaigns as well?

It was even more laggy on my laptop. I will have to investigate more. I’ll try other modules.

I don’t even know what the Client Extension is, so that’s a no.

Just a couple more things I’d like to ask:

  1. Are you using any overrides/UI files that affect the standard interface?

  2. Would it be possible to just upload the custom script files used by the module without the areas and the bigger files?

It could also be that the answer lies outside of the game (drivers ecc…) however, that fact that you had lag on two different machines seems to point us to something from the game instead.

Based on the replies posted while I was writing mine, my ideas were definitely not relevant.

Still one that could be worth looking into: are you using haks, and more specifically large haks?

Hi andgalf,

I agree. It won’t be the weather system as that barely does anything after initial setup. :slight_smile: Unless something is not setup correctly, but I think you had it OK the last time checked. (i.e. My module uses the same code and no lag.)

(Typo : Bortelle > Botelle.)

Anyway, this can be many things … I have experienced lag due to the following …

  1. Windows needs a reboot.
  2. Windows is doing an update and it is not realised until it says it needs to restart.
  3. Another Windows operation in the background.
  4. Module: A faulty script that has not been compiled properly somewhere.
  5. Windows 10 uses more resources and your computer cannot handle it as well.
  6. Sound drivers have also played a problem in the past with me (inc old codecs).

Like others have suggested, if you are able to give access to your files for download, I can also check for you.

Cheers, Lance.

1 Like

Does the area have a lot of light sources? If yes, uncheck “create shadows” for all of them or most of them. Use cache for creature used in this areas (On area properties).

I can run NwN2 on really old PC using only 4Go RAM with GPU ATI radeon 5450 serie graphic card with no problems. And for obscur reason, win7 will run Nwn2 better then any OS. So stick with win7 for old games. You can also run the game in windowed mode, this is also strange but will resolve some issues some times.

And like others peoples have already said check your system. Suspend wmi performer.

If it was just of me, I would use Ubuntu (linux distro).

1 Like

Try the Client Extension. It gets rid of a lot of lag, among other good things.


does the cursor lag, or is it just the animations? how much fps do you get? if your game performs well but the characters lag around then it could be an engine issue under win10.

try to disable fast startup and restart your pc: power options > choose what power buttons do > uncheck fast startup

at default win10 won’t really shut down your system which leads to all kinds of asynchronous issues with older engines after a while.

to check your fps: press return ingame > ##debugmode 1 > ##showfps > ##debugmode 0

@Lance_Botelle Sorry, Lance, will correct the typo. I haven’t rebooted Win10 in a while so that could definitely be an issue.

@travus I tried the Client Extension and that seemed to solve the problem. The animations and everything runs a lot smoother. I might actually have heard about this at some point, but I thought it was just about multiplayer. I don’t know if I installed it correctly though. I tried checking the readme but got a tiny bit confused by all the ways you should/could start the client extension. So I just went “what the heck” and put the unzipped map in my NWN2 Complete folder and run NW Launcher from there. Then it said that there was a new version to install so I did that (it went really quickly) and then started my module.

My brother told me that when he beta tested A Strange World 2 (my next module to be released as soon as 4760 is done beta testing) he experienced some lag on his laptop and solved that by restarting Win10 and then directly run the game, and then it ran a lot smoother. He didn’t think I needed another newer driver from Nvidia as Win10 normally takes care of these things itself, and since this is such an old game it shouldn’t make any difference.

Anyway, maybe one should point out, ask people, to download the Client Extension for the game when they run A Strange World 2 and A Strange World 3 (the module I’m working on now and the one that was a bit too laggy).

@Semper Interesting ideas to try. Maybe I will do that, but since the Client Extension fixed things, at least for now, maybe I won’t have to do that.

@raymondsebas I haven’t checked if I have a lot of light sources in this area. It’s an outdoor area by the way. I did however convert a few of the buildings in the periphery to Environment Objects. The downside to that is that characters can move through them then. But I guess that is solved by putting walkmesh cutters… And yes, NWN2 did run really well on my old Win7, but now that era is gone sadly. Didn’t want to go to Win10 but since Microsoft stopped supporting it I felt like I had to switch.

Thanks to all for trying to help! I say as I always say: It’s a blessing to be part of such an awesome and friendly community!


Yep, the Client Extension is a “must have” resource regardless if playing single player or MP.

If you only plan on using it for single player, I recommend closing down the auto-map and the message window that are running behind the game. Just ALt+TAB while in game and you should see those two windows open on your desk-top. Just shut both of them down to save resources on your CPU. The auto-map is a real hog otherwise. Don’t shut-down the command prompt window though. That one is necessary for the client extension to run.


@travus I did as you said and closed the auto-map and message window. Will the game remember this or will I have to close these every time I start the game? By the way, looking at my mod again, when you spin around the camera with the mouse it runs a lot smoother too. A real joy, actually. Thanks for informing me about this!


The client extension will leave them deactivated. You shouldn’t have to shut them down anymore. If you need to reactivate them sometime later, there is a command you can type in to open them back up. I don’t remember what it is off hand but there should be some info in the readme file on it.

If you happen to notice your character “jumping/teleporting” a lot when you click to move, try deactivating the mpredict. To do that, open a notepad file and type “/mpredict” in it. Then save the file naming it “autocmds”. Then make a copy of that file and rename the copy to “autocmds_ingame”. Put both of those files in your <mydocs/Neverwinter Nights 2> folder. They should be in the same place as your ini files.


Something else I should mention about the client extension is that it likes to output log files which tend to pile up taking up space. They are pretty much useless. To stop the log files, type “/logging off” in the same two files I mention above.

1 Like

@travus Ok. I’ll do all of your suggestions here. One question though, just so that I do understand correctly, should I save the files as .txt (I do think that’s the only format that notepad can save but I’m not sure, that’s why I’m asking)?

1 Like

example autocmds.txt (i have “.txt” and it seems to work)

/camerapitch 90
/logging off

Yes, txt files.