NWN2 Mouse no longer able to move PC

This HAS to be stupidity on my part but I’ve been playing away fine on both the OC and now Mysteries of Westgate with no ( well very few) issues. However, now i’ve hit a dead stop - literally.

I’m playing on Bootcamp on a Mac so Windows is running natively ( just for info although that’s not the issue here). Up to now, wherever I click the cursor the PC (or whoever I’m controlling) runs to that spot as expected.

However, now the mouse still does everything else - selecting items on screen, turning camera at edges and will even move the PC if I click on a trader but if I click on the ground there’s no movement.

Movement works perfectly with keys.

I suspected at first that I had somehow jumped into one of the other modes but I changed keybindings for them and clicked on the key for exploration mode ( which I think I’ve been playing the whole game in? I’ve certainly not consciously changed that.) That made no difference.

So, I’m stumped. The mouse is obviously being recognised, it’s not a tiny area where the PC is hemmed in by the party. I’ve restarted the game numerous times but no joy.

FWIW, the modes button is in my bottom right hand corner as usual but to the left of it where I reckon the choices might be, there is a small box but nothing in it as if they are greyed out.

I’ve tried playing other modules with same result.

Anyone, any thoughts?

Hi jimdad55

what you describe looks very confusing (maybe just for me)
but very much reminds me of the problem with hotkeys or just turn oned character mode.

  1. check if your mouse works in other applications. (If it works in other applications it means good)
    ====
  2. check the hotkey settings and game option settings in the game
    because if they changed don’t be surprised why mouse buttons dosent work .



    ======
  3. check if you can switch between 3 modes.
    What you described reminds me of a camera = character mode
    if you can choose the mode you need
    if you really have this button disappeared it is really strange, most likely it’s bug

=============
4) if all of the above did not work
try resetting settings

just in case, make a copy of the original file and save somewhere
before trying to dump
it seems in the second part of the game, the settings are reset as well.

reset by default

===
5) search for similar topics on the forums

Good luck with finding a solution!

Thanks for the reply. In order:

  1. Mouse works in other applications. It works in EE and it even works in this nWN2 module. If I click on a trader the PC moves to speak to him. The mouse rotates the camera when I go to edge of screen.

  2. Hot key settings hadn’t changed and I can use the keyboard to move about using them.

  3. Can’t change between modes as the box you highlight in bottom right corner of screen is empty. The word “mode” is there but box to the left of it is empty. In the diagram those three buttons you indicate are not there.

  4. Tried resetting default settings but that didn’t work.

  5. Thanks for the link. Will try removing the .ini and restarting the game allowing it to create a new one.

Thanks again for your help. Will post how I get on. This is a strange one. I was sure it was a mode issue.

Well, that was interesting. Nothing worked until I deleted the nwn2player.ini file. Opened up the game and everything working normally.

Thanks, @lord_XD. It was that Steam thread you linked to under number 4 that did the trick. The dev there, Julius suggested doing that.

Not sure how it happened in the first place but I’m not going to get greedy. Onward . . .

3 Likes

This has been a bug since the game was released. The only way to fix it is to delete the file like you did. It will happen again some day. I have no idea what causes it.

Thanks, @Dwayne. As you’ll have seen I managed to get it working again so I’ll know what to do next time. I’m also saving much more than I ever managed in my real life finances :weary:

I’m starting to realise why some hold a rather poor option of NWN2 because of the many bugs, which is a pity as I’m really enjoying playing the OC and now Westgate. I like the general look of the game (although NWN1 is getting much better), the conversation system and the cutscenes although, having had to make some cutscenes for a module a while ago in EE, I’m betting the NWN2 ones are even harder to come to terms with, especially if the toolset is anything to go by.

I always thought NWN2 looked rather ugly when it was first released back in 2006, compared to NWN1. Nowadays with all the amazing custom armors, outfits, heads, haircuts, creatures and GUI
and everything it’s the total opposite. When looking at NWN1 nowadays I think it looks quite horrible compared to NWN2, to be honest. Interesting how things change. That’s why I abandoned NWN1 (ok, not only that but I have already played all the modules I’m interested in for that one).
Speaking of NWN2, I don’t think I could ever go back to playing or fiddling with the vanilla NWN2 though. You got to have NWN2 Facelift Pack as a bare minimum in my opinion.

And sure NWN2 is still buggy, but when fiddling with making modules you can make the game quite stable if you’re being very careful and know a bit of the game’s limitations. There’s quite a particular way of doing things I’ve learned throughout the years from many here on the vault. For every entry in my series of modules I make I’ve managed to get them more stable (I believe). To me it seems though that the game was never intended to be played on Mac. My first module is practically unplayable on Mac.

The best adventure on NWN2 for me has always been Mask of the Betrayer. I really liked that one.
Then there’s a couple of good modules, but there are so many more produced for NWN1, and module-wise the best gems are found for NWN1, like the Tales of Arterra series and Sanctum of the Archmage series.

Ok, this has nothing to do with NWN2 Mouse not working, I just realized. Ah well… :crazy_face:

3 Likes

I reported this bug back when bugs were still being fixed. Nothing was ever done about it. If you don’t know how to fix it then you can’t play nwn2 again. Even uninstalling does not work unless you manually remove the left over files. I even have a different computer with a different operating system now and this bug still happens.

Yeah, it’s certainly a game killer. You wonder how many people gave up because they couldn’t find the solution. Pity as the game itself is pretty good , imo.

Obsidian just did not care about this serious bug. I have not bought any of their games since NWN2. I don’t trust them to fix problems with their games.

1 Like