(no problem for me here :)

Hey guys. Thanks for all the quick replies! Looks like none of my Act II saves have the West Harbor.Z file. As far as travel from certain locations, I had tried travel from Crossroad Keep, Port Llast, and Highcliff all with no luck. I do use the Client Extension.

Could it be as easy as getting a properly saved Act II file from someone and dragging that into my save folder? Or is a remedy a little tougher? Additionally, any chance you guys see some other issues in this save file?

I see a missing Z file for “Slums” but I am not sure I’ve unlocked that location yet. I just got to the point where I took control of Crossroad Keep.

not really. Unfortunately the .Z files are “your save” for that  area  module – it’s the state that you left the  area  module in (after creating mayhem there and whatnot) … if for example you’ve done or partly done a quest there, some variables that track the quest could be contained in the .Z file …

It’d be better to reload a previous save, rather than copy in another file (which might or might not be ok-ish). /shrug


Gotcha, well that’s unfortunate. I’ll reload an earlier save from Act I going into Act II and see if I can get the proper file to save. I ran a small experiment and copied over an Act I .Z file to my Act II save, and although I’m sure that’s slightly illegal it seemed to work okay for completing two quests… Although, I’m not sure if the area was set up completely correctly. It doesn’t look like there is much going on in West Harbor during Act II, other than telling Retta Starling about Lorne and giving Brother Merrin a tithe box.

Regarding the .Z file that isn’t there for the “Slums”, is that perhaps because I haven’t unlocked/visited there yet?

I also have another unrelated question… Upon looking for the save files, I realized there are two NWN2 folders. One which is where I installed the game at through GOG, and another which exists in the Documents folder. I’ve got all the mods and fixes in the override folder where the game is installed through GOG, but there is also an override folder in the Documents one. I haven’t noticed any of the fixes not working, but is there any issue here?

no it really should be there I believe … id copy that one in too …

sort of. Both folder hierarchies work but if you have to reinstall it’s likely going to delete/overwrite the install directory. But if you put your stuff in MyDocs, you can at least copy the MyDocs/Nwn2 directory someplace safe before doing an uninstall/reinstall …

So you should put all your mods/add-ons/customizations under your MyDocs folder … the installation folder should be left untouched (unless you’re doing quirky things that require it)

It should be okay to copy your extra stuff from the install /override (or wherever) into the corresponding folder under MyDocs (just make sure that the game and the toolset are closed when you do)

I fixed it by copying the Z file from an earlier save and pasting it where it was missing.

Check out my post from 2021:

NWN2: Old Owl Well Cut Scene

Long story short, when the party left CK and took care of Highcliff, I didn’t realize the save before leaving CK was missing CK’s Z file. After finishing Highcliff and returning to CK, CK was messed up. To fix it, I pasted the Z file from an earlier CK save (likely from a save made while in the basement, or just after leaving the basement) into the save made just before exciting CK.

As far as The Slums, I’m not sure if the game makes a Z file before it’s visited. My gut feeling is it should be there.

I’m deployed at the moment and unable to get to my computer for a few days to check. (I’m lucky to have any internet access).

Resist the temptation to mess with the games’ install directory. I can only think of 2-3 reasons to do so, none are quite worth it. Only tinker with things in DOCUMENTS. (Oops, KevL already said this…)

I now make a standalone save everytime before my party transitions.

PS:. Thanks for the screenshot. It confirmed we’re all talking about the same directory and files. You’ll likely find the missing Z file in prior saves. The problem may be that the Z files have been missing in many successive saves.


Above was from a different thread.

Regarding #1, I have a hunch it may be possible to have two of Tor’s Holy Symbols, and likely not a failure to take the symbol. This happening really rings a bell. I seem to remember looking at the inventory and seeing two during one of my last 2-3 playthroughs.

I’ll check some old saves prior to returning to Fort Locke.

I could be TOTALLY misremembering.

I just did a search (super high reliability :roll_eyes:) and found posts mentioning having two Tor’s Holy Symbols. The posts were prior to nwn2fixes being a thing.


1 Like

Tor’s Holy Sybmol, Test 1:

I loaded a save from my latest playthrough, made at the end of Bandit Camp. the PC had Tor’s Holy Symbol, and only one. The party returned to Fort Locke, spoke to Tor Millows, and handed over the Holy Symbol. The symbol was correctly removed from the inventory. (nwn2fixes is installed)

Edit: A couple things:

  • I can’t remember how the conversation with the bandit leader went, or even if I left him alive and agreeing to no longer rob folks. I loaded the Bandit Camp save and ran back to the bandit leader’s room. Nobody was in the stronghold, for whatever that’s worth. :slightly_smiling_face:
  • Just for the heck of it, I loaded the save made immediately before entering the Inner Sanctum. No one in the party had the holy symbol. This just confirms the party didn’t have two holy symbols during this runthrough.

I really think I did have two during a playthrough.



noted, will search for where/how the Symbol is granted when i get a chance

Bug (and fix) for epic bard song of requiem

To reproduce: Don’t have the epic feat lasting inspiration to ease testing. Use song of requiem. This will run 5 to 10 times depending on if you have the lingering song feat. During this time, cast some other spell or use one of the other bard songs. Wait for the song of requiem cooldown timer of two minutes to end. Use song of requiem again. It does nothing, no bard feat uses are used but the feat cooldown timer starts again. After the cooldown timer expires, the song of requiem can be used normally again. This can be quite frustrating, the NWN2Wiki talk section for this feat has a note about it being bugged and only working half the time.

To fix: In the script nx_s2_sngrequiem, change the call in RemoveBardSongSingingEffect to use nSpellId instead of GetSpellId(). GetSpellId() gets reset whenever a spell or feat that uses a spell script is used.


@TonyK re. Song of Requiem script

comparing the stock script against Kaedrin’s, i notice that GetCanBardSing() got removed (it checks for Silence/Paralyze/Stunned/Sleep/Petrify). That seems odd, or do you believe it’s not needed ?

1 Like

@kevL_s ,

I think it calling GetCanBardSing() should get done. It looks like GetCanBardSing() was left in for other bard songs and inspirations by Kaedrin. It might have gotten accidentally removed as part of intentionally removing AttemptNewSong to make Song of Requiem no longer count as an inspiration. Another issue is that he left in RemoveBardSongSingingEffect which isn’t needed with the singing effect for inspiration no longer being done. This could accidently remove the currently running inspiration if it was recently cast.


ok Thanks. I’ll look through those functs etc and try to amalgamate a better script …


Anyone tried fixing the Swift And Silent feat? Apparently, it’s supposed to be available after you get the Stealthy feat, but for some reason, it was assigned as a class feat with no class attached, so it can’t be taken.

On top of that, if taken with the console commands or items, it doesn’t seem to work.

But that’s what I read on the Wiki, I never knew it existed until earlier.

Did you try adding a line in cls_feat_.2da where class is “fight” for fighter, “wiz” for wizard etc… referencing the Swift and Silent feat? Then the modified classes would be able to get it after they have the Stealthy feat. I suppose you could start with cls_feat_rog.2da

@kevL_s In a creature blueprint, when I select the “Female, Playful” Sound Set and attempt to play it from the pop-up menu button, the toolset crashes. The remedy for this is to place a repaired ‘vs_fx0slinf.SSF’ file in the Override folder.

Note: this file is available from the “Library of Missing Audio Files for NWN2”, under the ‘SSF_Fixes’ folder. My suggestion would be to just add everything in that folder to the Override; that way the sounds will play properly in the toolset. I think you’d also need them in your game hak.


unless player also has Nwn2Fixes with the fixed files, right?

Should i push all files from Library of Missing Audio Files for NWN2 into Nwn2Fixes ?

1 Like

The full set includes files from NWN, so I’m not sure if those would be considered “fixes” as such.

1 Like

ok Tks. will simply unzip the .SSFs in then.



looks like you could change “ALLCLASSESCANUSE” from 0 to 1 for general usage (and “FeatCategory” from CLASSABILITY_FT_CAT to GENERAL_FT_CAT).

tbh i was playing around with faster Stealth speed based on custom feats a couple of weeks ago. (a lot of it seems hardcoded) The idea that i used was to modify “Modebar.XML” to run a custom script in its UIScene OnUpdate event, sorta like this →

<UIScene name="SCREEN_MODEBAR" x="ALIGN_RIGHT" y="ALIGN_BOTTOM" width="169" height="132"
draggable="true" fadeout="0.1" fadein="0.1" scriptloadable="true" priority="SCENE_INGAME"
update="true" updaterate="0.3" OnUpdate='UIObject_Misc_ExecuteServerScript("gui_modebarstealth")'
OnAdd='UIScene_OnAdd_SetupSpecificHotbar("MODEBAR_GRID",120)' />

That would run a script sorta like this (every 0.3 seconds) →

// 'gui_modebarstealth'
	For Stealth movement speed increase when character has certain feat(s).

const int iSPELLID_STEALTHBONUSSPEED = 35634; // arbitrary (no conflicts)

void main()
	object oPc = GetControlledCharacter(OBJECT_SELF);

	if (GetStealthMode(oPc))
		if (!GetHasSpellEffect(iSPELLID_STEALTHBONUSSPEED, oPc))
			if (GetHasFeat(FEAT_SWIFT_AND_SILENT, oPc, TRUE))
				// NOTE: EffectMovementSpeedIncrease() has range 0..99
				effect eSpeed = EffectMovementSpeedIncrease(50);

				eSpeed = ExtraordinaryEffect(eSpeed);
				eSpeed = SetEffectSpellId(eSpeed, iSPELLID_STEALTHBONUSSPEED);

				ApplyEffectToObject(DURATION_TYPE_PERMANENT, eSpeed, oPc);
	else if (GetHasSpellEffect(iSPELLID_STEALTHBONUSSPEED, oPc))
		effect eScan = GetFirstEffect(oPc);
		while (GetIsEffectValid(eScan))
			if (GetEffectSpellId(eScan) == iSPELLID_STEALTHBONUSSPEED)
				RemoveEffect(oPc, eScan);
				eScan = GetFirstEffect(oPc);
				eScan = GetNextEffect(oPc);

But the changes involved might be a bit much for Nwn2Fixes (without a better consensus i guess – enabling a feat, the change to a gui and its OnUpdate tick, the added script …). Or i’d have to investigate whether the hardcode for FEAT_SWIFT_AND_SILENT actually works or not before going wholehog, etc. Tbh it’s a bit hard to notice a 50% stealth-speed increase …

1 Like