Path of Evil Remastered


#1

Continued from the old forums: https://neverwintervault.org/forums/neverwinter-nights-2/nwn2-modules/path-evil-remastered

If you want to post bugs, this is the place. If you want to leave feedback, this is a good place too.


#2

Here we are in the new digs. Sorry to be a downer on my first post on this side but…

I still can’t enter Agarar Summoning Circle from the overland map.

Oddly, with the fix in override, going back to an older save, forging the thin keys do result in getting a key. Unfortunately it is Terivar’s Key. Also the item code also produces Terivar’s Key. This key says it belongs to Terivar Velauntur from the Dock Ward so it is something from first chapter. Is it possible that in making changes during the facelift that the Ekkathys key got overwritten?

I still end up in the mines when I enter Ekkathys from the overland map.

The silver lining is that the rebake of the cave did the trick and that can be entered normally.


#3

Try it again (same link). It looks like I didn’t include the updated script for entering Ekkathys, and I updated both the Ekkathys key and the Terivar key. Don’t know about Agarar at this point.


#4

That did the trick.

As to Agarar, it is not exactly plot imperative. I will skip it and move on.

Though of course my first thought on running into problems was to remove possible override conflicts, and with or without seemed to make no difference, but it is worth noting that I am playing with Tchos HD UI panels and dialogue in override.


#5

The second level of the crypt behind Baranthyr crashes the game whenever you try to climb down to it. When Travus was fixing similar crashes in Whiteplume Mountain, I think he said this came down to issues caused by missing ceiling tiles. Might be something similar.

Also, the smith is not offering an option to upgrade weapons or armor.

When I had the old guard tower turned into a wizard tower the tower itself vanished save for the front door. Edit: Scratch that. The tower didn’t update and I can’t be sure the attempt is what messed up the visual. I know I could see the tower when I first walked by and can’t know. That is all I can be sure of.

Edit: The door to Zeketh Orlyrae in the drow outpost under Calimport is unreachable. This would be a showstopper since you can’t leave until you complete this but I have been to Ekkathys and have a stone of recall.

Some cave assets are missing in the illithid area. Nothing that stops progress.

Kamal, it occurs to me to ask if you want me to mention every bug I run into or just the critical ones? I am happy to go into whatever detail you want.


#6

You can Vault email me whatever bugs you want to report.


#7

Yder Tanthul is a right bastard. But he and his shadovar lackeys are dead now. Serves them right.

Not really a bug report, but needed to be said.

On topic: there are some missing textures in the Shadovar maps.


#8

The mindflayers in Bree go hostile when I approach. I am not sure this is a bug but I seem to remember being able to talk with them in the old version of PoE. Just in case particular party members matter for them going hostile, I have Laisera, Carcarin, Mu’tasin, and the Tortured King with me.

I am still testing it all but it seems like all the areas that require a certain companion to enter are stuck. Whatever is supposed to trigger if you do have the right companion along is not triggering. Maybe this is a result of the change to the SoZ party system. That is my only guess, at any rate.

I have checked a bunch of the locations on the map and most seem to be bug free.


#9

The Tortured King doesn’t like mindflayers due to his background, iirc this causes him to attack them on sight.


#10

That would do it.

I went to get Garnet’s treasure horde in Myth Drannor but it seems some trigger isn’t firing. I can go to the treasure, and pick up the book but nothing happens. When I go back to Ekkathys there is no dialogue related to the treasure either.

Also, the keep timer is stuck on 25%. I assume as in the original campaign, plot has to progress to trigger being able to go further (So far I only have two crown pieces since I have been exploring to test map locations) but I was wondering if being capped was causing a problem with whatever dialogue might relate to the treasure horde.

Lastly, what map locations are tied to which follower’s personal quest? I want to systematically test them all to make sure I am right about not being able to enter their areas but I only remembered one for sure.


#11

The guardian naga and sand worms in the oasis/monastic outpost that you can reach via the portal are not visible. Thankfully, companions have no trouble attacking them. Also in the ruins, the central exit to the surface has pathing issues that make it impossible to reach.


#12

The companion quests with unique locations are
Witchlea Bridge (southwest Faerun, near the top right on the map) for Mutasin
Agarar Summoning Circle (northwest Faerun in the Anauroch) for Carcarin
Araelluwen (northwest Faerun, in the Dalelands near the top right on the map) for Alira
Westergrass Marsh (southeast Faerun, near the middle of the map, in Lurien) for Timoteo

Odd that the keep timer is stuck, because I tracked that bug down in the keep demo, fixed it, and copied the scripts over to here. Either I didn’t actually copy them over, or there’s duplicate scripting.

I’ll look at other things as I have time (eg this weekend probably).


#13

None of the areas specific to companions work except for Alira’s which is perhaps more perplexing than none of them working. Also, she does not level up when she joins, starting with zero xp.

Factors specific to my playthrough that might be causing issues are that I have the leadership feat and that the slot that added was used for an SoZ style companion. The next time I go through this I will take neither. Anyone else considering a playtest also may want to see if not using the feat or SoZ style companion fixes the issues.

In testing all the companion areas I dismissed a lot of companions. They do not seem to have shown up at Ekkathys.


#14

I currently have no power (and thus no heat) at Chez Kamal, with an eta from the power company of Sunday evening, so no fixing things until the power is restored.

/ not dragging my desktop to a hotel.

// on the other hand I have an oil lamp at home for emergency light, so I’m living the DnD life yo.


#15

Getting heavy winds here and I expect I am one fallen branch away from sharing your fate. Though it is probably a lot warmer here. I would probably just bundle up and try to make do at home.

I hope power is back quickly. Stay safe, and don’t forget the sacrifice to Auril.

On topic, I tested all the portal locations and save for problems listed earlier all seems well. I am puttering around in Pros at the moment. Heh. Didn’t notice the scroll merchant’s name was Vellum in older playthroughs… :smiley:


#16

https://www.dropbox.com/s/76urvgkedjhqg2d/poe_patch.7z

Fixed and tested the inability to enter companion areas (you may need to ask them to talk about themselves to start their quests).
Should fix stronghold time not advancing.
Should fix the smith not offering weapon/armor upgrades for stronghold forces.

I’ve fixed and tested the naga/purple worm not appearing, the walkmesh issues, the missing textures, the crashing in ruins behind Baranthyr (you were right, tiles missing texture entries, just like White Plume Mountain) etc, but those are not included here. Also I can confirm that the mindflayers in Bree are hostile because the Tortured King was in the party, and he auto-attacks them (because of his backstory).

Not fixed: companions not going to Ekkathys. I did test dismissing companions from a different module (specifically in Bedine, but they use the same scripts) than their “home” point, so I need to investigate that.


#17

The stronghold seems to be progressing again.
The smith is still not upgrading weapons or armor for stronghold forces.
An additional oddity is that I have both gnolls and skeletons patrolling the Ekkathys now (I picked gnolls back when I took over).

Another bug I have noticed that in no way impacts gameplay is some of your loadscreen blurbs are pulling from the wrong files. Sometimes I get lore of one type or another but sometimes I get things like “partial plate helmet” as the loadscreen text.

I am glad your time without power is over


#18

Is the smith asking about upgrading the troops arms and armor? he should do so even if it’s not working, the conditional for that being available is having the journal entry for owning the stronghold (set when you talk to the majordomo the first time).


#19

Nope. You just get an option to access the store and an option that says you are just admiring his work. I just checked to make sure and I do have the journal entry saying I am in charge of the stronghold


#20

https://www.dropbox.com/s/4yimjqcr2b2szhg/ek_smithy.dlg

It checks that you have the stronghold in the journal.