Path of Evil Remastered


#21

I am afraid that did not fix the dialogue. Is there a chance the earlier fix for getting the thin keys forged is interacting with the troop upgrade option?

Edit: Nope, removing the key fixes didn’t help. It was worth a shot.


#22

Fixed the smithy conversation (same link).


#23

The smith conversation has some progress but I still can’t upgrade weapons or armor for the troops. I get an option to ask about improving weapons and one for improving armor but all I can do from there is talk about how the troops are currently equipped or return to the main conversation tree.


#24

By the way, the Ruined Temple in the SE map is broken, map is there but on screen there’s just black and i can’t move.


#25

I confirmed that one today. Which is actually really weird because that exact thing is an old bug that I specifically resolved at some point, so something broke in there again.


#26

I managed to miss that location. Just checked and yup, I can confirm dark and immobile.


#27

Almost done here, but:

the cavern below the Karas Family Mine crashes my computer when trying to enter.
Same goes for the basement of the planar inn, showstopper as for now.
Henchmen Quests don’t work, even though i can enter the areas now.Might be my game, i’ve had this on the old version, too.


#28

https://www.dropbox.com/sh/zaj2k5u26g3r9s4/AAAtGG0Ta4M0hwgoRgl8Ywofa

Fixed for the planar inn basement. Interestingly, all the various areas in here and in White Plume Mountain that have had this problem all use the RWS Deep Chasm tileset. They are displaying texture when viewed in the toolset, but they don’t have a texture assigned when you look at the properties of the tiles.


#29

Yes, the RWS Deep Chasms tiles have a number of oddities and inconsistencies in how they were built.


#30

I found a major bug in Calimport Muzaad. During the “Trade Dispute” Quest you’re supposed to find Nassir (or whatever that guy’s name is) to get the quest, but the building he’s supposed to be in, is locked with a DC of 99, which effectively makes the quest impossible to complete, since the door is also indestructible.

By the way, is there a reason that building doesn’t have dynamic collision turned on? It’s very jarring to see my entire party just walk through the building like it’s not even there. :crazy_face:


#31

Fixed the Trade Dispute bug. The walkmesh part was already fixed, but now when the tout tells you about the quest the door will unlock.


#32

Thanks, for fixing it, kamal. I already opened the area in the toolset and fixed it myself, but where can I download your fixes up to this point?


#33

If it’s not in this thread, it’s not posted yet. The Trade Dispute bug isn’t game breaking as it’s not a main plot quest, so I didn’t post the fix.


#34

The Bokhara Golem Works still has some faction issues. The only golems that are not hostile in the entire place are Aldric and the Thayan Golem that patrols just outside his room. Even the Iron Golem with Aldric is hostile.

Even so, the quest is almost complete-able since you can talk to Aldric and then go kill the Red Wizards, with their golem support. Tough fighting, but possible. Where it all goes wrong though is that the golem body you get at the end is also hostile so you end up having to kill it.


#35

Should fix the abandoned temple in southeast Faerun, some sort of walkmesh issue, I worked around it. I’ve tested this myself.

I’ve also made some faction adjustments to the golem factory. The hostile golems were in the Defender faction, so somehow that faction got angered. They are now in a new factions call Player friendly that friendly to player, hostile to hostile, and neutral to everything else. The golem body at the end is now neutral instead of Defender as well (Aldric was also neutral, so that should fix the golem body and allow the quest to be completed). That should hopefully fix it.


#36

I will go back and test after Nag Hammadi.

Nag Hammadi is going well so far but the walkmesh in the basement only allows for movement along the central chamber. The side chambers are unwalkable. This is my last crown piece and all other crown areas worked without issue.

Those mage golems are no joke. Just as tough as I remember them. The brutal, brutal fights continue.


#37

What, exactly, makes them so tough? They are weakened iron golems (with standard golem resistances), plus some mage levels. They are meant to be mages the generally have low level spells, and that are also capable of standing up in melee, but not super-overpowered. Golem killing spells like Crumble should be super effective. They are not meant to be unfair (unlike the undead dungeon where you’re warned about that when you enter).


#38

Oh that wasn’t a complaint. I made things harder on myself in terms of self imposed gear limitations and a far from optimal party. Since I did almost every location and side quest before hitting this location and they scale up, they are chucking decent level spells. And I tried not to prepare specifically for fights I only knew were coming because I have played this many times before. These are some good fights.

Hmm… I wonder if I can stealth into that undead dungeon and just pilfer the sword…


#39

My playtesting is done, I think. Hopefully I didn’t miss anything.

The ruined temple is still missing a few things. One wall in particular in the right chamber has only one side.

Karsadin can’t be raised or ressurrected.

The final cinematic cuts off before going over what happened to the various companions. Could this be messed up due to the change to SoZ party, or the attempt to have companions not leave forever, or presence of the leadership feat? The cinematic goes blank so maybe it is still progressing but something is mucking up the presentation.

This really is a fantastic mod. I am glad you are giving it a second look, Kamal.


#40

Hello, I just started your mod yesterday and I love it so far. That being said, I have hit some issues. The second cave still makes you vanish and you cannot enter; is Sirocco in that cave? I looked everywhere else on that map and cannot find it. Also, when you first start out, Druids are put on the warrior path with no option to choose the cleric path. Playing a woodelf neutral evil druid with martial weapon proficiency. Not a big deal, but I thought I would mention it.