Path of Evil Remastered


#41

I have found out the scimitar is in that cave. I can’t finish qsar without it. I tried to get the fix you made from the other thread, but dropbox says it isn’t there anymore. Even if I could just mark that subquest finished so I can move on the the larger quest, I would be happy. Thanks for all your hard work. I really like that I can change classes for my companions. I made the tortured king a fighter/cleric. I was a little disappointed he could not choose Umberlee like my druid, but that is ok.


#42

One other thing, the magistrate said I could keep Ghazi’s ring but took it in the conversation.


#43

I had that, too.Item code is just “Sirocco”, so you can spawn it with the console.


#44

giveitem Sirocco?


#45

Yes


#46

All reported bugs now fixed. It will take some time to get things uploaded.


#47

Files are all up to date, with a bunch of fixes, mainly in Al-Qasr, Calimport, and the strongold city. fixes


#48

Hello, is there a link to just the fixes? or do I have to reload the entire thing?


#49

I am hitting more bugs. In Calimport Muzad, Nasim’s door does not open even though I have the quest from the old tout. In the temple of Shar, I got the key to the teleport room so I can visit the underdark but when I open the door there is no link to enter.


#50

I’ve added a fixed and personally tested version of Mutasin’s dialog.

Also, I am unable to reproduce the bugs listed above. Those sound like they are from a previous version, before I fixed the various Calimport bugs (including tile issues in the Shar temple).


#51

Found a few bugs

  1. Calimport, Temple of the old night, no access to the back of the temple.
  2. Al-Qasr, Temple of Ilbrandul, left hand door opens, have to use “WADS” to get to the lower level.
  3. Al-Qasr, Agran Waaha, cave transition to the Pasha’s Scimitar cave does not transition to the cave, the characters become transparent.
  4. Pros, Church, Vampire Quest kill the priests, Cannot walk down the center isle easily.
  5. Bree, Illithid slave supply, Illithid become hostile after aquiring a slave supply for them.

#52

I am in the summoning circle with Carcarin, but the quest doesn’t start. Carcarin does nothing. I can’t talk to her about it even though she mentioned it just before we transitioned into the area.
I couldn’t bribe Mutasin. He acts like we already spoke. He will not join the group, he acts like he already did, but has not.


#53

Do you have the Mutasin dialog override from the Vault page? That specifically fixes the join dialog, I have tested it repeatedly.

How are you killing the kobolds in the first summoning circle? This is another thing I’ve repeatedly tested successfully (literally successful 10 times in a row).


#54

There are no kobolds nothing happens. I even turned on debug mode so I could make sure she crosses the trigger points. Nothing happens. She mentions the quest before we transition, we transition and we walk around taking multiple paths to the summoning circle. I have quit and reloaded 3 times. I have left the summoning area and returned several times. I am at a loss. Between Mutasin and Carcarin, I am wondering if I should delete POE completely and try a 100% fresh download?


#55

I checked the summoning circle. I thought they were kobolds, but they are bladelings. They are manually placed in the area, not spawned, so they should always be there since there’s no chance of a spawn failing.


#56

Ok, I am redowloading the whole thing. There were no bladelings or anything else there when we entered. I have no problem restarting.


#57

@kamal
I would’ve just reported these bugs via a message but I started digging through the files and found a lot (hundreds) of loopholes/bugs. I figured it would be better if I just made the fixes myself and give the new files to you. Otherwise, I imagine, you would have been overwhelmed with it all. There is a change log with the fixes file.
So far these fixes are only for everything in the SouthWest quarter of Faerun. I’m working on the other quarters.
Some major fixes include:

  • The warehouse fights in neverwinter (rogue/fighter paths) now execute very nicely.
  • Any uncontrolled rogues that automatically open locks or disarm traps now also get XP and a notice appears letting you know this. XP is divided among the party.
  • The troublesome tiles in the Temple of Old Night and Tortured King Ruins are fixed.
  • Companions that have been removed from the party now reliably spawn at their designated locations (prior to finding the stronghold).
  • The annoying “black void on transition” bug fixed.
  • Fixed an issue with some of the “defender” NPCs in Qasr (and the Pier area) that would attack you after dealing with the Genasi in Intisar.
  • Under some circumstances you would not be able to recruit Mutasin. Now you can (under the right conditions).
  • The loading screens sometimes displayed some odd tips. This is now fixed. See install notes.
  • The custom cleric domian script didn’t seem to be working as advertised. I scraped it and used some extra code to reset Mutasin and Laisera based on the packages.2DA. See install notes.
  • There are literally hundreds of other minor fixes.

You must have the Feb 03 2019 version of Path of Evil from the Nexus installed before using these fixes!
Extract this file into your <mydocs/neverwinter nights 2> folder. All files are set into the appropriate folders so just click yes when it asks to overwrite.
Next, delete the following files from the Campaign/Path of Evil/resources/2das folder:
loadscreens.2da, nwn2_tips.2da and packages.2da.
These files are now represented in the hak or the override folder. Apparently, due to some weird bug in the engine, edited versions of these files don’t work reliably from the campaign folder. Additionally, an edited packages.2da won’t work from the campaign folder nor a hak file. Don’t ask me. That’s why I have it in the override. This is a necessary move for the domain reset on Mutasin. So make sure there are no other copies of the packages.2da in your override.
Of course, these fixes need to be tested for confirmation.

**************UPDATE*****************
3/3/19
This now includes fixes for the NW quadrant of Faerun.
Major fix for the Carcarin quest.
Many minor fixes.

**************UPDATE*****************
3/8/19
Now includes everything except the Stronghold and the Final module -I’m working on those next.
Major fixes include a few areas that had troublesome tiles. Several custom tiles were causing much trouble. If I could not replace them with an adequate variant, I had to delete the MDB file from the \Campaigns\Path of Evil\resources\models folder.
The following files have been deleted as I could not use a variant to replace them to get a proper bake:
TL_SF_HHHH_03.MDB
TL_SF_SPU1_02.MDB
TL_SF_SPU3_01.MDB
TL_SF_WWCC_03.MDB
TL_SF_WWWC_02.MDB
TL_SF_WWWC_03.MDB
TL_SF_WWWX_11.MDB
TL_SF_WWWX_22.MDB
TL_SF_WWXX_18.MDB

Made some modifications to Timoteo’s quest.
Many minor fixes.
**************UPDATE*****************
3/17/19
All done! Lots of major fixes in the stronghold module. Four areas crashed the game as soon as you tried to enter them - they are all fixed. Several bugged quests are fixed. Cleaned up a lot of loopholes. The temple building can now be accessed after repairing it.
A ton of minor fixes.

These fixes could use to be tested to make sure I haven’t created other bugs. Other than that, I think the game is greatly improved. Make sure the 2das and MDAs mentioned above are deleted, else some problems will remain.
Thanks kamal! I actually enjoyed digging through this mod in the toolset. I learned a lot!


#58


Whoa!


#59

When you’re done with this, I’d like your permission to include it.


#60

Yep, you can have all of it. I’m doing the southeast quad now. After that is the northeast.