Placeable Cloning - Weird Results? (RESOLVED!)

I used MDBCloner to clone a banner model so I could change the image it had on it.

So, I cloned model PLC_MC_BANNER10_X2 (2da line 2696) using my own image. I added my model at its own new 2da ref.

I loaded the toolset and my new blueprint model worked. HOWEVER, when I went to open the original blueprint to compare , it also had my own image!

BUT, and here it gets even more weird, if I dropped in an instance of the original before I brought in my own into an area, BOTH blueprints would now show the original image!

So, whichever blueprint I used first in an area dictated which image would show!

What if I want/need to use both blueprint images?

Where have I gone wrong?

Thanks in advance.

Maybe @rjshae or @4760 or @kamal have any ideas why?

RESOLVED USING @rjshae UTIL:-

https://neverwintervault.org/project/nwn2/other/tool/mdbconfig

I’m quite sure you changed the name of the mdb when you cloned it, so the only reason I can think of at the moment is that you need to create a new blueprint with your new appearance (or, if you use the original one in an area, change the appearance in the dropdown list in its properties).

1 Like

@4760

Yes, I changed the name of the mdb and made sure that was the correct one on the new 2da line.

I also made sure my new blueprint was the one with the correct 2da line ref as appearance.

As I say, it’s really weird …

  1. If I place the original down, my own version will also look like the original if placed next.
  2. If, however, I place my version down first, then using the original after will also look like mine!

I tried changing areas from where I placed an instance of my own down in an area and now any I use are all my versions. (i.e. I cannot use the original from its original blueprint.)

I contacted @kevL_s as well, as I am wondering if it is a limitation of the way MDBCloner works. I think the file it “clones” only replaces limited elements and so some “original” code that remains somehow makes reference to the original mdb.

Opening my new mdb file, I note this in the opening lines …

NWN2     RIGD$   COL20  COL34  RIGDè/  PLC_MC_BANNER10_X2 C3           ALB_BANNER_NARMOR               ALB_BANNER_NARMOR_N                                             ALB_BANNER_NARMOR                 €?  €?  €?fff?fff?fff?…ëÑ>ÿÿoA   »   Œ   _'¿Óé½é`õ?r’¡¯  €¿ôô:³øÖ¿ç	ü0˜ë½   €õô:3  €¿ù2ä;^Ä~¿  €?_'¿½é½

i.e. I notice PLC_MC_BANNER10_X2 still referenced there, which may be confusing how it works. I would have thought this to say ALB_BANNER_NARMOR. Scratch what I just said, as I obviously have tried other updates to this file since.

Here is what I have …

@4760
@rjshae

I fixed it!

I discovered @rjshae had his own great mdb utility … (See link), which allowed me to alter the part I thought was wrong in the file and it now works as expected!

(It was something to do with the “Packet Name”.)

Thanks everyone!

https://neverwintervault.org/project/nwn2/other/tool/mdbconfig
4 Likes