Player Placeable Props

I have a pw server running nwnx.
The module has this script (x2_mod_def_act) in the on activate item hook.

I have tried two solutions and neither of them have worked.

  1. Created Item with i_tagofitem_ac that runs a script to spawn a placeable.
    (I have decided not to go this route)

  2. Created item that opens a conversation window and then the player can choose from a list of placeables that are using the conversation script ga_create_object. I inserted the tag and the “p” in the actions tab for the placeable that I created. The location defaults to OBJECT-SELF.

In both methods, the placeables are not spawning in. Is there something about spawning placeables in a pw running nwnx? My scripting is terrible, but I would have thought that using the conversation method would have eliminated my scripting involvement. and yet still nothing spawns in. Are there area settings the would prevent it or module settings? Any help and knowledge would be awesome.

I have attached my second method which works in a non pw module.
Placeable_Method_2.7z (1.9 KB)

I’ve only ever spawned placeables to a waypoint, you could stick one in and see if it works. Also check you have the right tags etc.

1 Like

I tried changing the location to waypoint in a non pw mod.
The item opens the conversation and I place the placeable at the waypoint I placed. so this works too in a non pw mod,

But, when I go to pw mod, the conversation no longer works. And when it did, it would not spawn the placeable. I don’t know what is going on.

There might be something to do with the settings that’s different on a pw mod, you could try spawning a person that way you can see if it’s a placeable thing or a spawn issue.

1 Like

Here is what I did and got it working.

My Method worked in a non pw mod. So, I just made that working mod into a directory and copied my pw files to it. Then added my haks, campaign, and mod scripts in the module properties. Advance compiled the scripts, staged, and loaded onto server. It worked, placeables spawn as intended.

My only conclusion was that something was corrupted in my pw directory, cause I did not change any scripts or haks.

Maybe this is just another case of toolset weirdness.

1 Like

That’s good and sometimes it’s just best to chalk it up to toolset weirdness.

I know they keep going on about AI and I’m not really interested but it would be quite nice to be able to ask your computer “why isn’t this working and what’s your problem, you’ve done this loads of times before !”

The reply would probably be “because you missed a comma and I didn’t understand what you meant.”

1 Like