When placed in an area, the PLC_MC_LEVER1 (Floor Lever) works as is with just the ‘x2_plc_used_act’ script in the ‘On Used Script’ slot. However, the PLC_MC_LEVER3 does not. I’ve been trying to figure out why that is. One thing I noticed is that the former uses PLC_MC_LEVER1_IDLE/**PLC_**OPENIDLE/**PLC_**TURNON gr2 files while the latter uses PLC_MC_LEVER3_X2_IDLE/OPENIDLE/TURNON gr2 files. But I have seen some containers work using OPENIDLE gr2s. Has anybody out there managed to get the PLC_MC_LEVER3 to work?

For animations for placeables to work, you need to name them as follows:

  • idle: PLC_tag of placeable_Idle.gr2
  • idle in open position: PLC_tag of placeable_PLC_OpenIdle.gr2
  • closing: PLC_tag of placeable_PLC_Close.gr2
  • activated: PLC_tag of placeable_PLC_TurnOn.gr2
  • opening: PLC_tag of placeable_PLC_Open.gr2

That means you’ll need to extract the PLC_MC_LEVER3_X2_OpenIdle and PLC_MC_LEVER3_X2_TurnOn gr2 files from lod-merged_X2, insert “_PLC” just after X2, and it’ll work.

By the way, Windows doesn’t care about upper/lower case, it’s just a habit I have to make the purpose of the animation more obvious.

1 Like

Actually I already tried that and it didn’t work.

It worked when I tested it before posting. But I noticed there are some files in my override that are not in the \Data folder, so it’s likely I fixed it along with my animated placeables pack.

Anyway, in case I didn’t include it, try this.

Okay, thank you. Has that been included in kevL’s fixes pack? It might be worth adding that in.