Please Help - weird glitch with "Open Lock"

I’m working on crafting a few different modules and have noticed a strange glitch has appeared in all of them. When ever I playtest them and a PC tries to open a lock, I get the following message back: “Open Lock: success will never be possible.

These are not marked as “Key required to unlock or lock.” I’ve tried different DC settings, different placeables, different Rogues with varying Open Lock skills, various Lockpicks. Nothing works. I’m not using any Haks with any of these modules.

Any idea what might be causing this and how to fix it?

The player character probably has insufficient skill then. Never heard of an issue that would case this.

Eitherway if you post one area with this problem I can take a quick look if there aren’t some scripts perhaps.

From what you write I take, that there’s actually only one explanation: Your characters don’t have the lockpick skill. You must put at last one skillpoint into the skill at character creation/levelup. The skill can’t be used untrained.
Anything else … comes near to mysterium which will never be solved. Try to reproduce it with a new empty mod, one area, one door. If the bug is still there, post it (as shadow mentions).

As I said in the OP, I tried a number of different Rogues with different Open Lock skills and got the same message each time. This included a level 36 Rogue for who any basic lock should be able to get through easier than a wet paper bag. The message is “success will never be possible” - meaning it isn’t a case of insufficient skill but rather the system has determined that opening the lock is impossible under any circumstances.

The system itself seems to be doing something with the Open Lock skill. When I looked at the character sheet in the model - the “Open Lock” skill has been completely removed from the list.

I’ve attached a new test model with several different locks. Each time I try to unlock something I get the same error.
Lock (8.1 KB)

It’s doing this with every module now.

Check your override folder and if you’re on EE your development folder too. When developing one or more modules you should definitely have the override empty. If you haven’t put something in the development folder to check it out before including it in your module (as a hak, a script, etc.), then it also needs to be empty. As this is happening in every module I strongly suspect that whatever is causing this is in one or both of those folders so try emptying them. If that doesn’t work, do you have any patch haks? If so try disabling those too.

The reason for developing things clean is simply because you may rely on something that other people don’t have. Hak files don’t have this problem.


The screenshot is self-examplanatory.

That character has no ranks in Open Locks skill. Normally Open Lock would be between move silently and parry but it is not on your screenshot.

My guess is that you have somewhere in your haks, patch-haks, override or development folder a skills.2da modification that removed the Open Locks skill from the game. It is more logical than all your rogue characters not having a single rank in that skill…

Even though, I tested your module and I was able to open the chests without any issues. So it is not in module/scripts.

I’ve checked both my override folder and my development folder - and both are empty. I can’t remember ever putting anything in either folder.

I also emptied out my hak folder. And am still having the same problem. The few haks I did have involved just tilesets or clothing - nothing that should have removed the Open Lock skill entirely from characters.

Tested your module with three rogues. The Devastating Rogue (F4/R6) failed to open lock and got the message because it has no ranks in open locks. Damien Oneknife (R15) worked. Custom built rogue worked fine.

Thus, on my system - vanilla .28 Stable - it works fine. Therefore, one can only conclude that the issue is something local to your installation. If you are on Steam, run “verify files.” Speaking of Steam, you wouldn’t be subscribed to any Steam workshop content would you? If yes, it could be something you’re subscribed to.

I did try the “verify files” on Steam - and everything checked out ok. I’m not subscribed to any Steam workshop content.

It looks like it must be some strange glitch that’s developed on my local system. This weekend I’ll try uninstalling everything and reinstalling and see if that helps.

Are you sure your rogue characters have/had ranks in open lock? This skill is one of those you cannot use at all if you don’t take at least 1 rank.

The character on screenshot has definitely no ranks in it. If the assumption of some override deleting the skill was not proven, then the only other assumption is that those characters never took ranks in Open Lock in first place.

Yes, I’m certain the characters had ranks in Open Lock. This whole issue arose when I tried playtesting some of my mods and I started to get that message that it was never possible to open the lock. This was with PC’s I had specifically created with ranks in Open Lock so I could test it.

At first I thought maybe the DC on the locks was too high. So I tried lowering them. And then when that didn’t work, I thought maybe there was some issue with the placeable models I was using. So I tried substituting different placeables. And I still had the same issue. Then I tried to boost the PC’s Open Lock skills with items like higher level Thieves Tools and a Ring of Lockpicks. Still the same problem. Then I tried using different, higher level PC’s with more ranks in Open Lock. Same issue.

The thing was that the system wasn’t even trying a lockpicking attempt and then coming back with a failure response - as it does when attempting a lock with a high DC. Instead when I tried the lockpicking command, the system immediately responded that it would never be possible to unlock the item.

So I’m right … :slight_smile: The question is why. I’ll check out your mod later this day.

You don’t need to uninstall everything as the first step. Rename your Neverwinter Nights folder in /documents and then run the game and allow it to build a new folder. Then port over the module you uploaded here and see if open locks works. If it still doesn’t, then uninstall and reinstall.

1 Like

As the others, I had no issues with your test mod. Say, do you use any tools (such as Leto) to modify your character after creation/Level up outside the game?

Thanks for the tip. I’ll give it a try.

No I don’t use anything like that. In fact I make it a point to keep (mostly) to just the official content and avoid any outside bells and whistle. I’m an old school NWN player/builder. Back in the early days a lot of the players were experimenting with content and I would try it out. This inevitably led to different system problems and glitches. So I had to uninstall / reinstall a few different times. And you have to remember this was back in a time where you had to load the various Discs, along with downloading the patches through a slow internet connection. It would literally take hours. After that I decided to just keep it simple. Which is why a glitch like this developing is so strange and frustrating.

At this point, if the issue is persisting and you can reliably recreate it, I would send Beamdog an issue report with a copy of the module where its occurring as well as the character bic and a save game (saved in the module).

Issues are reported here: Beamdog/nwn-issues: Neverwinter Nights: Enhanced Edition Technical Bug Tracker (

Report it as a “Game” issue.

Also, have you tested out using Open Lock in any of the campaigns or premium modules? The DEV Team will probably want that info too.

Well I’ve finished the reinstall and tested it with a couple different modules and characters and it seems to be working fine now. Whatever odd hiccup in the system that was causing the problem seems to be gone now.

I want to thank everyone for their help and feedback.