Polymorphed creatures (including me) can't attack

It seems there’s little hope i’ll get an answer on the beamdog forums, so maybe somebody on the vault could help me.

When polymorphed i usually cannot attack anything except in the first combat round (or at all). That goes for druid & shifter forms and 4th circle polymorph spell. Furthermore, polymorphed enemies can’t attack me.

I found an old advice (this bug appears to be ancient): polymorph, rest, save, reload. It worked for my PC, but not for other polymorphed creatures. They just keep standing and turning to me.

I cleaned the override folder, went back to stable versions, deleted all the subscribes in steam workshop, reinstalled the game completely. I tried different single player modules and the beginning of HotU. Stll haven’t tested it on PWs.
Any advice on this issue would be appreciated. Thank you!

Are you on an nvidia graphics card? Have you made sure your development folder is clear? Is your userpatch.ini file empty (points to nothing).


Yes, i use nVidia card (GTX 1060 6 Gb to be precise).
Development folder is empty, and I don’t have userpatch.ini file at all.

While I doubt very much that the setting that I am going to suggest will fix your problem, it is useful to set it anyway.

Open your nvidia control panel.
Go to 3D settings/Manage 3D settings.
In the right-hand panel select the Program Settings.
Under “1. Select a program to customize” there is a drop-down box. Use it to find and select Neverwinter Nights (nwmain.exe).
On the same line press the Add button.
Under “2 Specify the settings etc.” Scroll down until you see threaded optimization. By default it is set to on. For NwN this needs to be set to off. NwN only uses a single thread.


Hm, it’s been already set to OFF. But thank you anyway.

It’s not unheard of on our PW, but AFAIK is only large polymorph against opponent that has a big model (like the invis drag models). I don’t have any of the useful technical info on that.

When you say delete steam workshop content, does that include deleting in the steam folder as well as unsubscribing?

This is incorrect. Please don’t do this unless you know exactly what it does (and it doesn’t do what you think it does based on that reply).

OGL threaded optimizations do cause some issues for the NWN toolset, and previously it was advised to do this step for nwtoolset.exe, not nwmain.exe. However, for several years now the toolset will automatically disable threaded optimizations for itself through nvapi.dll, so the manual change is not necessary.

I checked the workshop folder, it was empty after I unsubscribed.

Also, bugged forms are really all the large ones for my PC (but as I stated earlier, PC can be cured with resting and reloading - once for every module).
But NPCs sometimes can’t atack even in medium and small shapes - notably boar and panther form of druids and some wererats (for example, the witch in Forlorn maze from Ravenloft - Beyond The Gates) and werewolves (werewolf girl from the same module). At the same time, polymorphed werewolves in MTS 1 seem to attack normally (I’ve just checked that). Both above-mentioned modules don’t use any custom content BTW.

Is your game updated to the latest version?

Yes, I had latest development version, but after noticing the bug downgraded to latest stable patch. It didn’t do any good though, so now I play with dev patch again, because it’s cool.

Install Community Patch, it will solve the issue. (well it should, but it is possible that the vanilla scripts that are causing this are in your module and thus would take priority and thus the issue remain, in such case let me know).

You can safely ignore any of the replies above, it is not problem on your side but in game itself.

1 Like

You mean CEP? I have the latest version installed. But yeah, modules i mentioned don’t use it. Gonna do some testing with CEP-using campaigns. Thank you so much!
UPD. Ooops, i think you mean 1.72. Completely forgot about its existence!
UPD 2. And SOLVED! Thank you again!

So what is the actual problem/fix? Wasn’t able to diagnose anything consistent (it doesn’t affect everyone).

Old 1.69 issue with horse system, skin and polymorphing.

It probably doesn’t affect everyone as the skin is created only when using some spells in singleplayer modules made pre-1.69.

I don’t remember this exactly, it is several years since I heard about this last time and the old forums where was this posted are gone, but some script is trying to equip the PC skin after polymorph over and over with very small delay, which then totally messes up the character as each attempt is followed with action cancel.

1 Like

Thx for reply.

The transition scripts are a good bet, (we override nw_g0_transition, but maybe there’s some object that defaults to x0/x2/x3 of same…). Or one of the stock weap spells I didn’t want added…

Unfortunately unless it’s an errant script hook on an object, probably not a patch prospect to be fixed.