Pool of Radiance Remastered Unofficial Patch

I’ve been working on this patch for Pool of Radiance Remastered. The patch could certainly use to be tested. Any volunteers would be welcome. Install instructions and a changelog are in the download.
It fixes issues with the journal, companions can now multi-class, transitions no longer freeze the game when controlling companions, a big combat in chapter 3 no longer starts at the beginning of an important convo, and many other small issues.
My apologies for this patch being a bit large. I had to convert the .mod files into directory format for simplicity reasons. There were same-named files in each .mod that were slightly different from each other. I could have merged some of them, but it was easier to just do the mod conversion.

7 Likes

I’d actually been thinking about replaying this anyway so I’d be happy to take a look.

1 Like

I will give it a go as well. It may be a day or two until I can start though.

1 Like
  1. After you report the killing of the goblin leader to Sasha you are sent to the Adventurers rest area and the Kuto’s Well quest is initiated. If you have not retrieved the Apothecary book or cleared the Ruined Inn in the Slums, those areas are no longer available.

  2. I’ve retrieved the Apothecary book but the Gnome is no longer outside Bitter Blade so I cannot complete that quest. I recall that being a bug in the original as well.

Will try to do more testing soon, weird weekend.

If you have the book, you can still turn-in the book later when the gnome has his shop in the slums.

1 Like

I confirm the gnome is no longer present in module 1, but can be found again in module 2.
I found that two ruined houses (the ones near the well, which are empty) don’t have a working exit: the party jumps out, but the circle indicating where the PC wants to go remains in the area (probably meaning the jump didn’t work - nobody is visible however). I clicked and clicked on the door transition, but had to revert to a previous save.

Speaking of Kutos well: in module 2, the transition is very small (you have to click on a specific point to make it work, and not anywhere on the marker as usual).

1 Like

I can’t seem to replicate that issue. Just to confirm, its the Kuto’s Well area in chapter 1. There are three doors generally west of the well and a fourth door to the northeast of the well. I transitioned without issue in and out of all four of those doors while controlling the main PC, and again while controlling a companion.

Again, on this issue I wasn’t able to replicate. Just to confirm, Kuto’s Well, chapter 2, where you have to sneak through the orcs while wearing the mask of disguise. The area transitions seemed to work fine for me without pixel hunting.

Curious, none of the above doors/transitions were changed through my patching. So it may be some kind of issue that arises only in certain circumstances.

1 Like

Actually, it’s the previous transition (from New Phlan to the Slums).

Since it’s not too far in the campaign, I’ll start a new game and see if that happens again (in which case I’ll upload a save, to check if it comes from the game or from my config).

I tried the NWN2 PoR but was turned off by the first area. The ground was so uneven, in an unnatural way, that it broke my immersion. Could do with a bit of reworking.

Well, I’m afraid I encountered a game-breaking bug. Fourth or fifth time I prevent the orcs from taking Kutos well, and nothing happens after that.
Since there are no transitions (no exits), there must be something in the area not triggered correctly.

DebugMode 1
I wrote a script allowing me the kill the enemies without moving, and this time the giants one of the companions mentioned actually appeared, and when there were dead then a messenger showed up.
With this in mind, I let the PC stand still and not participate in the battle. Unfortunately, that didn’t solve the problem: it looks like the companions walk on a trigger, but since the conditions are not met yet the next wave is not spawned. Apparently, when the current wave is done, the next one doesn’t appear though, probably because of this.

1 Like

OK, tried again, this time asking the party to hold their positions. As for the previous times, Corben advised that giants were coming, but none spawned… I’ll take a look in the toolset and see what could explain this.

Edit:
Well, it appears there’s a timing issue… In the several battles I fought to keep the well, I noticed that sometimes the first line Corben says is about “reinforcements”, although what makes more sense is when he says “we’re under attack”.
I also noticed that as soon as the first orc is slain, the second wave arrives. Not sure if that’s the way it should work, but I’m wondering: what happens if there’s not enough room to spawn the additional enemies? Won’t the engine make them appear in unreachable parts of the area? (there are two in this case).

1 Like

Once you bash the door to Sokol keep you have to use a non–rogue character to enter. Otherwise, a character with any rogue levels will keep trying to pick open door.

Blueprints:
Orc Blades and Curved Orc Blades have two blue prints each. One can be sold the other shows ‘0’ for sale value.

Yarash’s bed in the Pyramid Control Room is useable but cannot be reached because the placeables around it are not walkable.

1 Like

I just finished a playthrough and nothing new seems broken. Most of the problems I ran into were there for previous playthroughs.

The gate to Sokol keep needs to be picked even if the gate is destroyed. If you right click on it you can select use but otherwise a thief will be stuck forever trying to pick the lock. Am I crazy though or did there used to be a part of the Sokol Keep defense where you went on the roof and shot at approaching orcs? I remember it but did not encounter it on this playthrough.

The final fight will repeat itself endlessly with a newly spawned villain if you move around after the cut scene due to a repeating trigger.

Yarash’s bed is a restful bed but is inaccessible.

I think the duplicate orc blades are intentional as the weapon vendor has dialogue about taking one of the blades but not being willing to take any more.

The well defense went smoothly for me and I can’t recreate the problem 4760 ran into. I suppose its possible I keep running over triggers in the right order or something.

The conversation triggers that only occur once now is a fantastic improvement and greatly appreciated.

Thanks for working on this unnofficial patch, Travus. I hope this helps.

2 Likes

Which fight is this referring to?

Improvement: Add a key to Constanica’s cell to the Pirate Captain’s loot. Her just popping through the bars on a convo is a bit hokey.

1 Like

After you kill the dragon and the final cutscene plays you are still left in the game and moving around at all causes a new dragon to spawn and its pre-fight dialogue to repeat.

2 Likes

I’ve updated the UOP with the bugs you all have mentioned, except for the orc blade blueprints and the issue 4760 mentioned (I can’t seem to replicate that issue). I also went through the entire campaign again and found a few more minor bugs that are now fixed.

6 Likes