PRC+Aielund Saga Question


So, I installed the PRC 3.8 in the Aielund Saga (wonderful module, I was having lots of fun) and the PRC was working fine at first glance, aside from the ocasional merchant calling me a Halfling even though I was an Aasimar. I was able to go as far as the Barbarian Threat quest, but the Mayor wouldn’t give me the quest, saying I still had business in the Ranges. I looked in the toolset and apprently the PC needs to be lvl5 to procceed, I was lvl4. Then I noticed I wasn’t getting any XP from kills! With a little research I found someone who fixed it for him, something to do with the “nw_c2_default7” script missing the “ExecuteScript(“sha_xpsystem”, OBJECT_SELF);” line. I tried to fix it, but I have 0 knowledge in scripting. I tried to edit the script in the toolset and just add the line like it is in the “original” file and save it with a different name, but it didn’t worked. I also tried to extract the script and add it in the hak with NWNPACKER, but it corrupt the file for some reason.

So, can a script savant help me here? I have no clue how to proceed.

Thanks a bunch!

EDIT: NVM, I used nwhak instead of the nwnpacker and it worked. Don’t know how to delete or lock this!